summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-02-03 09:13:06 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-02-03 09:13:06 +0000
commit2ecb66fa4da83b21be4e161ad53cf83f13366812 (patch)
tree0e8b40ef439922aa78dc609c4c0e4af1cf11f89f /games-arcade
parentwhitespace (diff)
downloadgentoo-2-2ecb66fa4da83b21be4e161ad53cf83f13366812.tar.gz
gentoo-2-2ecb66fa4da83b21be4e161ad53cf83f13366812.tar.bz2
gentoo-2-2ecb66fa4da83b21be4e161ad53cf83f13366812.zip
Don't use egamesinstall
(Portage version: 2.1.2-r6)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/burgerspace/ChangeLog8
-rw-r--r--games-arcade/burgerspace/burgerspace-1.8.1.ebuild26
-rw-r--r--games-arcade/burgerspace/files/burgerspace-1.8.1-build.patch42
3 files changed, 62 insertions, 14 deletions
diff --git a/games-arcade/burgerspace/ChangeLog b/games-arcade/burgerspace/ChangeLog
index 876f9caac296..f4525ad862d8 100644
--- a/games-arcade/burgerspace/ChangeLog
+++ b/games-arcade/burgerspace/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/burgerspace
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/burgerspace/ChangeLog,v 1.6 2006/09/20 16:41:27 blubb Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/burgerspace/ChangeLog,v 1.7 2007/02/03 09:13:06 nyhm Exp $
+
+ 03 Feb 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/burgerspace-1.8.1-build.patch, burgerspace-1.8.1.ebuild:
+ Don't use egamesinstall
20 Sep 2006; <blubb@gentoo.org> burgerspace-1.8.1.ebuild:
stable on amd64
diff --git a/games-arcade/burgerspace/burgerspace-1.8.1.ebuild b/games-arcade/burgerspace/burgerspace-1.8.1.ebuild
index 65a6f1c0e637..9101b6f14530 100644
--- a/games-arcade/burgerspace/burgerspace-1.8.1.ebuild
+++ b/games-arcade/burgerspace/burgerspace-1.8.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/burgerspace/burgerspace-1.8.1.ebuild,v 1.7 2006/09/20 16:41:27 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/burgerspace/burgerspace-1.8.1.ebuild,v 1.8 2007/02/03 09:13:06 nyhm Exp $
-inherit games
+inherit autotools eutils games
DESCRIPTION="Clone of the 1982 BurgerTime video game by Data East"
HOMEPAGE="http://www3.sympatico.ca/sarrazip/dev/burgerspace.html"
@@ -13,18 +13,20 @@ SLOT="0"
KEYWORDS="amd64 ppc ~sparc x86"
IUSE=""
-DEPEND=">=media-libs/libsdl-1.2.4
- >=media-libs/sdl-image-1.2
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
media-libs/sdl-mixer
dev-games/flatzebra"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ AT_M4DIR=macros eautoreconf
+}
+
src_install() {
- egamesinstall \
- docdir="${D}/usr/share/doc/${PF}" \
- desktopentrydir="${D}/usr/share/applications" \
- pixmapdir="${D}/usr/share/pixmaps" \
- || die
- rm -f "${D}/usr/share/doc/${PF}"/{COPYING,INSTALL}
- prepalldocs
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS HACKING NEWS README THANKS TODO
prepgamesdirs
}
diff --git a/games-arcade/burgerspace/files/burgerspace-1.8.1-build.patch b/games-arcade/burgerspace/files/burgerspace-1.8.1-build.patch
new file mode 100644
index 000000000000..a432a04eb60f
--- /dev/null
+++ b/games-arcade/burgerspace/files/burgerspace-1.8.1-build.patch
@@ -0,0 +1,42 @@
+--- Makefile.am
++++ Makefile.am
+@@ -4,15 +4,6 @@
+
+ man_MANS = doc/burgerspace.6
+
+-docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)
+-doc_DATA = \
+- AUTHORS \
+- COPYING \
+- INSTALL \
+- NEWS \
+- README \
+- THANKS \
+- TODO
+
+ RPMBUILD = rpmbuild
+ rpm: dist
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -33,10 +33,10 @@
+ PKGSOUNDDIR=$(srcdir)/sounds ./$(PACKAGE)
+
+
+-desktopentrydir = $(datadir)/applications
++desktopentrydir = /usr/share/applications
+ desktopentry_DATA = $(PACKAGE).desktop
+
+-pixmapdir = $(datadir)/pixmaps
++pixmapdir = /usr/share/pixmaps
+ pixmap_DATA = images/$(PACKAGE).png
+
+
+@@ -152,7 +152,7 @@
+ images/digit8.xpm \
+ images/digit9.xpm
+
+-pkgsounddir = $(datadir)/sounds/$(PACKAGE)
++pkgsounddir = $(pkgdatadir)
+ pkgsound_DATA = \
+ sounds/ingredient-bounces.wav \
+ sounds/ingredient-in-plate.wav \