summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:22 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:22 +0000
commitf0759f77429dfcff11fdeb040d0553dd1e8e0bd8 (patch)
treebc451cfc4f19d245b0c6a7f10e547fdc2006db52 /games-arcade/xtux
parentaction games ! (diff)
downloadgentoo-2-f0759f77429dfcff11fdeb040d0553dd1e8e0bd8.tar.gz
gentoo-2-f0759f77429dfcff11fdeb040d0553dd1e8e0bd8.tar.bz2
gentoo-2-f0759f77429dfcff11fdeb040d0553dd1e8e0bd8.zip
arcade games !
Diffstat (limited to 'games-arcade/xtux')
-rw-r--r--games-arcade/xtux/ChangeLog18
-rw-r--r--games-arcade/xtux/Manifest3
-rw-r--r--games-arcade/xtux/files/digest-xtux-200303061
-rw-r--r--games-arcade/xtux/xtux-20030306.ebuild38
4 files changed, 60 insertions, 0 deletions
diff --git a/games-arcade/xtux/ChangeLog b/games-arcade/xtux/ChangeLog
new file mode 100644
index 000000000000..44c8b0266084
--- /dev/null
+++ b/games-arcade/xtux/ChangeLog
@@ -0,0 +1,18 @@
+# ChangeLog for app-games/xtux
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xtux/ChangeLog,v 1.1 2003/09/10 19:29:22 vapier Exp $
+
+ 28 Jun 2003; <msterret@gentoo.org> xtux-20030306.ebuild:
+ use sed -i and emake
+
+*xtux-20030306 (25 May 2003)
+
+ 21 Jun 2003; Mike Frysinger <vapier@gentoo.org> :
+ Add custom CFLAGS and games.eclass support.
+
+ 12 Jun 2003; Seemant Kulleen <seemant@gentoo.org> xtux-20030306.ebuild:
+ xfree provides xpm
+
+ 25 May 2003; Jon Portnoy <avenj@gentoo.org> xtux-20030306.ebuild :
+ Initial import. Ebuild by me, myself, and I, working in full
+ cooperation with each other.
diff --git a/games-arcade/xtux/Manifest b/games-arcade/xtux/Manifest
new file mode 100644
index 000000000000..120e2005e935
--- /dev/null
+++ b/games-arcade/xtux/Manifest
@@ -0,0 +1,3 @@
+MD5 6c3d71ef5a11ed381e6be30ec4128bbd ChangeLog 683
+MD5 60f8fc7912b235efd6d17b75df75955c xtux-20030306.ebuild 892
+MD5 ae206f62d4928ea9a2064d36dea9d6b5 files/digest-xtux-20030306 70
diff --git a/games-arcade/xtux/files/digest-xtux-20030306 b/games-arcade/xtux/files/digest-xtux-20030306
new file mode 100644
index 000000000000..2d1ffce078a4
--- /dev/null
+++ b/games-arcade/xtux/files/digest-xtux-20030306
@@ -0,0 +1 @@
+MD5 6ca5d3b48c30411d1a64b4316d5cf6a9 xtux-src-20030306.tar.gz 1640928
diff --git a/games-arcade/xtux/xtux-20030306.ebuild b/games-arcade/xtux/xtux-20030306.ebuild
new file mode 100644
index 000000000000..28df4eab0d7a
--- /dev/null
+++ b/games-arcade/xtux/xtux-20030306.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xtux/xtux-20030306.ebuild,v 1.1 2003/09/10 19:29:22 vapier Exp $
+
+inherit games
+
+DESCRIPTION="Multiplayer Gauntlet-style arcade game"
+HOMEPAGE="http://xtux.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xtux/xtux-src-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="virtual/x11
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ for f in src/{client,common,server}/Makefile ; do
+ sed -i \
+ -e "s:-g -Wall -O2:${CFLAGS}:" ${f} || \
+ die "sed ${F} failed"
+ done
+ emake DATADIR=${GAMES_DATADIR}/xtux/data || die
+}
+
+src_install () {
+ dogamesbin xtux tux_serv
+
+ dodir ${GAMES_DATADIR}/xtux
+ cp -r data ${D}/${GAMES_DATADIR}/xtux/
+
+ dodoc AUTHORS CHANGELOG COPYING README README.GGZ doc/*
+
+ prepgamesdirs
+}