summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-09-03 02:10:04 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-09-03 02:10:04 +0000
commit7818b512d0b34819da296d21673fb7cab643c40f (patch)
tree28b25d690e404dac1c8725b282ced54611621b87 /games-arcade/xtux
parentVersion bump (diff)
downloadgentoo-2-7818b512d0b34819da296d21673fb7cab643c40f.tar.gz
gentoo-2-7818b512d0b34819da296d21673fb7cab643c40f.tar.bz2
gentoo-2-7818b512d0b34819da296d21673fb7cab643c40f.zip
add particle patch from Albert Zeyer (bug #236469)
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-arcade/xtux')
-rw-r--r--games-arcade/xtux/ChangeLog8
-rw-r--r--games-arcade/xtux/files/xtux-20030306-particles.patch30
-rw-r--r--games-arcade/xtux/xtux-20030306.ebuild13
3 files changed, 44 insertions, 7 deletions
diff --git a/games-arcade/xtux/ChangeLog b/games-arcade/xtux/ChangeLog
index c0bdfe406952..0bcfc7da0a39 100644
--- a/games-arcade/xtux/ChangeLog
+++ b/games-arcade/xtux/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/xtux
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/xtux/ChangeLog,v 1.10 2006/12/01 20:38:49 wolf31o2 Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xtux/ChangeLog,v 1.11 2008/09/03 02:10:03 mr_bones_ Exp $
+
+ 03 Sep 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/xtux-20030306-particles.patch, xtux-20030306.ebuild:
+ add particle patch from Albert Zeyer (bug #236469)
01 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org> xtux-20030306.ebuild:
Removing old virtual/x11 dependency.
diff --git a/games-arcade/xtux/files/xtux-20030306-particles.patch b/games-arcade/xtux/files/xtux-20030306-particles.patch
new file mode 100644
index 000000000000..9a340821dd6e
--- /dev/null
+++ b/games-arcade/xtux/files/xtux-20030306-particles.patch
@@ -0,0 +1,30 @@
+diff -u -r xtux.old/src/client/particle.c xtux/src/client/particle.c
+--- xtux.old/src/client/particle.c 2008-09-02 20:34:24.000000000 +0200
++++ xtux/src/client/particle.c 2008-09-02 20:35:40.000000000 +0200
+@@ -340,11 +340,11 @@
+ ptl->pos[i].y = src_y;
+ d = dir + 128;
+ d += i%SHARD_ANGLE - SHARD_ANGLE/2;
+- ptl->vel[i].x = sin_lookup[dir + 64 + rand()%64] * SHARD_EXP_VEL;
+- ptl->vel[i].y = -cos_lookup[dir + 64 + rand()%64] * SHARD_EXP_VEL;
++ ptl->vel[i].x = sin_lookup[(dir + 64 + rand()%64) % DEGREES] * SHARD_EXP_VEL;
++ ptl->vel[i].y = -cos_lookup[(dir + 64 + rand()%64) % DEGREES] * SHARD_EXP_VEL;
+ vel = SHARD_MIN_VEL + (SHARD_MAX_VEL*rand()/(RAND_MAX+SHARD_MIN_VEL));
+- ptl->vel[i].x += vel * sin_lookup[d] * 10;
+- ptl->vel[i].y += vel * -cos_lookup[d] * 10;
++ ptl->vel[i].x += vel * sin_lookup[d % DEGREES] * 10;
++ ptl->vel[i].y += vel * -cos_lookup[d % DEGREES] * 10;
+ }
+
+ ptl = particles_new(color2, PTL_TOP, num_sh2);
+@@ -357,8 +357,8 @@
+ ptl->vel[i].x = sin_lookup[rand()%256] * SHARD_EXP_VEL;
+ ptl->vel[i].y = -cos_lookup[rand()%256] * SHARD_EXP_VEL;
+ vel = SHARD_MIN_VEL + (SHARD_MAX_VEL*rand()/(RAND_MAX+SHARD_MIN_VEL));
+- ptl->vel[i].x += vel * sin_lookup[d] * 20;
+- ptl->vel[i].y += vel * -cos_lookup[d] * 20;
++ ptl->vel[i].x += vel * sin_lookup[d % DEGREES] * 20;
++ ptl->vel[i].y += vel * -cos_lookup[d % DEGREES] * 20;
+ }
+
+ /* "Extra" particles (ie bullet holes) */
diff --git a/games-arcade/xtux/xtux-20030306.ebuild b/games-arcade/xtux/xtux-20030306.ebuild
index ead482809a98..a25f581f5121 100644
--- a/games-arcade/xtux/xtux-20030306.ebuild
+++ b/games-arcade/xtux/xtux-20030306.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/xtux/xtux-20030306.ebuild,v 1.12 2006/12/01 20:38:49 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xtux/xtux-20030306.ebuild,v 1.13 2008/09/03 02:10:03 mr_bones_ Exp $
-inherit games
+inherit eutils games
DESCRIPTION="Multiplayer Gauntlet-style arcade game"
HOMEPAGE="http://xtux.sourceforge.net/"
@@ -28,6 +28,7 @@ src_unpack() {
-e "s:./tux_serv:tux_serv:" \
src/client/menu.c \
|| die "sed failed"
+ epatch "${FILESDIR}/${P}-particles.patch"
}
src_compile() {
@@ -36,8 +37,10 @@ src_compile() {
src_install () {
dogamesbin xtux tux_serv || die "dogamesbin failed"
- dodir "${GAMES_DATADIR}/xtux"
- cp -r data "${D}/${GAMES_DATADIR}/xtux/" || die "cp failed"
+ insinto "${GAMES_DATADIR}/xtux"
+ doins -r data/ || die "doins failed"
dodoc AUTHORS CHANGELOG README README.GGZ doc/*
+ newicon data/images/icon.xpm ${PN}.xpm
+ make_desktop_entry xtux "Xtux" /usr/share/icons/${PN}.xpm
prepgamesdirs
}