summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-16 19:17:06 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-16 19:17:06 +0000
commitf65d4d45d194c3c4c8c5719edb68882f76288429 (patch)
treec9fe2de58c702d503bef59a4a4af30732d41525d /games-arcade/xboing
parentStable on amd64 wrt bug #341311 (diff)
downloadgentoo-2-f65d4d45d194c3c4c8c5719edb68882f76288429.tar.gz
gentoo-2-f65d4d45d194c3c4c8c5719edb68882f76288429.tar.bz2
gentoo-2-f65d4d45d194c3c4c8c5719edb68882f76288429.zip
Respect LDFLAGS. Bug #334643
(Portage version: 2.1.9.14/cvs/Linux i686)
Diffstat (limited to 'games-arcade/xboing')
-rw-r--r--games-arcade/xboing/ChangeLog7
-rw-r--r--games-arcade/xboing/xboing-2.4-r1.ebuild15
2 files changed, 14 insertions, 8 deletions
diff --git a/games-arcade/xboing/ChangeLog b/games-arcade/xboing/ChangeLog
index 172c9f33fac2..8b2854eaa14b 100644
--- a/games-arcade/xboing/ChangeLog
+++ b/games-arcade/xboing/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/xboing
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/xboing/ChangeLog,v 1.12 2008/03/08 00:04:54 wolf31o2 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xboing/ChangeLog,v 1.13 2010/10/16 19:17:06 tupone Exp $
+
+ 16 Oct 2010; Tupone Alfredo <tupone@gentoo.org> xboing-2.4-r1.ebuild:
+ Respect LDFLAGS. Bug #334643 by flameeyes@gentoo.org
08 Mar 2008; Chris Gianelloni <wolf31o2@gentoo.org> xboing-2.4-r1.ebuild:
QA cleanup: Fix quoting.
diff --git a/games-arcade/xboing/xboing-2.4-r1.ebuild b/games-arcade/xboing/xboing-2.4-r1.ebuild
index c3e891bb5659..9ce77852ec65 100644
--- a/games-arcade/xboing/xboing-2.4-r1.ebuild
+++ b/games-arcade/xboing/xboing-2.4-r1.ebuild
@@ -1,6 +1,7 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/xboing/xboing-2.4-r1.ebuild,v 1.11 2008/03/08 00:04:54 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xboing/xboing-2.4-r1.ebuild,v 1.12 2010/10/16 19:17:06 tupone Exp $
+EAPI=2
inherit eutils games
@@ -22,21 +23,23 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${WORKDIR}"/xboing-${PV}-debian.patch
sed -i '/^#include/s:xpm\.h:X11/xpm.h:' *.c
}
-src_compile() {
+src_configure() {
xmkmf -a || die
sed -i \
-e "s:GENTOO_VER:${PF/${PN}-/}:" \
Imakefile
+}
+
+src_compile() {
emake \
CXXOPTIONS="${CXXFLAGS}" \
CDEBUGFLAGS="${CFLAGS}" \
+ LOCAL_LDFLAGS="${LDFLAGS}" \
XBOING_DIR=${GAMES_DATADIR}/${PN} \
|| die
}