summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-01-27 14:42:16 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-01-27 14:42:16 +0000
commit4ef367e8ccf46597094ce69c8eda816bd3806ae6 (patch)
tree30bed4cd0969d81942ffac2507c7aafa16a6576d /games-arcade/wop
parentversion bump (diff)
downloadgentoo-2-4ef367e8ccf46597094ce69c8eda816bd3806ae6.tar.gz
gentoo-2-4ef367e8ccf46597094ce69c8eda816bd3806ae6.tar.bz2
gentoo-2-4ef367e8ccf46597094ce69c8eda816bd3806ae6.zip
Fix gcc-4.3 bug #253496
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r8 x86_64)
Diffstat (limited to 'games-arcade/wop')
-rw-r--r--games-arcade/wop/ChangeLog8
-rw-r--r--games-arcade/wop/files/wop-0.4.3-gcc43.patch31
-rw-r--r--games-arcade/wop/wop-0.4.3-r1.ebuild7
3 files changed, 41 insertions, 5 deletions
diff --git a/games-arcade/wop/ChangeLog b/games-arcade/wop/ChangeLog
index 2eca10b983d0..8e9d50d48a19 100644
--- a/games-arcade/wop/ChangeLog
+++ b/games-arcade/wop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/wop
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/wop/ChangeLog,v 1.8 2008/06/22 15:32:17 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/wop/ChangeLog,v 1.9 2009/01/27 14:42:16 tupone Exp $
+
+ 27 Jan 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/wop-0.4.3-gcc43.patch, wop-0.4.3-r1.ebuild:
+ Fix gcc-4.3 bug #253496 by Erik Hahn <erik_hahn@gmx.de>
22 Jun 2008; Markus Meier <maekke@gentoo.org> wop-0.4.3-r1.ebuild:
x86 stable, bug #227645
diff --git a/games-arcade/wop/files/wop-0.4.3-gcc43.patch b/games-arcade/wop/files/wop-0.4.3-gcc43.patch
new file mode 100644
index 000000000000..59aee2a665dd
--- /dev/null
+++ b/games-arcade/wop/files/wop-0.4.3-gcc43.patch
@@ -0,0 +1,31 @@
+--- src/scusibot.cpp.old 2009-01-27 15:22:39.000000000 +0100
++++ src/scusibot.cpp 2009-01-27 15:23:10.000000000 +0100
+@@ -5,6 +5,7 @@
+ #include "stationarygun.hpp"
+ #include "global.hpp"
+ #include <vector>
++#include <algorithm>
+
+ ScusiBot::ScusiBot()
+ : m_event( Event::EMPTY ), m_count( 0 ), m_state( IDLE ) {
+--- src/spriteset.cpp.old 2009-01-27 15:26:39.000000000 +0100
++++ src/spriteset.cpp 2009-01-27 15:27:51.000000000 +0100
+@@ -2,6 +2,7 @@
+
+ #include "spriteset.hpp"
+ #include "global.hpp"
++#include "sprite.hpp"
+
+ /**********************************************************/
+
+@@ -17,6 +18,9 @@
+ #endif // SUPPRESS_COLORING
+ #endif // BLACK_
+
++/* force creation of an implementation of SpriteSet<Sprite> */
++static SpriteSet<Sprite> foo;
++
+ /**********************************************************/
+
+ template <class T>
+
diff --git a/games-arcade/wop/wop-0.4.3-r1.ebuild b/games-arcade/wop/wop-0.4.3-r1.ebuild
index a8d6ba7c8686..fe3a6a4301d3 100644
--- a/games-arcade/wop/wop-0.4.3-r1.ebuild
+++ b/games-arcade/wop/wop-0.4.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/wop/wop-0.4.3-r1.ebuild,v 1.5 2008/06/22 15:32:17 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/wop/wop-0.4.3-r1.ebuild,v 1.6 2009/01/27 14:42:16 tupone Exp $
inherit eutils toolchain-funcs games
@@ -39,7 +39,8 @@ src_unpack() {
-e "s:^data =.*$:data = ${GAMES_DATADIR}/${PN}:" \
woprc \
|| die "sed failed"
- epatch "${FILESDIR}"/${P}-Makefile.patch
+ epatch "${FILESDIR}"/${P}-Makefile.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
}
src_compile() {