summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-01-05 15:18:24 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-01-05 15:18:24 +0000
commit416637809c62b628546b9bb95278e1e0dac74271 (patch)
treeb6ed3260821dd4ea3969689b18ced88bd605491f /games-arcade/wop
parentBump latest alpha; also drop older versions. New version builds tests in para... (diff)
downloadgentoo-2-416637809c62b628546b9bb95278e1e0dac74271.tar.gz
gentoo-2-416637809c62b628546b9bb95278e1e0dac74271.tar.bz2
gentoo-2-416637809c62b628546b9bb95278e1e0dac74271.zip
Fix build with gcc-4.4.2. Bug #298900
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-arcade/wop')
-rw-r--r--games-arcade/wop/ChangeLog8
-rw-r--r--games-arcade/wop/files/wop-0.4.3-gcc43.patch49
2 files changed, 31 insertions, 26 deletions
diff --git a/games-arcade/wop/ChangeLog b/games-arcade/wop/ChangeLog
index 8e9d50d48a19..dc49b5f32ef9 100644
--- a/games-arcade/wop/ChangeLog
+++ b/games-arcade/wop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/wop
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/wop/ChangeLog,v 1.9 2009/01/27 14:42:16 tupone Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/wop/ChangeLog,v 1.10 2010/01/05 15:18:24 tupone Exp $
+
+ 05 Jan 2010; Tupone Alfredo <tupone@gentoo.org>
+ files/wop-0.4.3-gcc43.patch:
+ Fix build with gcc-4.4.2. Bug #298900 by flameeyes@gentoo.org
27 Jan 2009; Alfredo Tupone <tupone@gentoo.org>
+files/wop-0.4.3-gcc43.patch, wop-0.4.3-r1.ebuild:
diff --git a/games-arcade/wop/files/wop-0.4.3-gcc43.patch b/games-arcade/wop/files/wop-0.4.3-gcc43.patch
index 59aee2a665dd..903a97ba92ce 100644
--- a/games-arcade/wop/files/wop-0.4.3-gcc43.patch
+++ b/games-arcade/wop/files/wop-0.4.3-gcc43.patch
@@ -1,31 +1,32 @@
---- src/scusibot.cpp.old 2009-01-27 15:22:39.000000000 +0100
-+++ src/scusibot.cpp 2009-01-27 15:23:10.000000000 +0100
+--- src/scusibot.cpp.old 2010-01-05 15:41:23.000000000 +0100
++++ src/scusibot.cpp 2010-01-05 15:41:46.000000000 +0100
@@ -5,6 +5,7 @@
#include "stationarygun.hpp"
#include "global.hpp"
#include <vector>
+#include <algorithm>
-
+
ScusiBot::ScusiBot()
- : m_event( Event::EMPTY ), m_count( 0 ), m_state( IDLE ) {
---- src/spriteset.cpp.old 2009-01-27 15:26:39.000000000 +0100
-+++ src/spriteset.cpp 2009-01-27 15:27:51.000000000 +0100
-@@ -2,6 +2,7 @@
-
- #include "spriteset.hpp"
- #include "global.hpp"
-+#include "sprite.hpp"
-
+ : m_event( Event::EMPTY ), m_count( 0 ), m_state( IDLE ) {
+--- src/gameinfowindow.cpp.old 2010-01-05 15:45:09.000000000 +0100
++++ src/gameinfowindow.cpp 2010-01-05 15:46:08.000000000 +0100
+@@ -10,6 +10,8 @@
+ #include "avatarworm.hpp"
+ #include "wopsprites.hpp"
+ #include "wopsprites.cpp"
++#include "spriteset.cpp"
++#include "spritesequence.cpp"
+ #include "scorekeeper.hpp"
+ #include "wopgui.hpp"
+
+--- src/map.cpp.old 2010-01-05 15:46:35.000000000 +0100
++++ src/map.cpp 2010-01-05 15:47:06.000000000 +0100
+@@ -9,6 +9,8 @@
+ #include "world.hpp"
+ #include "wopsettings.hpp"
+ #include "objectpaths.hpp"
++#include "spriteset.cpp"
++#include "spritesequence.cpp"
+
/**********************************************************/
-
-@@ -17,6 +18,9 @@
- #endif // SUPPRESS_COLORING
- #endif // BLACK_
-
-+/* force creation of an implementation of SpriteSet<Sprite> */
-+static SpriteSet<Sprite> foo;
-+
- /**********************************************************/
-
- template <class T>
-
+