summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-01-19 09:18:08 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-01-19 09:18:08 +0000
commit335fa9f2612eaa3a8384a7316fcdb92195e4af01 (patch)
tree2c70a5af7a647b8a0d7a41e6f605b386bcee3e99 /games-arcade/wop
parentAdd pkgconfig dep, bug #206265 (diff)
downloadgentoo-2-335fa9f2612eaa3a8384a7316fcdb92195e4af01.tar.gz
gentoo-2-335fa9f2612eaa3a8384a7316fcdb92195e4af01.tar.bz2
gentoo-2-335fa9f2612eaa3a8384a7316fcdb92195e4af01.zip
Add makedepend dep, bug #206268
(Portage version: 2.1.4)
Diffstat (limited to 'games-arcade/wop')
-rw-r--r--games-arcade/wop/ChangeLog7
-rw-r--r--games-arcade/wop/wop-0.4.3-r1.ebuild44
2 files changed, 23 insertions, 28 deletions
diff --git a/games-arcade/wop/ChangeLog b/games-arcade/wop/ChangeLog
index 4b8fca73ab1a..d67f0c221a20 100644
--- a/games-arcade/wop/ChangeLog
+++ b/games-arcade/wop/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/wop
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/wop/ChangeLog,v 1.5 2007/04/27 17:20:57 drizzt Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/wop/ChangeLog,v 1.6 2008/01/19 09:18:08 nyhm Exp $
+
+ 19 Jan 2008; Tristan Heaven <nyhm@gentoo.org> wop-0.4.3-r1.ebuild:
+ Add makedepend dep, bug #206268
*wop-0.4.3-r1 (27 Apr 2007)
diff --git a/games-arcade/wop/wop-0.4.3-r1.ebuild b/games-arcade/wop/wop-0.4.3-r1.ebuild
index 6090b83dd181..4adc92ed68db 100644
--- a/games-arcade/wop/wop-0.4.3-r1.ebuild
+++ b/games-arcade/wop/wop-0.4.3-r1.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/wop/wop-0.4.3-r1.ebuild,v 1.2 2007/06/12 13:00:00 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/wop/wop-0.4.3-r1.ebuild,v 1.3 2008/01/19 09:18:08 nyhm Exp $
inherit eutils toolchain-funcs games
MY_DATA_V="2005-12-21"
MY_DATA_P="${PN}data-${MY_DATA_V}"
-
DESCRIPTION="Worms of Prey - A multi-player, real-time clone of Worms"
HOMEPAGE="http://wormsofprey.org/"
SRC_URI="http://wormsofprey.org/download/${P}-src.tar.bz2
@@ -17,31 +16,29 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-fbsd"
IUSE=""
-DEPEND="sys-libs/zlib
- >=media-libs/libsdl-1.2
- >=media-libs/sdl-net-1.2.5
- >=media-libs/sdl-image-1.2
- >=media-libs/sdl-mixer-1.2
- >=media-libs/sdl-ttf-2.0"
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-net
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf"
+DEPEND="${RDEPEND}
+ x11-misc/makedepend"
MY_DATA_S=${WORKDIR}/${MY_DATA_P}
src_unpack() {
unpack ${A}
-
+ cd "${S}"
# correct path to global woprc
sed -i \
-e "s:/etc/woprc:${GAMES_SYSCONFDIR}/woprc:g" \
- "${S}/src/wopsettings.cpp" \
+ src/wopsettings.cpp \
|| die "sed failed"
-
# patch global woprc with the correct data files location and install it
sed -i \
-e "s:^data =.*$:data = ${GAMES_DATADIR}/${PN}:" \
- "${S}/woprc" \
+ woprc \
|| die "sed failed"
-
- cd "${S}"
epatch "${FILESDIR}"/${P}-Makefile.patch
}
@@ -51,17 +48,12 @@ src_compile() {
src_install() {
dogamesbin bin/${PN} || die "dogamesbin failed"
-
- newicon "${MY_DATA_S}/images/misc/icons/wop16.png" ${PN}.png
- make_desktop_entry wop "Worms of Prey"
-
- insinto "${GAMES_DATADIR}/${PN}"
- doins -r "${MY_DATA_S}"/* || die "doins failed"
-
- dodoc AUTHORS ChangeLog PACKAGE_MAINTAINERS README{,-Libraries.txt} REVIEWS
-
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r "${MY_DATA_S}"/* || die "doins data failed"
insinto "${GAMES_SYSCONFDIR}"
- doins "${S}/woprc" || die "doins failed"
-
+ doins woprc || die "doins woprc failed"
+ newicon "${MY_DATA_S}"/images/misc/icons/wop16.png ${PN}.png
+ make_desktop_entry wop "Worms of Prey"
+ dodoc AUTHORS ChangeLog README{,-Libraries.txt} REVIEWS
prepgamesdirs
}