summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-02-26 22:21:52 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-02-26 22:21:52 +0000
commitc2dc983da29d767f233d4f77cd20d64396c74855 (patch)
tree85d09da25dac580cebc66ff004f5ac3052fb83f9 /games-arcade/whichwayisup
parentVersion bump and old version cleanup (diff)
downloadgentoo-2-c2dc983da29d767f233d4f77cd20d64396c74855.tar.gz
gentoo-2-c2dc983da29d767f233d4f77cd20d64396c74855.tar.bz2
gentoo-2-c2dc983da29d767f233d4f77cd20d64396c74855.zip
Version bump, closes bug #209986
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-arcade/whichwayisup')
-rw-r--r--games-arcade/whichwayisup/ChangeLog8
-rw-r--r--games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/games-arcade/whichwayisup/ChangeLog b/games-arcade/whichwayisup/ChangeLog
index f8fc27e19e19..84aac030b1df 100644
--- a/games-arcade/whichwayisup/ChangeLog
+++ b/games-arcade/whichwayisup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/whichwayisup
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/whichwayisup/ChangeLog,v 1.6 2008/02/20 18:42:53 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/whichwayisup/ChangeLog,v 1.7 2008/02/26 22:21:52 coldwind Exp $
+
+*whichwayisup-0.7.9 (26 Feb 2008)
+
+ 26 Feb 2008; Santiago M. Mola <coldwind@gentoo.org>
+ +whichwayisup-0.7.9.ebuild:
+ Version bump, closes bug #209986
20 Feb 2008; nixnut <nixnut@gentoo.org> whichwayisup-0.7.0.ebuild:
Added ~ppc wrt bug 207910
diff --git a/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild b/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild
new file mode 100644
index 000000000000..97fc6cba6e69
--- /dev/null
+++ b/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild,v 1.1 2008/02/26 22:21:52 coldwind Exp $
+
+NEED_PYTHON="2.4"
+
+inherit eutils python games
+
+MY_PV=${PV//./}
+MY_P=${PN}_b${MY_PV}
+DESCRIPTION="A traditional and challenging 2D platformer game with a slight rotational twist"
+HOMEPAGE="http://hectigo.net/puskutraktori/whichwayisup/"
+SRC_URI="http://hectigo.net/puskutraktori/whichwayisup/${MY_P}.zip"
+
+LICENSE="GPL-2 CCPL-Attribution-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=dev-python/pygame-1.6"
+# media-libs/sdl-image[png]
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s:libdir\ =\ .*:libdir\ =\ \"$(games_get_libdir)/${PN}\":" \
+ run_game.py || die "Changing library path failed"
+ sed -i -e "s:data_dir\ =\ .*:data_dir\ =\ \"${GAMES_DATADIR}/${PN}\":" \
+ lib/data.py || die "Changing data path failed"
+ rm data/pictures/Thumbs.db
+ }
+
+src_install() {
+ newgamesbin run_game.py ${PN} || die "newgamesbin failed"
+
+ insinto "$(games_get_libdir)/${PN}"
+ doins lib/*.py || die "doins lib failed"
+
+ dodoc README.txt changelog.txt
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data/* || die "doins data failed"
+
+ doicon "${FILESDIR}"/${PN}-32.xpm
+ make_desktop_entry ${PN} "Which Way Is Up?" ${PN}-32.xpm
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ python_mod_optimize "$(games_get_libdir)/${PN}"
+ games_pkg_postinst
+}
+
+pkg_postrm() {
+ python_mod_cleanup "$(games_get_libdir)/${PN}"
+}