summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-10-26 05:53:21 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-10-26 05:53:21 +0000
commitb6df621a9b7e5736207c88760d8cab123be57519 (patch)
treedddf6e7239997e35f4559d341d210160497adea4 /games-arcade/whichwayisup
parentVersion bump. (diff)
downloadgentoo-2-b6df621a9b7e5736207c88760d8cab123be57519.tar.gz
gentoo-2-b6df621a9b7e5736207c88760d8cab123be57519.tar.bz2
gentoo-2-b6df621a9b7e5736207c88760d8cab123be57519.zip
EAPI=2
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-arcade/whichwayisup')
-rw-r--r--games-arcade/whichwayisup/ChangeLog6
-rw-r--r--games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild27
2 files changed, 19 insertions, 14 deletions
diff --git a/games-arcade/whichwayisup/ChangeLog b/games-arcade/whichwayisup/ChangeLog
index 306acaf5d66b..3d90a9f4b6a3 100644
--- a/games-arcade/whichwayisup/ChangeLog
+++ b/games-arcade/whichwayisup/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/whichwayisup
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/whichwayisup/ChangeLog,v 1.14 2009/10/25 17:11:06 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/whichwayisup/ChangeLog,v 1.15 2009/10/26 05:53:21 mr_bones_ Exp $
+
+ 26 Oct 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ whichwayisup-0.7.9.ebuild:
+ EAPI=2
25 Oct 2009; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove coldwind from metadata.xml (#181764)
diff --git a/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild b/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild
index 808ce96a5a5f..862bbc1f63f3 100644
--- a/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild
+++ b/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild,v 1.7 2008/06/22 15:34:39 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild,v 1.8 2009/10/26 05:53:21 mr_bones_ Exp $
NEED_PYTHON="2.4"
-
+EAPI=2
inherit eutils python games
MY_PV=${PV//./}
@@ -19,17 +19,18 @@ IUSE=""
DEPEND="app-arch/unzip"
RDEPEND=">=dev-python/pygame-1.6"
-# media-libs/sdl-image[png]
S=${WORKDIR}/${PN}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i -e "s:libdir\ =\ .*:libdir\ =\ \"$(games_get_libdir)/${PN}\":" \
- run_game.py || die "Changing library path failed"
- sed -i -e "s:data_dir\ =\ .*:data_dir\ =\ \"${GAMES_DATADIR}/${PN}\":" \
- lib/data.py || die "Changing data path failed"
+src_prepare() {
+ sed -i \
+ -e "s:libdir\ =\ .*:libdir\ =\ \"$(games_get_libdir)/${PN}\":" \
+ run_game.py \
+ || die "Changing library path failed"
+ sed -i \
+ -e "s:data_dir\ =\ .*:data_dir\ =\ \"${GAMES_DATADIR}/${PN}\":" \
+ lib/data.py \
+ || die "Changing data path failed"
rm data/pictures/Thumbs.db
}
@@ -44,8 +45,8 @@ src_install() {
insinto "${GAMES_DATADIR}/${PN}"
doins -r data/* || die "doins data failed"
- doicon "${FILESDIR}"/${PN}-32.xpm
- make_desktop_entry ${PN} "Which Way Is Up?" ${PN}-32
+ newicon "${FILESDIR}"/${PN}-32.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Which Way Is Up?"
prepgamesdirs
}