summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2004-12-16 12:55:51 +0000
committerJoseph Jezak <josejx@gentoo.org>2004-12-16 12:55:51 +0000
commita1fc1003c275a160f336761abcb146e22e75f077 (patch)
tree4a0cdc3f742bd638ad6c1f271a064f6a58bb1120 /games-arcade/viruskiller
parentrename 5.010 to 5.10 because 5.010 < 5.09 (Manifest recommit) (diff)
downloadgentoo-2-a1fc1003c275a160f336761abcb146e22e75f077.tar.gz
gentoo-2-a1fc1003c275a160f336761abcb146e22e75f077.tar.bz2
gentoo-2-a1fc1003c275a160f336761abcb146e22e75f077.zip
Force compilation with -fsigned-char to fix bug #72788 and other fixes.
Diffstat (limited to 'games-arcade/viruskiller')
-rw-r--r--games-arcade/viruskiller/ChangeLog6
-rw-r--r--games-arcade/viruskiller/viruskiller-0.9.ebuild12
2 files changed, 13 insertions, 5 deletions
diff --git a/games-arcade/viruskiller/ChangeLog b/games-arcade/viruskiller/ChangeLog
index 4d65d3635a20..2b251a29c4a5 100644
--- a/games-arcade/viruskiller/ChangeLog
+++ b/games-arcade/viruskiller/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/viruskiller
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/viruskiller/ChangeLog,v 1.6 2004/11/22 14:25:01 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/viruskiller/ChangeLog,v 1.7 2004/12/16 12:55:51 josejx Exp $
+
+ 16 Dec 2004; Joseph Jezak <josejx@gentoo.org> viruskiller-0.9.ebuild:
+ Forced compilation with -fsigned-char to fix bug #72788 and added sed check.
+ Also added dependency on pkgconfig to fix zzip-config errors.
22 Nov 2004; Karol Wojtaszek <sekretarz@gentoo.org>
viruskiller-0.9.ebuild:
diff --git a/games-arcade/viruskiller/viruskiller-0.9.ebuild b/games-arcade/viruskiller/viruskiller-0.9.ebuild
index ef083ea87eb8..6b9b6b1393f6 100644
--- a/games-arcade/viruskiller/viruskiller-0.9.ebuild
+++ b/games-arcade/viruskiller/viruskiller-0.9.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/viruskiller/viruskiller-0.9.ebuild,v 1.6 2004/11/22 14:25:01 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/viruskiller/viruskiller-0.9.ebuild,v 1.7 2004/12/16 12:55:51 josejx Exp $
-inherit games
+inherit games flag-o-matic
DESCRIPTION="Simple arcade game, shoot'em up style, where you must defend your file system from invading viruses"
HOMEPAGE="http://www.parallelrealities.co.uk/virusKiller.php"
@@ -18,7 +18,8 @@ DEPEND="media-libs/libsdl
media-libs/sdl-mixer
media-libs/sdl-image
media-libs/sdl-ttf
- dev-libs/zziplib"
+ dev-libs/zziplib
+ dev-util/pkgconfig"
pkg_nofetch() {
einfo "Please download ${A} from"
@@ -32,10 +33,13 @@ src_unpack() {
sed -i \
-e "/^BINDIR = /s:/$:/bin/:" \
-e "/^DOCDIR = /s:doc/.*:doc/${PF}/html/:" \
- makefile
+ -e "s:/usr/bin/zzip-config:pkg-config zziplib:"\
+ -e "s:zzip-config:pkg-config zziplib:"\
+ makefile || die "Can't patch makefile"
}
src_compile() {
+ append-flags -fsigned-char
emake || die
}