summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-04-25 21:52:14 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-04-25 21:52:14 +0000
commit0ee5ae770589c41f49dd80a3cb7488104308ed20 (patch)
treeef156786a685ff6dacb864eeb7ec4e8fe0b66240 /games-arcade/thinktanks-demo
parentVersion bump. (diff)
downloadgentoo-2-0ee5ae770589c41f49dd80a3cb7488104308ed20.tar.gz
gentoo-2-0ee5ae770589c41f49dd80a3cb7488104308ed20.tar.bz2
gentoo-2-0ee5ae770589c41f49dd80a3cb7488104308ed20.zip
Removing internal copies of system libraries. Fix bug #217036
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-arcade/thinktanks-demo')
-rw-r--r--games-arcade/thinktanks-demo/ChangeLog10
-rw-r--r--games-arcade/thinktanks-demo/thinktanks-demo-1.1-r1.ebuild46
2 files changed, 54 insertions, 2 deletions
diff --git a/games-arcade/thinktanks-demo/ChangeLog b/games-arcade/thinktanks-demo/ChangeLog
index 67ea59ba7fe7..cb1ff4c0d7f6 100644
--- a/games-arcade/thinktanks-demo/ChangeLog
+++ b/games-arcade/thinktanks-demo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/thinktanks-demo
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/thinktanks-demo/ChangeLog,v 1.4 2006/09/19 18:58:30 wolf31o2 Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/thinktanks-demo/ChangeLog,v 1.5 2008/04/25 21:52:14 tupone Exp $
+
+*thinktanks-demo-1.1-r1 (25 Apr 2008)
+
+ 25 Apr 2008; Tupone Alfredo <tupone@gentoo.org>
+ +thinktanks-demo-1.1-r1.ebuild:
+ Removing internal copies of system libraries. Fix bug #217036 by Gordon Malm.
19 Sep 2006; Chris Gianelloni <wolf31o2@gentoo.org>
thinktanks-demo-1.1.ebuild:
diff --git a/games-arcade/thinktanks-demo/thinktanks-demo-1.1-r1.ebuild b/games-arcade/thinktanks-demo/thinktanks-demo-1.1-r1.ebuild
new file mode 100644
index 000000000000..ebe044a06685
--- /dev/null
+++ b/games-arcade/thinktanks-demo/thinktanks-demo-1.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/thinktanks-demo/thinktanks-demo-1.1-r1.ebuild,v 1.1 2008/04/25 21:52:14 tupone Exp $
+
+inherit eutils games
+
+DESCRIPTION="tank combat game with lighthearted, fast paced pandemonium"
+HOMEPAGE="http://www.garagegames.com/pg/product/view.php?id=12"
+SRC_URI="ftp://ggdev-1.homelan.com/thinktanks/ThinkTanksDemo_v${PV}.sh.bin"
+
+LICENSE="THINKTANKS"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="strip"
+IUSE=""
+
+DEPEND=""
+RDEPEND="media-libs/libsdl
+ media-libs/libvorbis"
+
+GAMES_CHECK_LICENSE="yes"
+S=${WORKDIR}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+ dodir "${dir}" "${GAMES_BINDIR}"
+
+ tar -zxf ThinkTanks.tar.gz -C "${D}/${dir}" || die "extracting ThinkTanks.tar.gz"
+
+ exeinto "${dir}"
+ doexe bin/Linux/x86/thinktanksdemo
+ dosym "${dir}"/thinktanksdemo "${GAMES_BINDIR}"/thinktanks-demo
+ # Using system libraries
+ rm -rf "${D}/${dir}"/lib
+
+ insinto "${dir}"
+ doins icon.xpm
+
+ dodoc ReadMe_Linux.txt
+
+ prepgamesdirs
+}