summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-07-10 06:21:07 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-07-10 06:21:07 +0000
commit371f94d0b6e6ae4ca170f499f92358599a4d2193 (patch)
tree2b3f57a865e12d7531b09c9c670766b10e59f0b4 /games-arcade/supertux/supertux-0.1.3.ebuild
parentwhen asking for the current profile of a cross target that has yet to be conf... (diff)
downloadgentoo-2-371f94d0b6e6ae4ca170f499f92358599a4d2193.tar.gz
gentoo-2-371f94d0b6e6ae4ca170f499f92358599a4d2193.tar.bz2
gentoo-2-371f94d0b6e6ae4ca170f499f92358599a4d2193.zip
version bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-arcade/supertux/supertux-0.1.3.ebuild')
-rw-r--r--games-arcade/supertux/supertux-0.1.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-arcade/supertux/supertux-0.1.3.ebuild b/games-arcade/supertux/supertux-0.1.3.ebuild
new file mode 100644
index 000000000000..ea88f9dab346
--- /dev/null
+++ b/games-arcade/supertux/supertux-0.1.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/supertux/supertux-0.1.3.ebuild,v 1.1 2005/07/10 06:21:07 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="A game similar to Super Mario Bros."
+HOMEPAGE="http://super-tux.sourceforge.net"
+SRC_URI=" http://download.berlios.de/supertux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="opengl"
+
+DEPEND="virtual/opengl
+ virtual/x11
+ >=media-libs/libsdl-1.2.4
+ >=media-libs/sdl-image-1.2.2
+ >=media-libs/sdl-mixer-1.2.5"
+
+pkg_setup() {
+ if ! built_with_use media-libs/sdl-mixer mikmod ; then
+ die "Please emerge sdl-mixer with USE=mikmod"
+ fi
+ games_pkg_setup
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-debug \
+ $(use_enable opengl) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" \
+ desktopdir=/usr/share/applications \
+ icondir=/usr/share/pixmaps \
+ install || die "make install failed"
+ dodoc AUTHORS ChangeLog LEVELDESIGN README TODO
+ prepgamesdirs
+}