summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-11-19 20:27:13 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-11-19 20:27:13 +0000
commite81999187b25c60417f8143d3efe60058d7dff52 (patch)
tree7a74658dee49180cd43397fdee5a479295e1949d /games-arcade/ssc
parentFixing dbus depends (diff)
downloadgentoo-2-e81999187b25c60417f8143d3efe60058d7dff52.tar.gz
gentoo-2-e81999187b25c60417f8143d3efe60058d7dff52.tar.bz2
gentoo-2-e81999187b25c60417f8143d3efe60058d7dff52.zip
Use system ode instead of the bundled version
(Portage version: 2.1.2_rc2)
Diffstat (limited to 'games-arcade/ssc')
-rw-r--r--games-arcade/ssc/ChangeLog6
-rw-r--r--games-arcade/ssc/files/ssc-0.8-ode.patch31
-rw-r--r--games-arcade/ssc/ssc-0.8.ebuild29
3 files changed, 52 insertions, 14 deletions
diff --git a/games-arcade/ssc/ChangeLog b/games-arcade/ssc/ChangeLog
index 4bc7948306e2..0e7f4e62b4fc 100644
--- a/games-arcade/ssc/ChangeLog
+++ b/games-arcade/ssc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/ssc
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/ssc/ChangeLog,v 1.6 2006/04/24 15:39:21 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/ssc/ChangeLog,v 1.7 2006/11/19 20:27:13 nyhm Exp $
+
+ 19 Nov 2006; Tristan Heaven <nyhm@gentoo.org> +files/ssc-0.8-ode.patch,
+ ssc-0.8.ebuild:
+ Use system ode instead of the bundled version
24 Apr 2006; <Tupone@gentoo.org> ssc-0.8.ebuild:
Fix for gcc-4.1
diff --git a/games-arcade/ssc/files/ssc-0.8-ode.patch b/games-arcade/ssc/files/ssc-0.8-ode.patch
new file mode 100644
index 000000000000..5518392b82f8
--- /dev/null
+++ b/games-arcade/ssc/files/ssc-0.8-ode.patch
@@ -0,0 +1,31 @@
+--- Makefile.in
++++ Makefile.in
+@@ -109,7 +109,7 @@
+ sharedstatedir = @sharedstatedir@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+-SUBDIRS = support src data
++SUBDIRS = src data
+
+ pkgdata_DATA = ssc.conf
+
+--- src/Makefile.in
++++ src/Makefile.in
+@@ -67,7 +67,7 @@
+ LIBOBJS = @LIBOBJS@
+
+ LIBS = \
+- ../support/ode/lib/libode.a \
++ `ode-config --libs` \
+ `freetype-config --libs` \
+ -lGLU -lGL -lSDL_mixer \
+ `sdl-config --libs` \
+@@ -117,7 +117,7 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ INCLUDES = \
+- -I../support/ode/include \
++ `ode-config --cflags` \
+ `freetype-config --cflags` \
+ `sdl-config --cflags`
+
diff --git a/games-arcade/ssc/ssc-0.8.ebuild b/games-arcade/ssc/ssc-0.8.ebuild
index 414b86592d86..1ef287687089 100644
--- a/games-arcade/ssc/ssc-0.8.ebuild
+++ b/games-arcade/ssc/ssc-0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/ssc/ssc-0.8.ebuild,v 1.9 2006/04/24 15:39:21 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/ssc/ssc-0.8.ebuild,v 1.10 2006/11/19 20:27:13 nyhm Exp $
inherit eutils games
@@ -17,24 +17,27 @@ DEPEND="virtual/opengl
virtual/glu
media-libs/libsdl
media-libs/sdl-mixer
- media-libs/freetype"
+ dev-games/ode
+ >=media-libs/freetype-2"
src_unpack() {
unpack ${A}
cd "${S}"
-
sed -i \
-e "s:/usr/local/share/:${GAMES_DATADIR}/:" \
src/{asteroid.cc,audio.cc,config.cc,menu.cc} \
|| die "sed failed"
sed -i \
- -e "/CXXFLAGS/s:-Werror::" \
- configure
- epatch "${FILESDIR}/${P}-gcc34.patch"
+ -e '/CXXFLAGS=$OPT_CXXFLAGS/d' \
+ configure \
+ || die "sed configure failed"
+ epatch \
+ "${FILESDIR}"/${P}-gcc34.patch \
+ "${FILESDIR}"/${P}-ode.patch
}
src_install () {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README TODO
prepgamesdirs
}
@@ -42,12 +45,12 @@ src_install () {
pkg_postinst() {
games_pkg_postinst
echo
- einfo "You may need to copy ${GAMES_DATADIR}/ssc/ssc.conf to"
- einfo "~/.ssc/ssc.conf and modify it to suit your needs before"
- einfo "the game will work on your system. You should be able"
- einfo "to cut and paste the commands below:"
+ elog "You may need to copy ${GAMES_DATADIR}/ssc/ssc.conf to"
+ elog "~/.ssc/ssc.conf and modify it to suit your needs before"
+ elog "the game will work on your system. You should be able"
+ elog "to cut and paste the commands below:"
echo
- einfo "mkdir ~/.ssc/"
- einfo "cp ${GAMES_DATADIR}/ssc/ssc.conf ~/.ssc/"
+ elog "mkdir ~/.ssc/"
+ elog "cp ${GAMES_DATADIR}/ssc/ssc.conf ~/.ssc/"
echo
}