summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-09-14 12:19:33 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-09-14 12:19:33 +0000
commit25e6c3fd85d2461f8afcd2b5b0a678cba46294be (patch)
tree9e062c48829a468d74b1ec4175ac46c1029d6256 /games-arcade/ssc
parentBump to latest upstream stable release (diff)
downloadgentoo-2-25e6c3fd85d2461f8afcd2b5b0a678cba46294be.tar.gz
gentoo-2-25e6c3fd85d2461f8afcd2b5b0a678cba46294be.tar.bz2
gentoo-2-25e6c3fd85d2461f8afcd2b5b0a678cba46294be.zip
Build with media-libs/libpng-1.5 Bug #380631
(Portage version: 2.1.10.15/cvs/Linux i686)
Diffstat (limited to 'games-arcade/ssc')
-rw-r--r--games-arcade/ssc/ChangeLog6
-rw-r--r--games-arcade/ssc/files/ssc-0.8-png15.patch40
-rw-r--r--games-arcade/ssc/ssc-0.8.ebuild10
3 files changed, 50 insertions, 6 deletions
diff --git a/games-arcade/ssc/ChangeLog b/games-arcade/ssc/ChangeLog
index f64680f879b0..b29da2609562 100644
--- a/games-arcade/ssc/ChangeLog
+++ b/games-arcade/ssc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/ssc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/ssc/ChangeLog,v 1.8 2011/08/25 11:23:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/ssc/ChangeLog,v 1.9 2011/09/14 12:19:32 tupone Exp $
+
+ 14 Sep 2011; Tupone Alfredo <tupone@gentoo.org> ssc-0.8.ebuild,
+ +files/ssc-0.8-png15.patch:
+ Build with media-libs/libpng-1.5 Bug #380631 by Diego Elio Pettenò
25 Aug 2011; Diego E. Pettenò <flameeyes@gentoo.org> ssc-0.8.ebuild:
QA: add missing libpng dependency.
diff --git a/games-arcade/ssc/files/ssc-0.8-png15.patch b/games-arcade/ssc/files/ssc-0.8-png15.patch
new file mode 100644
index 000000000000..2e02e436e0db
--- /dev/null
+++ b/games-arcade/ssc/files/ssc-0.8-png15.patch
@@ -0,0 +1,40 @@
+--- src/glpng.c.old 2011-09-14 13:53:16.020425183 +0200
++++ src/glpng.c 2011-09-14 14:08:52.258314061 +0200
+@@ -278,7 +278,7 @@
+ endinfo = png_create_info_struct(png);
+
+ // DH: added following lines
+- if (setjmp(png->jmpbuf))
++ if (setjmp(png_jmpbuf(png)))
+ {
+ png_destroy_read_struct(&png, &info, &endinfo);
+ return 0;
+@@ -382,7 +382,7 @@
+ endinfo = png_create_info_struct(png);
+
+ // DH: added following lines
+- if (setjmp(png->jmpbuf))
++ if (setjmp(png_jmpbuf(png)))
+ {
+ png_destroy_read_struct(&png, &info, &endinfo);
+ return 0;
+@@ -561,7 +561,7 @@
+ #define ALPHA *q
+
+ switch (trans) {
+- case PNG_CALLBACK:
++ case PNG_CALLBAC:
+ FORSTART
+ ALPHA = AlphaCallback((unsigned char) r, (unsigned char) g, (unsigned char) b);
+ FOREND
+--- src/glpng.h.old 2011-09-14 14:08:09.689319112 +0200
++++ src/glpng.h 2011-09-14 14:08:27.073317049 +0200
+@@ -57,7 +57,7 @@
+ #define PNG_SIMPLEMIPMAP PNG_SIMPLEMIPMAPS
+
+ /* Transparency parameters */
+-#define PNG_CALLBACK -3 /* Call the callback function to generate alpha */
++#define PNG_CALLBAC -3 /* Call the callback function to generate alpha */
+ #define PNG_ALPHA -2 /* Use alpha channel in PNG file, if there is one */
+ #define PNG_SOLID -1 /* No transparency */
+ #define PNG_STENCIL 0 /* Sets alpha to 0 for r=g=b=0, 1 otherwise */
diff --git a/games-arcade/ssc/ssc-0.8.ebuild b/games-arcade/ssc/ssc-0.8.ebuild
index 600fb5916b03..18c24fc3e437 100644
--- a/games-arcade/ssc/ssc-0.8.ebuild
+++ b/games-arcade/ssc/ssc-0.8.ebuild
@@ -1,6 +1,7 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/ssc/ssc-0.8.ebuild,v 1.11 2011/08/25 11:23:13 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/ssc/ssc-0.8.ebuild,v 1.12 2011/09/14 12:19:32 tupone Exp $
+EAPI=2
inherit eutils games
@@ -21,9 +22,7 @@ DEPEND="virtual/opengl
>=media-libs/freetype-2
media-libs/libpng"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
sed -i \
-e "s:/usr/local/share/:${GAMES_DATADIR}/:" \
src/{asteroid.cc,audio.cc,config.cc,menu.cc} \
@@ -34,7 +33,8 @@ src_unpack() {
|| die "sed configure failed"
epatch \
"${FILESDIR}"/${P}-gcc34.patch \
- "${FILESDIR}"/${P}-ode.patch
+ "${FILESDIR}"/${P}-ode.patch \
+ "${FILESDIR}"/${P}-png15.patch
}
src_install () {