summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-10-04 02:51:13 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-10-04 02:51:13 +0000
commitfaa68ec8b9e0cc5a8464a458a66dd9fd0afcfde9 (patch)
tree24208cb9aab36680c8216f72ae7b7a924739ea66 /games-arcade/spout
parentUpdate to install properly for xfree or xorg-x11, add virtual/x11 to RDEPEND.... (diff)
downloadgentoo-2-faa68ec8b9e0cc5a8464a458a66dd9fd0afcfde9.tar.gz
gentoo-2-faa68ec8b9e0cc5a8464a458a66dd9fd0afcfde9.tar.bz2
gentoo-2-faa68ec8b9e0cc5a8464a458a66dd9fd0afcfde9.zip
version bump (bug #66264)
Diffstat (limited to 'games-arcade/spout')
-rw-r--r--games-arcade/spout/ChangeLog7
-rw-r--r--games-arcade/spout/Manifest6
-rw-r--r--games-arcade/spout/files/digest-spout-1.31
-rw-r--r--games-arcade/spout/spout-1.3.ebuild44
4 files changed, 55 insertions, 3 deletions
diff --git a/games-arcade/spout/ChangeLog b/games-arcade/spout/ChangeLog
index bc064dbd2bad..7c517ff53823 100644
--- a/games-arcade/spout/ChangeLog
+++ b/games-arcade/spout/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-arcade/spout
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/spout/ChangeLog,v 1.2 2004/07/22 20:57:45 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/spout/ChangeLog,v 1.3 2004/10/04 02:51:13 mr_bones_ Exp $
+
+*spout-1.3 (03 Oct 2004)
+
+ 03 Oct 2004; Michael Sterrett <mr_bones_@gentoo.org> +spout-1.3.ebuild:
+ version bump (bug #66264)
22 Jul 2004; David Holm <dholm@gentoo.org> spout-1.2.ebuild:
Added to ~ppc.
diff --git a/games-arcade/spout/Manifest b/games-arcade/spout/Manifest
index 8c8c182b3157..a73ae82e0588 100644
--- a/games-arcade/spout/Manifest
+++ b/games-arcade/spout/Manifest
@@ -1,4 +1,6 @@
-MD5 46823829120168984897abbc7b81a9e5 ChangeLog 481
-MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 aae9d6f423232e8c703c9d507d11f5cf spout-1.2.ebuild 1126
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 89056e197a786ad2d26dd41e001c2ad2 spout-1.3.ebuild 1126
+MD5 46823829120168984897abbc7b81a9e5 ChangeLog 481
MD5 a3c4db96d537df28af9df7322a420a29 files/digest-spout-1.2 66
+MD5 b54deca8c50ac59d9643202716e0c055 files/digest-spout-1.3 66
diff --git a/games-arcade/spout/files/digest-spout-1.3 b/games-arcade/spout/files/digest-spout-1.3
new file mode 100644
index 000000000000..f166decc5a4a
--- /dev/null
+++ b/games-arcade/spout/files/digest-spout-1.3
@@ -0,0 +1 @@
+MD5 d405cdf5b92717c9cb65cf17055a8cc7 spout-unix-1.3.tar.bz2 92144
diff --git a/games-arcade/spout/spout-1.3.ebuild b/games-arcade/spout/spout-1.3.ebuild
new file mode 100644
index 000000000000..2bd5ff4e58ce
--- /dev/null
+++ b/games-arcade/spout/spout-1.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/spout/spout-1.3.ebuild,v 1.1 2004/10/04 02:51:13 mr_bones_ Exp $
+
+inherit eutils games
+
+MY_P="spout-unix-${PV}"
+DESCRIPTION="Abstract Japanese caveflier / shooter"
+HOMEPAGE="http://code.mizzenblog.com/category/spout/"
+SRC_URI="http://code.mizzenblog.com/spout/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE=""
+
+DEPEND="virtual/x11
+ >=media-libs/libsdl-1.2.6"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dogamesbin spout || die "dogamesbin failed"
+ insinto /usr/share/pixmaps
+ doins spout.png
+ make_desktop_entry spout "Spout" spout.png
+ dodoc README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "To play in fullscreen mode, do 'spout f'."
+ einfo "To play in a greater resolution, do 'spout x', where"
+ einfo "x is an integer; the larger x is, the higher the resolution."
+ echo
+ einfo "To play:"
+ einfo "Accelerate - spacebar, enter, z, x"
+ einfo "Pause - escape"
+ einfo "Exit - shift+escape"
+ einfo "Rotate - left or right"
+ echo
+}