summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-01-19 05:57:19 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-01-19 05:57:19 +0000
commit7e9b58340481987aa49253b442b255b4ded38f18 (patch)
tree14629f268030a4917fd95cffac9a5cfe531de905 /games-arcade/spacerider
parentrm (diff)
downloadgentoo-2-7e9b58340481987aa49253b442b255b4ded38f18.tar.gz
gentoo-2-7e9b58340481987aa49253b442b255b4ded38f18.tar.bz2
gentoo-2-7e9b58340481987aa49253b442b255b4ded38f18.zip
Remove strip from makefile
(Portage version: 2.1.4)
Diffstat (limited to 'games-arcade/spacerider')
-rw-r--r--games-arcade/spacerider/ChangeLog8
-rw-r--r--games-arcade/spacerider/files/digest-spacerider-0.136
-rw-r--r--games-arcade/spacerider/files/spacerider-0.13-gentoo.patch25
-rw-r--r--games-arcade/spacerider/spacerider-0.13.ebuild10
4 files changed, 27 insertions, 22 deletions
diff --git a/games-arcade/spacerider/ChangeLog b/games-arcade/spacerider/ChangeLog
index 5510adfc521a..c77f470bb4c0 100644
--- a/games-arcade/spacerider/ChangeLog
+++ b/games-arcade/spacerider/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/spacerider
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/spacerider/ChangeLog,v 1.1 2007/02/18 11:10:36 tupone Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/spacerider/ChangeLog,v 1.2 2008/01/19 05:57:19 nyhm Exp $
+
+ 19 Jan 2008; Tristan Heaven <nyhm@gentoo.org>
+ files/spacerider-0.13-gentoo.patch, spacerider-0.13.ebuild:
+ Remove strip from makefile
*spacerider-0.13 (18 Feb 2007)
diff --git a/games-arcade/spacerider/files/digest-spacerider-0.13 b/games-arcade/spacerider/files/digest-spacerider-0.13
index da6a14f4c823..cb39e348dbcd 100644
--- a/games-arcade/spacerider/files/digest-spacerider-0.13
+++ b/games-arcade/spacerider/files/digest-spacerider-0.13
@@ -1,3 +1,3 @@
-MD5 b908144d03d69303443cbcce065117c1 download.php?file=spacerider-0.13.tar.bz2 283861
-RMD160 bd3eeae53aa69f4adcb8c7d92044856c38b0c3a5 download.php?file=spacerider-0.13.tar.bz2 283861
-SHA256 9314945b7004a64e7f511b7318af3aef5d1ab680577ba97399a8a11ab022678e download.php?file=spacerider-0.13.tar.bz2 283861
+MD5 b908144d03d69303443cbcce065117c1 spacerider-0.13.tar.bz2 283861
+RMD160 bd3eeae53aa69f4adcb8c7d92044856c38b0c3a5 spacerider-0.13.tar.bz2 283861
+SHA256 9314945b7004a64e7f511b7318af3aef5d1ab680577ba97399a8a11ab022678e spacerider-0.13.tar.bz2 283861
diff --git a/games-arcade/spacerider/files/spacerider-0.13-gentoo.patch b/games-arcade/spacerider/files/spacerider-0.13-gentoo.patch
index 7fe1a63ef5a6..d692f87632b0 100644
--- a/games-arcade/spacerider/files/spacerider-0.13-gentoo.patch
+++ b/games-arcade/spacerider/files/spacerider-0.13-gentoo.patch
@@ -1,24 +1,27 @@
---- Makefile.old 2007-02-18 11:15:20.000000000 +0100
-+++ Makefile 2007-02-18 11:19:56.000000000 +0100
-@@ -8,7 +8,6 @@
+--- Makefile
++++ Makefile
+@@ -3,12 +3,12 @@
+ BINDIR=/usr/bin/
+ MANDIR=/usr/share/man/man1/
+ DATADIR=/usr/share/games/spacerider/
+-CXX=g++
++CXX?=g++
+ CP=cp
MKDIR=mkdir -p
INSTALL=install
RM=rm -f
-CXXFLAGS=-Wall -fomit-frame-pointer -O3 `sdl-config --cflags`
++CXXFLAGS+=$(shell sdl-config --cflags)
OBJS=main.o globals.o spacerider.o music.o sprite.o enemy.o effect.o visible.o box.o features.o font.o image.o bullet.o
OUTPUT=spacerider
LIBS=`sdl-config --libs` -lSDL_image -lSDL_ttf -lSDL_mixer -lSDL_net -lSDL_gfx
-@@ -22,11 +21,11 @@
+@@ -22,8 +22,7 @@
$(OUTPUT): $(OBJS)
- $(CXX) $(CXXFLAGS) -o $(OUTPUT) $(OBJS) $(LIBS)
-+ $(CXX) $(CXXFLAGS) `sdl-config --cflags` -o $(OUTPUT) $(OBJS) $(LIBS)
- strip $(OUTPUT)
+- strip $(OUTPUT)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $(OUTPUT) $(OBJS) $(LIBS)
%.o: %.cpp
-- $(CXX) $(CXXFLAGS) -c $<
-+ $(CXX) $(CXXFLAGS) `sdl-config --cflags` -c $<
-
- clean:
- $(RM) $(OBJS) $(OUTPUT)
+ $(CXX) $(CXXFLAGS) -c $<
diff --git a/games-arcade/spacerider/spacerider-0.13.ebuild b/games-arcade/spacerider/spacerider-0.13.ebuild
index 348b05f5158e..d5353190fa45 100644
--- a/games-arcade/spacerider/spacerider-0.13.ebuild
+++ b/games-arcade/spacerider/spacerider-0.13.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/spacerider/spacerider-0.13.ebuild,v 1.2 2007/02/18 14:50:30 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/spacerider/spacerider-0.13.ebuild,v 1.3 2008/01/19 05:57:19 nyhm Exp $
inherit eutils games
DESCRIPTION="space-shooter written in C++, using the SDL"
-HOMEPAGE="http://www.hackl.dhs.org/spacerider"
-SRC_URI="http://www.hackl.dhs.org/data/download/download.php?file=${P}.tar.bz2"
+HOMEPAGE="http://www.hackl.dhs.org/spacerider/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2" # stupid php script
LICENSE="GPL-2"
SLOT="0"
@@ -34,9 +34,7 @@ src_install() {
dogamesbin ${PN} || die "dogamesbin failed"
insinto "${GAMES_DATADIR}/${PN}"
doins -r data || die "doins failed"
-
dodoc AUTHORS
newman ${PN}.{1,6}
-
prepgamesdirs
}