summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:22 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 19:29:22 +0000
commitf0759f77429dfcff11fdeb040d0553dd1e8e0bd8 (patch)
treebc451cfc4f19d245b0c6a7f10e547fdc2006db52 /games-arcade/missile
parentaction games ! (diff)
downloadgentoo-2-f0759f77429dfcff11fdeb040d0553dd1e8e0bd8.tar.gz
gentoo-2-f0759f77429dfcff11fdeb040d0553dd1e8e0bd8.tar.bz2
gentoo-2-f0759f77429dfcff11fdeb040d0553dd1e8e0bd8.zip
arcade games !
Diffstat (limited to 'games-arcade/missile')
-rw-r--r--games-arcade/missile/ChangeLog8
-rw-r--r--games-arcade/missile/Manifest4
-rw-r--r--games-arcade/missile/files/1.0.1-Makefile-path-fix.patch80
-rw-r--r--games-arcade/missile/files/digest-missile-1.0.11
-rw-r--r--games-arcade/missile/missile-1.0.1.ebuild43
5 files changed, 136 insertions, 0 deletions
diff --git a/games-arcade/missile/ChangeLog b/games-arcade/missile/ChangeLog
new file mode 100644
index 000000000000..807d621ca8f5
--- /dev/null
+++ b/games-arcade/missile/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-games/missile
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/missile/ChangeLog,v 1.1 2003/09/10 19:29:21 vapier Exp $
+
+*missile-1.0.1 (07 Jul 2003)
+
+ 07 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Matsuu Takuto <matsuu@gentoo.org>.
diff --git a/games-arcade/missile/Manifest b/games-arcade/missile/Manifest
new file mode 100644
index 000000000000..2ec3f164cc70
--- /dev/null
+++ b/games-arcade/missile/Manifest
@@ -0,0 +1,4 @@
+MD5 449b6e72f32105137a91e533ddfa6f59 files/digest-missile-1.0.1 65
+MD5 e35eefe94cc7a26de7e4c770d3156d4a files/1.0.1-Makefile-path-fix.patch 2730
+MD5 966dcd78c3135aaa655b15ebf39fd365 missile-1.0.1.ebuild 1152
+MD5 6d101c8751d18eadd1f6b493d1175c3c ChangeLog 372
diff --git a/games-arcade/missile/files/1.0.1-Makefile-path-fix.patch b/games-arcade/missile/files/1.0.1-Makefile-path-fix.patch
new file mode 100644
index 000000000000..8482bd382d27
--- /dev/null
+++ b/games-arcade/missile/files/1.0.1-Makefile-path-fix.patch
@@ -0,0 +1,80 @@
+--- Makefile.orig 2003-07-07 21:58:28.000000000 -0400
++++ Makefile 2003-07-07 21:59:22.000000000 -0400
+@@ -19,14 +19,19 @@
+ # INSTALLATION DIRS:
+ # binary will be installed to $game_prefix/$game_bin
+ # data to $game_prefix/$game_data
+-game_prefix = /usr/local
+-game_bin = bin
+-game_data = share/missile
+-game_icons = share/pixmaps
++game_prefix =GENTOO
++game_bin =GENTOO
++game_data =GENTOO
++game_icons =GENTOO
++DESTDIR =
++game_prefix:=$(DESTDIR)/$(game_prefix)
++game_bin:=$(DESTDIR)/$(game_bin)
++game_data:=$(DESTDIR)/$(game_data)
++game_icons:=$(DESTDIR)/$(game_icons)
+
+ # who the owner of the installed game will be
+-install_as_owner = root
+-install_as_group = games
++install_as_owner =GENTOO
++install_as_group =GENTOO
+
+
+
+@@ -70,8 +75,9 @@
+ #
+ #CC = ccmalloc gcc
+ CC = gcc
+-OPTS = $(RPM_OPT_FLAGS) -DDATA=\"$(game_prefix)/$(game_data)\" -DVERSION=\"$(DIST_VER)\" -D$(sound)
+-CFLAGS = -Wall -O2 $(OPTS) `sdl-config --cflags`
++MYOPTS =
++OPTS = $(RPM_OPT_FLAGS) -DDATA=\"$(game_data)\" -DVERSION=\"$(DIST_VER)\" -D$(sound)
++CFLAGS = -Wall -O2 $(OPTS) `sdl-config --cflags` $(MYOPTS)
+ #CFLAGS = -Wall -g `sdl-config --cflags`
+ LIBS = `sdl-config --libs` -lSDL_image $(SND_LIBS)
+ INCLUDE =
+@@ -143,14 +149,14 @@
+ install :
+ @$(STRIP) $(PROGRAM) || \
+ (echo; echo "Please run \"make\" first to build the program"; echo; exit -1)
+- $(INSTALL) $(IFLAGS) $(EXEC_PERM) $(PROGRAM) $(game_prefix)/$(game_bin)/$(PROGRAM)
++ $(INSTALL) $(IFLAGS) $(EXEC_PERM) $(PROGRAM) $(game_bin)/$(PROGRAM)
+ cd $(DATA);\
+ for f in `find . -type f`; do \
+- $(INSTALL) $(IFLAGS) $(FILE_PERM) $$f $(game_prefix)/$(game_data)/$$f;\
++ $(INSTALL) $(IFLAGS) $(FILE_PERM) $$f $(game_data)/$$f;\
+ done
+ cd $(ICONS);\
+ for f in `ls`; do \
+- $(INSTALL) $(IFLAGS) $(FILE_PERM) $$f $(game_prefix)/$(game_icons)/$$f;\
++ $(INSTALL) $(IFLAGS) $(FILE_PERM) $$f $(game_icons)/$$f;\
+ done
+ # $(MAKE) create_etc_conf
+ @echo ""
+@@ -160,7 +166,7 @@
+
+ #create_etc_conf:
+ # if [ -w /etc ]; then \
+-# echo "Data=$(game_prefix)/$(game_data)" > /etc/missilecommand.conf; \
++# echo "Data=$(game_data)" > /etc/missilecommand.conf; \
+ # fi
+
+ # I need the right way to do this...
+@@ -179,9 +185,9 @@
+
+
+ uninstall :
+- - rm $(game_prefix)/$(game_bin)/$(PROGRAM)
+- - rm -rf $(game_prefix)/$(game_data)
+- - rm $(game_prefix)/$(game_icons)/missile_icon_{black,blue,white,green,red,yellow}.png
++ - rm $(game_bin)/$(PROGRAM)
++ - rm -rf $(game_data)
++ - rm $(game_icons)/missile_icon_{black,blue,white,green,red,yellow}.png
+ @echo ""
+ @echo "---------------------------------------------------------------------"
+ @echo "$(PROGRAM) and associated files uninstalled."
diff --git a/games-arcade/missile/files/digest-missile-1.0.1 b/games-arcade/missile/files/digest-missile-1.0.1
new file mode 100644
index 000000000000..0c772762eacc
--- /dev/null
+++ b/games-arcade/missile/files/digest-missile-1.0.1
@@ -0,0 +1 @@
+MD5 a4a429dc74efff08ab555c792957fe4a missile-1.0.1.tar.gz 214933
diff --git a/games-arcade/missile/missile-1.0.1.ebuild b/games-arcade/missile/missile-1.0.1.ebuild
new file mode 100644
index 000000000000..1243008f11e6
--- /dev/null
+++ b/games-arcade/missile/missile-1.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/missile/missile-1.0.1.ebuild,v 1.1 2003/09/10 19:29:21 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="The Atari game Missile Command for Linux"
+HOMEPAGE="http://missile.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND=">=media-libs/libsdl-1.2.4
+ >=media-libs/sdl-image-1.2.1
+ >=media-libs/sdl-mixer-1.2.4
+ media-libs/libpng
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-Makefile-path-fix.patch
+ sed -i \
+ -e "/^game_prefix/s:=GENTOO:=${GAMES_PREFIX}:" \
+ -e "/^game_bin/s:=GENTOO:=${GAMES_PREFIX}/bin:" \
+ -e "/^game_data/s:=GENTOO:=${GAMES_DATADIR}/${PN}:" \
+ -e "/^game_icons/s:=GENTOO:=/usr/share/pixmaps/${PN}:" \
+ -e "/^install_as_owner/s:=GENTOO:=${GAMES_USER}:" \
+ -e "/^install_as_group/s:=GENTOO:=${GAMES_GROUP}:" \
+ Makefile
+}
+
+src_compile() {
+ make MYOPTS="${CFLAGS}" || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc README INSTALL
+ prepgamesdirs
+}