summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-04-21 07:30:41 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-04-21 07:30:41 +0000
commit46be8f300cd666bf3aea597b22b37e6ea8733d7a (patch)
tree0a368e0c65ce11b1ebee48ef5210ed9018681826 /games-arcade/methane
parentx86 stable per bug 364191 (diff)
downloadgentoo-2-46be8f300cd666bf3aea597b22b37e6ea8733d7a.tar.gz
gentoo-2-46be8f300cd666bf3aea597b22b37e6ea8733d7a.tar.bz2
gentoo-2-46be8f300cd666bf3aea597b22b37e6ea8733d7a.zip
Build with gcc-4.6 Bug #362381
Enabling parallell compilation (Portage version: 2.1.9.46/cvs/Linux i686)
Diffstat (limited to 'games-arcade/methane')
-rw-r--r--games-arcade/methane/ChangeLog9
-rw-r--r--games-arcade/methane/files/methane-1.4.8-gcc46.patch10
-rw-r--r--games-arcade/methane/methane-1.4.8.ebuild11
3 files changed, 23 insertions, 7 deletions
diff --git a/games-arcade/methane/ChangeLog b/games-arcade/methane/ChangeLog
index b4b9967dbd79..f96a2de8ac4b 100644
--- a/games-arcade/methane/ChangeLog
+++ b/games-arcade/methane/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-arcade/methane
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/methane/ChangeLog,v 1.17 2010/10/01 05:00:17 tupone Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/methane/ChangeLog,v 1.18 2011/04/21 07:30:41 tupone Exp $
+
+ 21 Apr 2011; Tupone Alfredo <tupone@gentoo.org> methane-1.4.8.ebuild,
+ +files/methane-1.4.8-gcc46.patch:
+ Build with gcc-4.6 Bug #362381 by Diego Elio Pettenò
+ Enabling parallell compilation
01 Oct 2010; Tupone Alfredo <tupone@gentoo.org> methane-1.4.8.ebuild,
+files/methane-1.4.8-ldflags.patch:
diff --git a/games-arcade/methane/files/methane-1.4.8-gcc46.patch b/games-arcade/methane/files/methane-1.4.8-gcc46.patch
new file mode 100644
index 000000000000..cd8ab12da977
--- /dev/null
+++ b/games-arcade/methane/files/methane-1.4.8-gcc46.patch
@@ -0,0 +1,10 @@
+--- source/global.h.old 2011-04-21 08:36:56.986592821 +0200
++++ source/global.h 2011-04-21 08:37:51.575981236 +0200
+@@ -17,6 +17,7 @@
+ #ifndef _global_h
+ #define _global_h 1
+
++#include <cstddef>
+ #ifndef _METH_RC
+
+ #ifndef METHANE_OLD_CPP_NEW
diff --git a/games-arcade/methane/methane-1.4.8.ebuild b/games-arcade/methane/methane-1.4.8.ebuild
index 6034ba066b48..be32c13a3aa8 100644
--- a/games-arcade/methane/methane-1.4.8.ebuild
+++ b/games-arcade/methane/methane-1.4.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/methane/methane-1.4.8.ebuild,v 1.7 2010/10/01 05:00:17 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/methane/methane-1.4.8.ebuild,v 1.8 2011/04/21 07:30:41 tupone Exp $
EAPI=2
inherit eutils games
@@ -28,13 +28,14 @@ src_prepare() {
fi
sed -i \
-e "s:/var/games:${GAMES_STATEDIR}:" \
- source/linux/doc.cpp history \
+ source/linux/doc.cpp \
|| die "sed failed"
- epatch "${FILESDIR}"/${P}-ldflags.patch
+ epatch "${FILESDIR}"/${P}-ldflags.patch \
+ "${FILESDIR}"/${P}-gcc46.patch
}
src_compile() {
- emake -C source/linux -j1 || die "emake failed"
+ emake -C source/linux || die "emake failed"
}
src_install() {