summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-05-12 06:07:31 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-05-12 06:07:31 +0000
commit07714a52314cd45b0e761cd5f196243a532f48d9 (patch)
tree63a33249e7d1beee3390c22e737eaaa2b8b53304 /games-arcade/lbreakout2/lbreakout2-2.5.2.ebuild
parentStable on mips. (diff)
downloadgentoo-2-07714a52314cd45b0e761cd5f196243a532f48d9.tar.gz
gentoo-2-07714a52314cd45b0e761cd5f196243a532f48d9.tar.bz2
gentoo-2-07714a52314cd45b0e761cd5f196243a532f48d9.zip
update levelset file with patch from Denilson via bug #162745
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-arcade/lbreakout2/lbreakout2-2.5.2.ebuild')
-rw-r--r--games-arcade/lbreakout2/lbreakout2-2.5.2.ebuild40
1 files changed, 33 insertions, 7 deletions
diff --git a/games-arcade/lbreakout2/lbreakout2-2.5.2.ebuild b/games-arcade/lbreakout2/lbreakout2-2.5.2.ebuild
index 6ece3dadb9a7..2ba5231906ca 100644
--- a/games-arcade/lbreakout2/lbreakout2-2.5.2.ebuild
+++ b/games-arcade/lbreakout2/lbreakout2-2.5.2.ebuild
@@ -1,18 +1,22 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/lbreakout2/lbreakout2-2.5.2.ebuild,v 1.6 2007/04/24 15:52:16 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/lbreakout2/lbreakout2-2.5.2.ebuild,v 1.7 2007/05/12 06:07:31 mr_bones_ Exp $
inherit flag-o-matic eutils games
+levels_V=20070121
+themes_V=20070121
+
DESCRIPTION="Breakout clone written with the SDL library"
HOMEPAGE="http://lgames.sourceforge.net/index.php?project=LBreakout2"
-SRC_URI="mirror://sourceforge/lgames/${P}.tar.gz
- mirror://gentoo/lbreakout2-levelsets-20040319.tar.gz"
+SRC_URI=" mirror://sourceforge/lgames/${P}.tar.gz
+ mirror://sourceforge/lgames/${PN}-levelsets-${levels_V}.tar.gz
+ themes? ( mirror://sourceforge/lgames/${PN}-themes-${themes_V}.tar.gz )"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ppc x86 ~x86-fbsd"
-IUSE=""
+IUSE="themes"
DEPEND="media-libs/libpng
sys-libs/zlib
@@ -24,9 +28,23 @@ GAMES_USE_SDL="nojoystick" #bug #139864
src_unpack() {
unpack ${P}.tar.gz
- mkdir "${S}/levels"
- cd "${S}/levels"
- unpack lbreakout2-levelsets-20040319.tar.gz
+
+ cd "${S}/client/levels"
+ unpack ${PN}-levelsets-${levels_V}.tar.gz
+
+ if use themes ; then
+ mkdir "${WORKDIR}/themes"
+ cd "${WORKDIR}/themes"
+ unpack ${PN}-themes-${themes_V}.tar.gz
+
+ # Delete a few duplicate themes (already shipped with lbreakout2
+ # tarball). Some of them have different case than built-in themes, so it
+ # is harder to just compare if the filename is the same.
+ rm -f absoluteB.zip oz.zip moiree.zip
+ for f in *.zip; do
+ unzip -q "$f" && rm -f "$f" || die "unpacking ${f}"
+ done
+ fi
}
src_compile() {
@@ -44,6 +62,14 @@ src_install() {
mv "${D}"/usr/share/doc/${PF}/{lbreakout2,html}
dodoc AUTHORS README TODO ChangeLog
+ if use themes ; then
+ insinto "${GAMES_DATADIR}/lbreakout2/gfx"
+ # The next operation is slow. I guess we should display some type of
+ # progress or something, just like "make install" prints what it is
+ # doing.
+ doins -r "${WORKDIR}/themes/"* || die "extra themes installation failed"
+ fi
+
newicon client/gfx/win_icon.png lbreakout2.png
make_desktop_entry lbreakout2 LBreakout2