summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-01-08 07:46:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-01-08 07:46:47 +0000
commit1b670b5974274af284bb39b06af100d03dfd3c80 (patch)
tree674c3a612d6794640ceb07264fabd7e8a51767a3 /games-arcade/kobodeluxe
parentuclibc_endian should test target, not host #204747 (diff)
downloadgentoo-2-1b670b5974274af284bb39b06af100d03dfd3c80.tar.gz
gentoo-2-1b670b5974274af284bb39b06af100d03dfd3c80.tar.bz2
gentoo-2-1b670b5974274af284bb39b06af100d03dfd3c80.zip
version bump (bug #204551)
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-arcade/kobodeluxe')
-rw-r--r--games-arcade/kobodeluxe/ChangeLog10
-rw-r--r--games-arcade/kobodeluxe/files/digest-kobodeluxe-0.5.13
-rw-r--r--games-arcade/kobodeluxe/kobodeluxe-0.5.1.ebuild50
3 files changed, 61 insertions, 2 deletions
diff --git a/games-arcade/kobodeluxe/ChangeLog b/games-arcade/kobodeluxe/ChangeLog
index bbe846c5e16d..92f0c10c8685 100644
--- a/games-arcade/kobodeluxe/ChangeLog
+++ b/games-arcade/kobodeluxe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/kobodeluxe
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/kobodeluxe/ChangeLog,v 1.22 2007/11/30 19:23:08 tupone Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/kobodeluxe/ChangeLog,v 1.23 2008/01/08 07:46:46 mr_bones_ Exp $
+
+*kobodeluxe-0.5.1 (08 Jan 2008)
+
+ 08 Jan 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +kobodeluxe-0.5.1.ebuild:
+ version bump (bug #204551)
*kobodeluxe-0.4.1 (30 Nov 2007)
diff --git a/games-arcade/kobodeluxe/files/digest-kobodeluxe-0.5.1 b/games-arcade/kobodeluxe/files/digest-kobodeluxe-0.5.1
new file mode 100644
index 000000000000..8a424cf29eb0
--- /dev/null
+++ b/games-arcade/kobodeluxe/files/digest-kobodeluxe-0.5.1
@@ -0,0 +1,3 @@
+MD5 cb5dcdaf07ccad18a921058138dedc4a KoboDeluxe-0.5.1.tar.bz2 1781752
+RMD160 b196054f2220fe1b479a490723b1f5da4e74aa1f KoboDeluxe-0.5.1.tar.bz2 1781752
+SHA256 0f7b910a399d985437564af8c5d81d6dcf22b96b26b01488d72baa6a6fdb5c2c KoboDeluxe-0.5.1.tar.bz2 1781752
diff --git a/games-arcade/kobodeluxe/kobodeluxe-0.5.1.ebuild b/games-arcade/kobodeluxe/kobodeluxe-0.5.1.ebuild
new file mode 100644
index 000000000000..ba08d54671a9
--- /dev/null
+++ b/games-arcade/kobodeluxe/kobodeluxe-0.5.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/kobodeluxe/kobodeluxe-0.5.1.ebuild,v 1.1 2008/01/08 07:46:46 mr_bones_ Exp $
+
+inherit eutils games
+
+MY_P="KoboDeluxe-${PV/_/}"
+DESCRIPTION="An SDL port of xkobo, a addictive space shoot-em-up"
+HOMEPAGE="http://www.olofson.net/kobodl/"
+SRC_URI="http://www.olofson.net/kobodl/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="opengl"
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ opengl? ( virtual/opengl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Fix paths
+ sed -i \
+ -e 's:\$(datadir)/kobo-deluxe:$(datadir)/kobodeluxe:' \
+ -e 's:\$(sharedstatedir)/kobo-deluxe/scores:$(localstatedir)/kobodeluxe:' \
+ configure || die "sed configure failed"
+ sed -i \
+ -e 's:kobo-deluxe:kobodeluxe:' \
+ data/gfx/Makefile.in \
+ data/sfx/Makefile.in || die "sed data/Makefile.in failed"
+ tar xzvf icons.tar.gz || die "unpacking icons failed"
+}
+
+src_compile() {
+ egamesconf $(use_enable opengl) || die
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newicon icons/KDE/icons/32x32/kobodl.png ${PN}.png
+ make_desktop_entry kobodl "Kobo Deluxe"
+ dodoc ChangeLog README* TODO
+ prepgamesdirs
+ fperms 2775 "${GAMES_STATEDIR}"/${PN}
+}