summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-07-27 18:04:51 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-07-27 18:04:51 +0000
commitb7cff4b371387a5c1708f3495305d378325296ee (patch)
tree650996efad6e1ed92772dc133a17b0b153b32d7a /games-arcade/holotz-castle
parentppc stable #278597 (diff)
downloadgentoo-2-b7cff4b371387a5c1708f3495305d378325296ee.tar.gz
gentoo-2-b7cff4b371387a5c1708f3495305d378325296ee.tar.bz2
gentoo-2-b7cff4b371387a5c1708f3495305d378325296ee.zip
Fix building with gcc-4.4, bug #273505
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade/holotz-castle')
-rw-r--r--games-arcade/holotz-castle/ChangeLog6
-rw-r--r--games-arcade/holotz-castle/files/holotz-castle-1.3.10-gcc44.patch11
-rw-r--r--games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild9
3 files changed, 21 insertions, 5 deletions
diff --git a/games-arcade/holotz-castle/ChangeLog b/games-arcade/holotz-castle/ChangeLog
index d5397370f455..00dda9423595 100644
--- a/games-arcade/holotz-castle/ChangeLog
+++ b/games-arcade/holotz-castle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/holotz-castle
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/holotz-castle/ChangeLog,v 1.9 2009/02/02 09:43:10 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/holotz-castle/ChangeLog,v 1.10 2009/07/27 18:04:51 nyhm Exp $
+
+ 27 Jul 2009; Tristan Heaven <nyhm@gentoo.org> holotz-castle-1.3.10.ebuild,
+ +files/holotz-castle-1.3.10-gcc44.patch:
+ Fix building with gcc-4.4, bug #273505
02 Feb 2009; Alfredo Tupone <tupone@gentoo.org>
files/holotz-castle-1.3.10-build.patch, holotz-castle-1.3.10.ebuild:
diff --git a/games-arcade/holotz-castle/files/holotz-castle-1.3.10-gcc44.patch b/games-arcade/holotz-castle/files/holotz-castle-1.3.10-gcc44.patch
new file mode 100644
index 000000000000..0c3af53591bf
--- /dev/null
+++ b/games-arcade/holotz-castle/files/holotz-castle-1.3.10-gcc44.patch
@@ -0,0 +1,11 @@
+--- JLib/JLib/Util/JFS.cpp
++++ JLib/JLib/Util/JFS.cpp
+@@ -887,7 +887,7 @@
+
+ // Si es un directorio lo importa recursivamente
+ struct dirent64 **namelist;
+- n = scandir64(filename, &namelist, 0, alphasort);
++ n = scandir64(filename, &namelist, 0, alphasort64);
+
+ if (n < 0)
+ {
diff --git a/games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild b/games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild
index fa4de0ba4a00..80bd5770ef59 100644
--- a/games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild
+++ b/games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild,v 1.4 2009/02/02 09:43:10 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/holotz-castle/holotz-castle-1.3.10.ebuild,v 1.5 2009/07/27 18:04:51 nyhm Exp $
EAPI=2
inherit eutils games
@@ -22,9 +22,10 @@ DEPEND="virtual/opengl
S=${WORKDIR}/${P}-src
-src_prepare() {
- epatch "${FILESDIR}"/${P}-build.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-gcc44.patch
+)
src_compile() {
emake -C JLib CPU_OPTS="${CXXFLAGS}" || die "emake failed"