summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-03-09 17:03:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-03-09 17:03:52 +0000
commit9b20c30b896670437a031cd2d748103431b60759 (patch)
tree7d33c8475ae4db84b70db2d215784bacb98f4c1b /games-arcade/gish-demo
parentFixed dependency, bug #261250. (diff)
downloadgentoo-2-9b20c30b896670437a031cd2d748103431b60759.tar.gz
gentoo-2-9b20c30b896670437a031cd2d748103431b60759.tar.bz2
gentoo-2-9b20c30b896670437a031cd2d748103431b60759.zip
make it use the newer openal (patch from Colin Macdonald via bug #261496)
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'games-arcade/gish-demo')
-rw-r--r--games-arcade/gish-demo/ChangeLog8
-rw-r--r--games-arcade/gish-demo/gish-demo-1.0.0.ebuild11
2 files changed, 14 insertions, 5 deletions
diff --git a/games-arcade/gish-demo/ChangeLog b/games-arcade/gish-demo/ChangeLog
index b767bb06ed16..5c03e0930b7d 100644
--- a/games-arcade/gish-demo/ChangeLog
+++ b/games-arcade/gish-demo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/gish-demo
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/gish-demo/ChangeLog,v 1.11 2006/10/02 08:01:14 mr_bones_ Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gish-demo/ChangeLog,v 1.12 2009/03/09 17:03:52 mr_bones_ Exp $
+
+ 09 Mar 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ gish-demo-1.0.0.ebuild:
+ make it use the newer openal (patch from Colin Macdonald via bug #261496)
02 Oct 2006; Michael Sterrett <mr_bones_@gentoo.org> files/gish-wrapper,
gish-demo-1.0.0.ebuild:
diff --git a/games-arcade/gish-demo/gish-demo-1.0.0.ebuild b/games-arcade/gish-demo/gish-demo-1.0.0.ebuild
index 51d2b5a7887b..e63e1580d3d9 100644
--- a/games-arcade/gish-demo/gish-demo-1.0.0.ebuild
+++ b/games-arcade/gish-demo/gish-demo-1.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/gish-demo/gish-demo-1.0.0.ebuild,v 1.13 2007/04/26 15:39:15 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gish-demo/gish-demo-1.0.0.ebuild,v 1.14 2009/03/09 17:03:52 mr_bones_ Exp $
inherit eutils multilib games
@@ -16,7 +16,7 @@ RESTRICT="strip"
QA_EXECSTACK="${GAMES_PREFIX_OPT:1}/${PN}/gish"
RDEPEND="media-libs/libsdl
- media-libs/openal
+ >=media-libs/openal-1.6.372
media-libs/freealut
virtual/opengl
media-libs/libvorbis
@@ -40,6 +40,11 @@ src_install() {
use amd64 && multilib_toolchain_setup x86
dosym /$(get_libdir)/libc.so.6 "${dir}"/libssl.so.4
dosym /$(get_libdir)/libc.so.6 "${dir}"/libcrypto.so.4
+
+ # it wants libopenal.so.0 but seems to work with libopenal.so.1
+ # (tested with media-libs/openal-1.6.372)
+ dosym /usr/$(get_libdir)/libopenal.so.1 "${dir}"/libopenal.so.0
+
exeinto "${dir}"
doexe "${FILESDIR}"/gish-wrapper || die "doexe failed"