summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-07-21 02:12:53 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-07-21 02:12:53 +0000
commite160c09914bbad04a8f13760409a92db61f76231 (patch)
tree6c4883a6bf147bd82d4ce3a177818bdd3db0cb6d /games-arcade/frozen-bubble
parentStable on ppc. (Manifest recommit) (diff)
downloadgentoo-2-e160c09914bbad04a8f13760409a92db61f76231.tar.gz
gentoo-2-e160c09914bbad04a8f13760409a92db61f76231.tar.bz2
gentoo-2-e160c09914bbad04a8f13760409a92db61f76231.zip
nick the patch from debian (bug #57372)
Diffstat (limited to 'games-arcade/frozen-bubble')
-rw-r--r--games-arcade/frozen-bubble/ChangeLog6
-rw-r--r--games-arcade/frozen-bubble/files/fb-sdlperl-deb.patch40
-rw-r--r--games-arcade/frozen-bubble/frozen-bubble-1.0.0-r3.ebuild5
3 files changed, 48 insertions, 3 deletions
diff --git a/games-arcade/frozen-bubble/ChangeLog b/games-arcade/frozen-bubble/ChangeLog
index 48771a42bd00..7d450fe3f011 100644
--- a/games-arcade/frozen-bubble/ChangeLog
+++ b/games-arcade/frozen-bubble/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/frozen-bubble
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/frozen-bubble/ChangeLog,v 1.11 2004/06/25 09:06:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/frozen-bubble/ChangeLog,v 1.12 2004/07/21 02:12:53 mr_bones_ Exp $
+
+ 20 Jul 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/fb-sdlperl-deb.patch, frozen-bubble-1.0.0-r3.ebuild:
+ nick the patch from debian (bug #57372)
25 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org>
frozen-bubble-1.0.0-r3.ebuild:
diff --git a/games-arcade/frozen-bubble/files/fb-sdlperl-deb.patch b/games-arcade/frozen-bubble/files/fb-sdlperl-deb.patch
new file mode 100644
index 000000000000..f58a51d5b0af
--- /dev/null
+++ b/games-arcade/frozen-bubble/files/fb-sdlperl-deb.patch
@@ -0,0 +1,40 @@
+--- /usr/games/frozen-bubble 2003-06-13 09:46:09.000000000 -0300
++++ frozen-bubble 2004-05-31 00:46:31.000000000 -0300
+@@ -308,7 +308,11 @@
+ sub add_image($) {
+ my $file = "$FPATH/gfx/$_[0]";
+ my $img = SDL::Surface->new(-name => $file);
+- $img->{-surface} or die "FATAL: Couldn't load `$file' into a SDL::Surface.\n";
++ if (UNIVERSAL::isa($img, "HASH")) {
++ $img->{-surface} or die "FATAL: Couldn't load `$file' into a SDL::Surface.\n";
++ } else {
++ $img or die "FATAL: Couldn't load `$file' into a SDL::Surface.\n";
++ }
+ add_default_rect($img);
+ return $img;
+ }
+@@ -1476,7 +1480,11 @@
+ }
+
+ put_image($imgbin{hiscore_frame}, $high_posx - 7, $high_posy - 6);
+- fb_c_stuff::shrink($app->{-surface}, $background->display_format->{-surface}, $high_posx, $high_posy, $high_rect->{-rect}, 4);
++ if (UNIVERSAL::isa($app, "HASH")) {
++ fb_c_stuff::shrink($app->{-surface}, $background->display_format->{-surface}, $high_posx, $high_posy, $high_rect->{-rect}, 4);
++ } else {
++ fb_c_stuff::shrink($$app, ${$background->display_format}, $high_posx, $high_posy, $$high_rect, 4);
++ }
+ $centered_print->($high_posx, $high_posy, $high->{name});
+ $centered_print->($high_posx, $high_posy+20, $high->{level} eq 'WON' ? "WON!" : "LVL-".$high->{level});
+ my $min = int($high->{time}/60);
+@@ -1644,8 +1652,10 @@
+ if ($graphics_level == 1) {
+ $background->blit($apprects{main}, $app, $apprects{main});
+ $app->flip;
+- } else {
++ } elsif (UNIVERSAL::isa($app, "HASH")) {
+ fb_c_stuff::effect($app->{-surface}, $background->display_format->{-surface});
++ } else {
++ fb_c_stuff::effect($$app, ${$background->display_format});
+ }
+
+ $display_on_app_disabled = 0;
diff --git a/games-arcade/frozen-bubble/frozen-bubble-1.0.0-r3.ebuild b/games-arcade/frozen-bubble/frozen-bubble-1.0.0-r3.ebuild
index 050bf8130a61..2f90b6e952b7 100644
--- a/games-arcade/frozen-bubble/frozen-bubble-1.0.0-r3.ebuild
+++ b/games-arcade/frozen-bubble/frozen-bubble-1.0.0-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/frozen-bubble/frozen-bubble-1.0.0-r3.ebuild,v 1.17 2004/07/16 22:36:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/frozen-bubble/frozen-bubble-1.0.0-r3.ebuild,v 1.18 2004/07/21 02:12:53 mr_bones_ Exp $
-inherit perl-module games
+inherit eutils perl-module games
NET_CLIENT_P=frozen-bubble-client-0.0.3
NET_SERVER_P=frozen-bubble-server-0.0.3
@@ -28,6 +28,7 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd ${S}
+ epatch "${FILESDIR}/fb-sdlperl-deb.patch"
sed -i \
-e 's:INSTALLDIRS=.*:PREFIX=${D}/usr:' \
c_stuff/Makefile \