summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-02-20 19:16:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-02-20 19:16:16 +0000
commit2b4cd399d13014389892f1568ca0b8999fa58277 (patch)
tree2f763a4d33e37d091d44c58a573da19d065a83a4 /games-arcade/frozen-bubble
parentRevbump adding patches for Qt 4.8 SSL compatibility. Fix bug #398791, thanks ... (diff)
downloadgentoo-2-2b4cd399d13014389892f1568ca0b8999fa58277.tar.gz
gentoo-2-2b4cd399d13014389892f1568ca0b8999fa58277.tar.bz2
gentoo-2-2b4cd399d13014389892f1568ca0b8999fa58277.zip
Version bump wrt #388911 by Ralf Mayer
(Portage version: 2.2.0_alpha87/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade/frozen-bubble')
-rw-r--r--games-arcade/frozen-bubble/ChangeLog8
-rw-r--r--games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1.ebuild83
2 files changed, 90 insertions, 1 deletions
diff --git a/games-arcade/frozen-bubble/ChangeLog b/games-arcade/frozen-bubble/ChangeLog
index a433403c5338..d3e8d9a620ed 100644
--- a/games-arcade/frozen-bubble/ChangeLog
+++ b/games-arcade/frozen-bubble/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/frozen-bubble
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/frozen-bubble/ChangeLog,v 1.41 2012/01/30 22:33:57 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/frozen-bubble/ChangeLog,v 1.42 2012/02/20 19:16:16 ssuominen Exp $
+
+*frozen-bubble-2.2.1_beta1 (20 Feb 2012)
+
+ 20 Feb 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +frozen-bubble-2.2.1_beta1.ebuild:
+ Version bump wrt #388911 by Ralf Mayer
30 Jan 2012; Samuli Suominen <ssuominen@gentoo.org>
frozen-bubble-2.2.0.ebuild:
diff --git a/games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1.ebuild b/games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1.ebuild
new file mode 100644
index 000000000000..64a6f9cf39d1
--- /dev/null
+++ b/games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1.ebuild,v 1.1 2012/02/20 19:16:16 ssuominen Exp $
+
+EAPI=2
+
+MY_P=${P/_/-}
+
+inherit eutils gnome2-utils perl-module games
+
+DESCRIPTION="A Puzzle Bubble clone written in perl (now with network support)"
+HOMEPAGE="http://www.frozen-bubble.org/"
+SRC_URI="http://www.frozen-bubble.org/data/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.12
+ >=dev-libs/glib-2
+ >=dev-perl/Alien-SDL-1.413
+ dev-perl/Compress-Bzip2
+ dev-perl/File-ShareDir
+ dev-perl/File-Which
+ >=dev-perl/SDL-2.511
+ media-libs/sdl-image[gif,png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-pango
+ media-libs/sdl-ttf
+ virtual/libiconv
+ virtual/perl-Getopt-Long
+ virtual/perl-IO"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-perl/locale-maketext-lexicon
+ virtual/perl-ExtUtils-CBuilder
+ virtual/perl-ExtUtils-ParseXS
+ virtual/perl-Module-Build"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ perl-module_src_configure
+}
+
+src_compile() {
+ perl-module_src_compile
+}
+
+src_install() {
+ mydoc="AUTHORS Changes HISTORY README" perl-module_src_install
+
+ dodir "${GAMES_BINDIR}"
+ mv -vf "${D}"/usr/bin/f* "${D}/${GAMES_BINDIR}" || die
+
+ newdoc server/README README.server
+ newdoc server/init/README README.server.init
+
+ local res
+ for res in 16 32 48 64; do
+ insinto /usr/share/icons/hicolor/${res}x${res}/apps
+ newins share/icons/frozen-bubble-icon-${res}x${res}.png ${PN}.png
+ done
+
+ make_desktop_entry ${PN} Frozen-Bubble
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}