summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-06-12 04:07:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-06-12 04:07:32 +0000
commit06e282e91f646408e67165a5de67ab255ed2f175 (patch)
tree1f0a26a6dff056acb28d950dad096224fbcc7ae3 /games-arcade/briquolo
parentResolve bug #225671 and also clean up USE flags to better represent the new 1... (diff)
downloadgentoo-2-06e282e91f646408e67165a5de67ab255ed2f175.tar.gz
gentoo-2-06e282e91f646408e67165a5de67ab255ed2f175.tar.bz2
gentoo-2-06e282e91f646408e67165a5de67ab255ed2f175.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-arcade/briquolo')
-rw-r--r--games-arcade/briquolo/ChangeLog8
-rw-r--r--games-arcade/briquolo/briquolo-0.5.7.ebuild58
-rw-r--r--games-arcade/briquolo/files/briquolo-0.5.7-gcc43.patch81
3 files changed, 146 insertions, 1 deletions
diff --git a/games-arcade/briquolo/ChangeLog b/games-arcade/briquolo/ChangeLog
index 5f06ae02bd90..badd02c052e3 100644
--- a/games-arcade/briquolo/ChangeLog
+++ b/games-arcade/briquolo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/briquolo
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/briquolo/ChangeLog,v 1.15 2008/04/30 19:07:25 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/briquolo/ChangeLog,v 1.16 2008/06/12 04:07:32 mr_bones_ Exp $
+
+*briquolo-0.5.7 (12 Jun 2008)
+
+ 12 Jun 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/briquolo-0.5.7-gcc43.patch, +briquolo-0.5.7.ebuild:
+ version bump
30 Apr 2008; Tristan Heaven <nyhm@gentoo.org>
+files/briquolo-0.5.6-gcc43.patch, briquolo-0.5.6.ebuild:
diff --git a/games-arcade/briquolo/briquolo-0.5.7.ebuild b/games-arcade/briquolo/briquolo-0.5.7.ebuild
new file mode 100644
index 000000000000..05a3e487174d
--- /dev/null
+++ b/games-arcade/briquolo/briquolo-0.5.7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/briquolo/briquolo-0.5.7.ebuild,v 1.1 2008/06/12 04:07:32 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Breakout with 3D representation based on OpenGL"
+HOMEPAGE="http://briquolo.free.fr/en/index.html"
+SRC_URI="http://briquolo.free.fr/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="virtual/opengl
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/libpng
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ # no thanks we'll take care of it.
+ sed -i \
+ -e '/^SUBDIRS/s/desktop//' \
+ Makefile.in \
+ || die "sed Makefile.in failed"
+ sed -i \
+ -e "/CXXFLAGS/s:-O3:${CXXFLAGS}:" \
+ -e 's:=.*share/locale:=/usr/share/locale:' \
+ configure \
+ || die "sed configure failed"
+ sed -i \
+ -e 's:$(datadir)/locale:/usr/share/locale:' \
+ po/Makefile.in.in \
+ || die "sed Makefile.in.in failed"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable nls) || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+ doicon desktop/briquolo.svg
+ make_desktop_entry briquolo Briquolo
+ prepgamesdirs
+}
diff --git a/games-arcade/briquolo/files/briquolo-0.5.7-gcc43.patch b/games-arcade/briquolo/files/briquolo-0.5.7-gcc43.patch
new file mode 100644
index 000000000000..13e932a1c69e
--- /dev/null
+++ b/games-arcade/briquolo/files/briquolo-0.5.7-gcc43.patch
@@ -0,0 +1,81 @@
+diff -ru src.orig/Constante.cpp src/Constante.cpp
+--- src.orig/Constante.cpp 2008-03-22 05:40:33.000000000 -0400
++++ src/Constante.cpp 2008-06-11 23:16:46.000000000 -0400
+@@ -27,6 +27,7 @@
+ #define DATADIR_BRIQUOLO "./"
+ #define PACKAGE "briquolo"
+ #endif
++#include <cstdlib>
+
+ #ifdef WIN32
+ #define WIN32_LEAN_AND_MEAN
+diff -ru src.orig/MOGL/MOGL_EnsembleObjet.cpp src/MOGL/MOGL_EnsembleObjet.cpp
+--- src.orig/MOGL/MOGL_EnsembleObjet.cpp 2008-03-24 09:12:36.000000000 -0400
++++ src/MOGL/MOGL_EnsembleObjet.cpp 2008-06-11 23:17:11.000000000 -0400
+@@ -24,7 +24,8 @@
+ #include "MOGL_Armature.h"
+ #include "MOGL_Peau.h"
+ //#include
+-#include <stdio.h>
++#include <cstdio>
++#include <cstring>
+
+ //#include <mmsystem.h>
+
+diff -ru src.orig/MOGL/MOGL_GestionnaireObjet.cpp src/MOGL/MOGL_GestionnaireObjet.cpp
+--- src.orig/MOGL/MOGL_GestionnaireObjet.cpp 2008-03-24 08:56:13.000000000 -0400
++++ src/MOGL/MOGL_GestionnaireObjet.cpp 2008-06-11 23:18:45.000000000 -0400
+@@ -21,6 +21,7 @@
+ *****************************************************************************/
+ #include "../I18n.h"
+ #include "MOGL_GestionnaireObjet.h"
++#include <cstring>
+
+ bool MOGL_GestionnaireObjet::ChargerObjetASCTriangle(const char * p_NomFichier, const MOGL_GestionnaireTexture & p_GM,
+ MOGL_Objet & p_Objet)
+diff -ru src.orig/MOGL/MOGL_GestionnaireObjet.h src/MOGL/MOGL_GestionnaireObjet.h
+--- src.orig/MOGL/MOGL_GestionnaireObjet.h 2006-03-07 15:31:24.000000000 -0500
++++ src/MOGL/MOGL_GestionnaireObjet.h 2008-06-11 23:20:07.000000000 -0400
+@@ -24,7 +24,8 @@
+
+ #include <vector>
+ #include <iostream>
+-#include <stdio.h>
++#include <cstdio>
++#include <cstring>
+
+ #include "MOGL_Triangle.h"
+ #include "MOGL_Objet.h"
+diff -ru src.orig/MOGL/MOGL_Image.h src/MOGL/MOGL_Image.h
+--- src.orig/MOGL/MOGL_Image.h 2006-03-07 15:53:11.000000000 -0500
++++ src/MOGL/MOGL_Image.h 2008-06-11 23:20:51.000000000 -0400
+@@ -24,6 +24,7 @@
+
+ #include "MOGL_Structure.h"
+ #include <string>
++#include <cstring>
+
+ using namespace std;
+
+diff -ru src.orig/MOGL/MOGL_Objet.cpp src/MOGL/MOGL_Objet.cpp
+--- src.orig/MOGL/MOGL_Objet.cpp 2006-03-07 15:31:24.000000000 -0500
++++ src/MOGL/MOGL_Objet.cpp 2008-06-11 23:21:05.000000000 -0400
+@@ -20,6 +20,7 @@
+ *
+ *****************************************************************************/
+ #include "MOGL_Objet.h"
++#include <cstdlib>
+
+ //MOGL_Objet::MOGL_Objet(): MOGL_ObjetAbstrait(), MOGL_ElementArbre()
+ MOGL_Objet::MOGL_Objet(): MOGL_Noeud(), _ModifieTriangle(true), _ModifieStrip(true),
+diff -ru src.orig/MOGL/MOGL_Peau.cpp src/MOGL/MOGL_Peau.cpp
+--- src.orig/MOGL/MOGL_Peau.cpp 2006-03-07 15:31:24.000000000 -0500
++++ src/MOGL/MOGL_Peau.cpp 2008-06-11 23:21:17.000000000 -0400
+@@ -20,6 +20,7 @@
+ *
+ *****************************************************************************/
+ #include "MOGL_Peau.h"
++#include <cstdlib>
+
+ MOGL_Peau::MOGL_Peau(): MOGL_Noeud(), _ModifieTriangle(true)
+ {