summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-09-27 18:24:43 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-09-27 18:24:43 +0000
commitff61f435f7f53066bf79e8aa71e985b2ac20dcdd (patch)
treef0b01fdc1087ec846aa8a39bf801394b7bca3f4f /games-action
parentRemoving the shipped libssl version, since it is vulnerable to RSA forgery. ... (diff)
downloadgentoo-2-ff61f435f7f53066bf79e8aa71e985b2ac20dcdd.tar.gz
gentoo-2-ff61f435f7f53066bf79e8aa71e985b2ac20dcdd.tar.bz2
gentoo-2-ff61f435f7f53066bf79e8aa71e985b2ac20dcdd.zip
Move games_pkg_setup to the end of pkg_setup
(Portage version: 2.1.2_pre1-r3)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/powermanga/powermanga-0.79.ebuild4
-rw-r--r--games-action/powermanga/powermanga-0.80.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/games-action/powermanga/powermanga-0.79.ebuild b/games-action/powermanga/powermanga-0.79.ebuild
index 38752b773334..7f925e65a1e4 100644
--- a/games-action/powermanga/powermanga-0.79.ebuild
+++ b/games-action/powermanga/powermanga-0.79.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/powermanga-0.79.ebuild,v 1.5 2006/04/13 19:49:56 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/powermanga-0.79.ebuild,v 1.6 2006/09/27 18:24:43 nyhm Exp $
inherit games
@@ -18,12 +18,12 @@ DEPEND="virtual/libc
media-libs/sdl-mixer"
pkg_setup() {
- games_pkg_setup
if ! built_with_use media-libs/sdl-mixer mikmod
then
eerror "${PN} needs sdl-mixer compiled with mikmod use-flag enabled!"
die "sdl-mixer without mikmod detected"
fi
+ games_pkg_setup
}
src_compile() {
diff --git a/games-action/powermanga/powermanga-0.80.ebuild b/games-action/powermanga/powermanga-0.80.ebuild
index 986bd065cb1f..a10ed2ff3f03 100644
--- a/games-action/powermanga/powermanga-0.80.ebuild
+++ b/games-action/powermanga/powermanga-0.80.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/powermanga-0.80.ebuild,v 1.3 2006/09/20 16:44:40 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/powermanga-0.80.ebuild,v 1.4 2006/09/27 18:24:43 nyhm Exp $
inherit games
@@ -17,11 +17,11 @@ DEPEND=">=media-libs/libsdl-0.11.0
media-libs/sdl-mixer"
pkg_setup() {
- games_pkg_setup
if ! built_with_use media-libs/sdl-mixer mikmod ; then
eerror "${PN} needs sdl-mixer compiled with mikmod use-flag enabled!"
die "sdl-mixer without mikmod detected"
fi
+ games_pkg_setup
}
src_unpack() {