summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-04-16 21:10:12 +0000
committerMike Frysinger <vapier@gentoo.org>2011-04-16 21:10:12 +0000
commite397cddb5ecb7b90ce6fc28fbf22a83c741c267d (patch)
treec19e38ecafbdd02d257d0fdcb57dbbea64be347c /games-action
parentFirst release on the 2.5 branch, no longer masked. Removed old ebuilds. (diff)
downloadgentoo-2-e397cddb5ecb7b90ce6fc28fbf22a83c741c267d.tar.gz
gentoo-2-e397cddb5ecb7b90ce6fc28fbf22a83c741c267d.tar.bz2
gentoo-2-e397cddb5ecb7b90ce6fc28fbf22a83c741c267d.zip
New package.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/trine-bin/ChangeLog10
-rw-r--r--games-action/trine-bin/metadata.xml5
-rw-r--r--games-action/trine-bin/trine-bin-1.08.ebuild63
3 files changed, 78 insertions, 0 deletions
diff --git a/games-action/trine-bin/ChangeLog b/games-action/trine-bin/ChangeLog
new file mode 100644
index 000000000000..e2cc4079c47c
--- /dev/null
+++ b/games-action/trine-bin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-action/trine-bin
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/trine-bin/ChangeLog,v 1.1 2011/04/16 21:10:12 vapier Exp $
+
+*trine-bin-1.08 (16 Apr 2011)
+
+ 16 Apr 2011; Mike Frysinger <vapier@gentoo.org> +trine-bin-1.08.ebuild,
+ +metadata.xml:
+ New package.
+
diff --git a/games-action/trine-bin/metadata.xml b/games-action/trine-bin/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/trine-bin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/trine-bin/trine-bin-1.08.ebuild b/games-action/trine-bin/trine-bin-1.08.ebuild
new file mode 100644
index 000000000000..78cec9546a56
--- /dev/null
+++ b/games-action/trine-bin/trine-bin-1.08.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/trine-bin/trine-bin-1.08.ebuild,v 1.1 2011/04/16 21:10:12 vapier Exp $
+
+# these are ELFs that include a ZIP (504b0304) appended to it
+# dd if=Trine.64.run of=Trine.64.zip ibs=$((0x342a8)) skip=1
+# dd if=Trine.32.run of=Trine.32.zip ibs=$((0x31c24)) skip=1
+# but `unzip` will skip the ELF at the start. both ELFs contain
+# the same zip appended, so only need to hash one of them.
+
+inherit games eutils
+
+DESCRIPTION="a physics-based action game where diff characters allow diff solutions to challenges"
+HOMEPAGE="http://trine-thegame.com/"
+SRC_URI="Trine.64.run"
+
+LICENSE="trine-eula"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch"
+
+DEPEND="app-arch/unzip"
+RDEPEND="sys-libs/glibc"
+
+S=${WORKDIR}
+
+d="${GAMES_PREFIX_OPT}/${PN}"
+QA_PRESTRIPPED="${d#/}/trine-launcher ${d#/}/trine-bin ${d#/}/lib*/lib*.so*"
+
+pkg_nofetch() {
+ einfo "Fetch ${SRC_URI} and put it into ${DISTDIR}"
+ einfo "See http://www.humblebundle.com/ for more info."
+}
+
+src_unpack() {
+ # manually run unzip as the initial seek causes it to exit(1)
+ unzip -q "${DISTDIR}/${A}"
+}
+
+src_install() {
+ local b bb
+ local sfx=$(use x86 && echo 32 || echo 64)
+
+ doicon Trine.xpm || die
+ for b in bin launcher ; do
+ bb="trine-${b}"
+ exeinto ${d}
+ newexe ${bb}${sfx} ${bb} || die
+ games_make_wrapper ${bb} "./${bb}" "${d}" || die
+ make_desktop_entry ${bb} "Trine ${b}" Trine
+ done
+
+ exeinto ${d}/lib${sfx}
+ doexe lib${sfx}/* || die
+
+ insinto ${d}
+ doins -r binds config data dev profiles *.fbz *.glade trine-logo.png || die
+
+ dodoc Trine_Manual_linux.pdf Trine_updates.txt
+
+ prepgamesdirs
+}