summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-01-09 21:54:12 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-01-09 21:54:12 +0000
commitdd5c6fb5492178336ff524997fa9e0a071f5ccd8 (patch)
treea1c3067a469aaa3dc55ec984d2030eca951ddbbc /games-action
parentInitial import. Ebuild by Paul Bredbury <brebs@sent.com>. Closing bug #137309. (diff)
downloadgentoo-2-dd5c6fb5492178336ff524997fa9e0a071f5ccd8.tar.gz
gentoo-2-dd5c6fb5492178336ff524997fa9e0a071f5ccd8.tar.bz2
gentoo-2-dd5c6fb5492178336ff524997fa9e0a071f5ccd8.zip
Revision bump to use the new split data/demodata.
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/d2x/ChangeLog9
-rw-r--r--games-action/d2x/d2x-0.2.5-r3.ebuild81
-rw-r--r--games-action/d2x/files/digest-d2x-0.2.5-r24
-rw-r--r--games-action/d2x/files/digest-d2x-0.2.5-r33
4 files changed, 94 insertions, 3 deletions
diff --git a/games-action/d2x/ChangeLog b/games-action/d2x/ChangeLog
index fde8aa8bea60..a5f22ab94122 100644
--- a/games-action/d2x/ChangeLog
+++ b/games-action/d2x/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/d2x
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.16 2006/10/24 22:31:42 wolf31o2 Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.17 2007/01/09 21:54:12 wolf31o2 Exp $
+
+*d2x-0.2.5-r3 (09 Jan 2007)
+
+ 09 Jan 2007; Chris Gianelloni <wolf31o2@gentoo.org> +d2x-0.2.5-r3.ebuild:
+ Revision bump to use the new split data/demodata.
24 Oct 2006; Chris Gianelloni <wolf31o2@gentoo.org> d2x-0.2.5-r2.ebuild:
Moved cdrom_get_cds to src_unpack since binary packages don't require the
diff --git a/games-action/d2x/d2x-0.2.5-r3.ebuild b/games-action/d2x/d2x-0.2.5-r3.ebuild
new file mode 100644
index 000000000000..e66bb40d5fe5
--- /dev/null
+++ b/games-action/d2x/d2x-0.2.5-r3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r3.ebuild,v 1.1 2007/01/09 21:54:12 wolf31o2 Exp $
+
+inherit eutils flag-o-matic games
+
+DESCRIPTION="Descent 2 engine from Icculus"
+HOMEPAGE="http://icculus.org/d2x/"
+SRC_URI="http://icculus.org/d2x/src/${P}.tar.gz"
+
+LICENSE="D1X"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="cdinstall debug opengl ggi svga"
+
+COMMON="media-libs/libsdl
+ media-libs/sdl-image
+ opengl? ( virtual/opengl )
+ ggi? ( media-libs/libggi )
+ svga? ( media-libs/svgalib )"
+RDEPEND="${COMMON}
+ cdinstall? ( games-action/descent2-data )
+ !cdinstall? ( games-action/descent2-demodata )"
+DEPEND="${COMMON}
+ x86? ( dev-lang/nasm )"
+
+dir=${GAMES_DATADIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PV}-shellscripts.patch"
+ epatch "${FILESDIR}/${P}-dofpcalcs-macro.patch"
+}
+
+src_compile() {
+ local defflags myconf ren renconf
+
+ # --disable-network --enable-console
+ local myconf="$(use_enable x86 assembler)"
+ use debug \
+ && myconf="${myconf} --enable-debug --disable-release" \
+ || myconf="${myconf} --disable-debug --enable-release"
+ # we do this because each of the optional guys define the same functions
+ # in gr, thus when they go to link they cause redefine errors ...
+ # we build each by it self, save the binary file, clean up, and start over
+ mkdir my-bins
+ for ren in sdl $(useq opengl && echo opengl) \
+ $(useq svga && echo svga) $(useq ggi && echo ggi) ; do
+ [ "${ren}" == "sdl" ] \
+ && renconf="" \
+ || renconf="--with-${ren}"
+ [ "${ren}" == "svga" ] \
+ && defflags="-DSVGALIB_INPUT" \
+ || defflags=""
+ make distclean
+ egamesconf \
+ ${myconf} \
+ ${renconf} \
+ --datadir="${GAMES_DATADIR_BASE}" \
+ || die "conf ${ren}"
+ emake CXXFLAGS="${CXXFLAGS} ${defflags}" || die "build ${ren}"
+ mv d2x* my-bins/
+ done
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dogamesbin my-bins/* || die "dogamesbin failed"
+ dodoc AUTHORS ChangeLog NEWS README* TODO readme.txt
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog "d2x-rebirth and d2x-xl are more up-to-date versions of this game."
+ echo
+}
diff --git a/games-action/d2x/files/digest-d2x-0.2.5-r2 b/games-action/d2x/files/digest-d2x-0.2.5-r2
index 3bae26d927d8..c7ba9d3119d2 100644
--- a/games-action/d2x/files/digest-d2x-0.2.5-r2
+++ b/games-action/d2x/files/digest-d2x-0.2.5-r2
@@ -1,2 +1,4 @@
-MD5 79474db1ff4f0ae1fb76d691701cc560 d2x-0.2.5.tar.gz 2015249
MD5 1b952cc4a4419e24d230589027d73490 d2shar10.tar.gz 4311406
+MD5 79474db1ff4f0ae1fb76d691701cc560 d2x-0.2.5.tar.gz 2015249
+RMD160 c27f16f52eaa7a3742cd7b50307bd747ab79c96f d2x-0.2.5.tar.gz 2015249
+SHA256 906d2f1703f68d27db6c20f98d9a85eea4b2e207faa536cf3362af9e5da0375b d2x-0.2.5.tar.gz 2015249
diff --git a/games-action/d2x/files/digest-d2x-0.2.5-r3 b/games-action/d2x/files/digest-d2x-0.2.5-r3
new file mode 100644
index 000000000000..b193c0063693
--- /dev/null
+++ b/games-action/d2x/files/digest-d2x-0.2.5-r3
@@ -0,0 +1,3 @@
+MD5 79474db1ff4f0ae1fb76d691701cc560 d2x-0.2.5.tar.gz 2015249
+RMD160 c27f16f52eaa7a3742cd7b50307bd747ab79c96f d2x-0.2.5.tar.gz 2015249
+SHA256 906d2f1703f68d27db6c20f98d9a85eea4b2e207faa536cf3362af9e5da0375b d2x-0.2.5.tar.gz 2015249