summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-02-06 23:27:31 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-02-06 23:27:31 +0000
commitaf3951584e65c01d96b5b34463eef5674b2124f8 (patch)
treef1ba3f51e64c8d12f61c91abd3cc25299c9b01f6 /games-action
parentAdd ~x86-fbsd wrt bug #430072 (diff)
downloadgentoo-2-af3951584e65c01d96b5b34463eef5674b2124f8.tar.gz
gentoo-2-af3951584e65c01d96b5b34463eef5674b2124f8.tar.bz2
gentoo-2-af3951584e65c01d96b5b34463eef5674b2124f8.zip
version bump wrt #369419
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/d1x-rebirth/ChangeLog8
-rw-r--r--games-action/d1x-rebirth/d1x-rebirth-0.57.3.ebuild111
-rw-r--r--games-action/d1x-rebirth/files/d1x-rebirth-0.57.3-flags.patch21
-rw-r--r--games-action/d1x-rebirth/metadata.xml9
4 files changed, 147 insertions, 2 deletions
diff --git a/games-action/d1x-rebirth/ChangeLog b/games-action/d1x-rebirth/ChangeLog
index c3aa02dc987e..d9c9997cfe5d 100644
--- a/games-action/d1x-rebirth/ChangeLog
+++ b/games-action/d1x-rebirth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/d1x-rebirth
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d1x-rebirth/ChangeLog,v 1.9 2013/01/31 08:45:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d1x-rebirth/ChangeLog,v 1.10 2013/02/06 23:27:30 hasufell Exp $
+
+*d1x-rebirth-0.57.3 (06 Feb 2013)
+
+ 06 Feb 2013; Julian Ospald <hasufell@gentoo.org> +d1x-rebirth-0.57.3.ebuild,
+ +files/d1x-rebirth-0.57.3-flags.patch:
+ version bump wrt #369419
31 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org>
-d1x-rebirth-0.55.1.ebuild:
diff --git a/games-action/d1x-rebirth/d1x-rebirth-0.57.3.ebuild b/games-action/d1x-rebirth/d1x-rebirth-0.57.3.ebuild
new file mode 100644
index 000000000000..ffedd8906e95
--- /dev/null
+++ b/games-action/d1x-rebirth/d1x-rebirth-0.57.3.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/d1x-rebirth/d1x-rebirth-0.57.3.ebuild,v 1.1 2013/02/06 23:27:30 hasufell Exp $
+
+EAPI=5
+
+CDROM_OPTIONAL="yes"
+inherit eutils cdrom scons-utils games
+
+DV=1
+MY_P=${PN}_v${PV}-src
+DESCRIPTION="Descent Rebirth - enhanced Descent ${DV} engine"
+HOMEPAGE="http://www.dxx-rebirth.com/"
+SRC_URI="mirror://sourceforge/dxx-rebirth/${MY_P}.tar.gz
+ http://www.dxx-rebirth.com/download/dxx/res/d1xrdata.zip
+ http://www.dxx-rebirth.com/download/dxx/res/dxx-rebirth_icons.zip
+ opl3-musicpack? ( http://www.dxx-rebirth.com/download/dxx/res/d${DV}xr-opl3-music.zip )
+ sc55-musicpack? ( http://www.dxx-rebirth.com/download/dxx/res/d${DV}xr-sc55-music.zip ) cdinstall? ( http://www.dxx-rebirth.com/download/dxx/res/d1datapt.zip )
+ linguas_de? ( http://www.dxx-rebirth.com/download/dxx/res/d${DV}xr-briefings-ger.zip )"
+
+LICENSE="D1X GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cdinstall debug demo ipv6 linguas_de +music opengl opl3-musicpack sc55-musicpack"
+REQUIRED_USE="?? ( cdinstall demo )
+ ?? ( opl3-musicpack sc55-musicpack )
+ opl3-musicpack? ( music )
+ sc55-musicpack? ( music )"
+
+RDEPEND="dev-games/physfs[hog,zip]
+ media-libs/libsdl[X,audio,joystick,opengl?,video]
+ cdinstall? ( !games-action/descent1-demodata )
+ music? (
+ media-libs/sdl-mixer[timidity]
+ )
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+PDEPEND="demo? ( games-action/descent1-demodata )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz dxx-rebirth_icons.zip
+ if use cdinstall ; then
+ unpack d1datapt.zip
+ cdrom_get_cds descent/descent.hog
+ mkdir "${S}"/Data
+ cp \
+ ${CDROM_ROOT}/descent/descent.{hog,pig} \
+ ${CDROM_ROOT}/descent/chaos.{hog,msn} \
+ "${S}"/Data \
+ || die "cp failed"
+ fi
+}
+
+src_prepare() {
+ if use cdinstall ; then
+ cd Data
+ patch -p0 < "${WORKDIR}"/d1datapt/descent.hog.diff descent.hog
+ patch -p0 < "${WORKDIR}"/d1datapt/descent.pig.diff descent.pig
+ fi
+ epatch "${FILESDIR}"/${P}-flags.patch
+}
+
+src_compile() {
+ escons \
+ verbosebuild=1 \
+ sharepath="${GAMES_DATADIR}/d${DV}x" \
+ $(use_scons ipv6) \
+ $(use_scons music sdlmixer) \
+ $(use_scons debug) \
+ $(use_scons opengl) \
+ || die
+}
+
+src_install() {
+ dodoc {CHANGELOG,INSTALL,README,RELEASE-NOTES}.txt
+
+ insinto "${GAMES_DATADIR}/d${DV}x"
+ doins "${DISTDIR}"/d1xrdata.zip
+ # None of the following zip files need to be extracted.
+ use linguas_de && doins "${DISTDIR}"/d${DV}xr-briefings-ger.zip
+ use opl3-musicpack && doins "${DISTDIR}"/d${DV}xr-opl3-music.zip
+ use sc55-musicpack && doins "${DISTDIR}"/d${DV}xr-sc55-music.zip
+
+ if use cdinstall ; then
+ doins Data/descent.{hog,pig}
+ insinto "${GAMES_DATADIR}"/d${DV}x/missions
+ doins Data/chaos.{hog,msn}
+ fi
+ doicon "${WORKDIR}/${PN}.xpm"
+
+ dogamesbin d${DV}x-rebirth
+ make_desktop_entry d${DV}x-rebirth "Descent ${DV} Rebirth"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if ! use cdinstall ; then
+ echo
+ elog "To play the full game enable USE=\"cdinstall\" or manually "
+ elog "copy the files to ${GAMES_DATADIR}/d${DV}x."
+ elog "See /usr/share/doc/${PF}/INSTALL.txt for details."
+ echo
+ fi
+}
diff --git a/games-action/d1x-rebirth/files/d1x-rebirth-0.57.3-flags.patch b/games-action/d1x-rebirth/files/d1x-rebirth-0.57.3-flags.patch
new file mode 100644
index 000000000000..b8aaa7235b4a
--- /dev/null
+++ b/games-action/d1x-rebirth/files/d1x-rebirth-0.57.3-flags.patch
@@ -0,0 +1,21 @@
+--- d1x-rebirth_v0.57.3-src/SConstruct
++++ d1x-rebirth_v0.57.3-src/SConstruct
+@@ -390,7 +390,6 @@
+ env.Append(CPPFLAGS = ['-g'])
+ else:
+ env.Append(CPPDEFINES = ['NDEBUG', 'RELEASE'])
+- env.Append(CPPFLAGS = ['-O2'])
+
+ # profiler?
+ if (profiler == 1):
+@@ -419,8 +418,9 @@
+ print '\n'
+
+ env.Append(CPPDEFINES = [('SHAREPATH', '\\"' + str(sharepath) + '\\"')])
++env.Append(LINKFLAGS = [str(lflags)])
+ # finally building program...
+-env.Program(target=str(target), source = common_sources, LIBS = libs, LINKFLAGS = str(lflags))
++env.Program(target=str(target), source = common_sources, LIBS = libs)
+ if (sys.platform != 'darwin'):
+ env.Install(BIN_DIR, str(target))
+ env.Alias('install', BIN_DIR)
diff --git a/games-action/d1x-rebirth/metadata.xml b/games-action/d1x-rebirth/metadata.xml
index 4dff9d2f2763..c5ac5107d867 100644
--- a/games-action/d1x-rebirth/metadata.xml
+++ b/games-action/d1x-rebirth/metadata.xml
@@ -12,6 +12,13 @@ Descent 1 source that was released by Parallax and is based on the D1X source.
<flag name="awe32">Enable AWE32 support</flag>
<flag name="demo">Use the demo data instead of the full game</flag>
<flag name="mixer">Enable mixer support</flag>
- <flag name="mpu401">Enable MPU401 music support</flag>
+ <flag name="mpu401">Enable MPU401 music support</flag>
+ <flag name="music">Support for ingame music</flag>
+ <flag name="linguas_de">Provides German translations for the game's
+ briefings, robot descriptions, and outro of the original campaign</flag>
+ <flag name="opl3-musicpack">Include alternate version of the game's music, recorded
+ with the Yamaha YMF262 OPL3 soundchip</flag>
+ <flag name="sc55-musicpack">Include alternate version of the game's music, recorded
+ with the Roland Sound Canvas SC-55 MIDI module</flag>
</use>
</pkgmetadata>