summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-05-01 22:28:29 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-05-01 22:28:29 +0000
commitaddfebf132c4f9d34d2abf28fd67b4cf47fcb1c6 (patch)
treee46b7e3e8c2058688be2d196f4a5c2eb7514b968 /games-action
parentFix AttributeError: UnixCCompiler instance has no attribute 'compiler_cxx_so' (diff)
downloadgentoo-2-addfebf132c4f9d34d2abf28fd67b4cf47fcb1c6.tar.gz
gentoo-2-addfebf132c4f9d34d2abf28fd67b4cf47fcb1c6.tar.bz2
gentoo-2-addfebf132c4f9d34d2abf28fd67b4cf47fcb1c6.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/violetland/ChangeLog8
-rw-r--r--games-action/violetland/violetland-0.2.10.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/games-action/violetland/ChangeLog b/games-action/violetland/ChangeLog
index c6d55c47d6fb..debb40dc561e 100644
--- a/games-action/violetland/ChangeLog
+++ b/games-action/violetland/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/violetland
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/ChangeLog,v 1.7 2010/04/27 14:48:45 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/ChangeLog,v 1.8 2010/05/01 22:28:29 mr_bones_ Exp $
+
+*violetland-0.2.10 (01 May 2010)
+
+ 01 May 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +violetland-0.2.10.ebuild:
+ version bump
27 Apr 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
violetland-0.2.9.ebuild:
diff --git a/games-action/violetland/violetland-0.2.10.ebuild b/games-action/violetland/violetland-0.2.10.ebuild
new file mode 100644
index 000000000000..3a9283c091be
--- /dev/null
+++ b/games-action/violetland/violetland-0.2.10.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/violetland-0.2.10.ebuild,v 1.1 2010/05/01 22:28:29 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils cmake-utils games
+
+DESCRIPTION="Help a girl by name of Violet to struggle with hordes of monsters."
+HOMEPAGE="http://code.google.com/p/violetland/"
+SRC_URI="http://violetland.googlecode.com/files/${PN}-v${PV}-src.zip"
+
+LICENSE="GPL-3 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[audio,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-ttf
+ x11-libs/libXext
+ x11-libs/libSM
+ virtual/opengl
+ virtual/glu"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}-v${PV}
+
+src_prepare() {
+ sed -i \
+ -e "/README_EN.TXT/d" \
+ -e "/README_RU.TXT/d" \
+ CMakeLists.txt || die "sed failed"
+}
+
+src_configure() {
+ mycmakeargs=(
+ "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
+ "-DDATA_INSTALL_DIR=${GAMES_DATADIR}"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ DOCS="README_EN.TXT CHANGELOG" cmake-utils_src_install
+ newicon icon-light.png ${PN}.png
+ make_desktop_entry ${PN} VioletLand
+ prepgamesdirs
+}