summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-04-18 21:43:33 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-04-18 21:43:33 +0000
commitab7449a4b8e9fa7828983ec133c6c91bda82cd25 (patch)
treeece36a25d4573b066d8228cbeddd4b1cdb0afb12 /games-action
parentx86 stable, bug #409403 (diff)
downloadgentoo-2-ab7449a4b8e9fa7828983ec133c6c91bda82cd25.tar.gz
gentoo-2-ab7449a4b8e9fa7828983ec133c6c91bda82cd25.tar.bz2
gentoo-2-ab7449a4b8e9fa7828983ec133c6c91bda82cd25.zip
add parallel-build patch from Alec Moskvin (bug #335148)
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/teeworlds/ChangeLog5
-rw-r--r--games-action/teeworlds/teeworlds-0.6.1.ebuild46
2 files changed, 36 insertions, 15 deletions
diff --git a/games-action/teeworlds/ChangeLog b/games-action/teeworlds/ChangeLog
index 380a2d7e0f06..1f5d576181b0 100644
--- a/games-action/teeworlds/ChangeLog
+++ b/games-action/teeworlds/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/teeworlds
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/teeworlds/ChangeLog,v 1.6 2012/03/27 15:16:11 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/teeworlds/ChangeLog,v 1.7 2012/04/18 21:43:33 mr_bones_ Exp $
+
+ 18 Apr 2012; Michael Sterrett <mr_bones_@gentoo.org> teeworlds-0.6.1.ebuild:
+ add parallel-build patch from Alec Moskvin (bug #335148)
*teeworlds-0.6.1 (27 Mar 2012)
diff --git a/games-action/teeworlds/teeworlds-0.6.1.ebuild b/games-action/teeworlds/teeworlds-0.6.1.ebuild
index 985a5b92eab0..042a3219f646 100644
--- a/games-action/teeworlds/teeworlds-0.6.1.ebuild
+++ b/games-action/teeworlds/teeworlds-0.6.1.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/teeworlds/teeworlds-0.6.1.ebuild,v 1.1 2012/03/27 15:16:11 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/teeworlds/teeworlds-0.6.1.ebuild,v 1.2 2012/04/18 21:43:33 mr_bones_ Exp $
EAPI=3
-
PYTHON_DEPEND="2"
-
-inherit eutils python games
+inherit eutils python toolchain-funcs games
REVISION="b177-r50edfd37"
@@ -43,10 +41,27 @@ src_prepare() {
# 01 & 02 from pull request: https://github.com/oy/teeworlds/pull/493
EPATCH_SOURCE="${FILESDIR}/${PV}" EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" \
epatch
+
+ cat <<- __EOF__ > "${S}/gentoo.lua"
+ function addSettings(settings)
+ print("Adding Gentoo settings")
+ settings.optimize = 0
+ settings.cc.exe_c = "$(tc-getCC)"
+ settings.cc.exe_cxx = "$(tc-getCXX)"
+ settings.cc.flags_c:Add("${CFLAGS}")
+ settings.cc.flags_cxx:Add("${CXXFLAGS}")
+ settings.link.exe = "$(tc-getCXX)"
+ settings.link.flags:Add("${LDFLAGS}")
+ end
+ __EOF__
+
+ sed -i \
+ -e '/^function build(settings)/a dofile("gentoo.lua") addSettings(settings)' \
+ bam.lua || die
}
src_configure() {
- bam config || die "bam config failed"
+ bam config || die
}
src_compile() {
@@ -65,36 +80,39 @@ src_compile() {
fi
fi
- bam ${myopt} || die "bam failed"
+ # Taken from the libreoffice-3.5.2.2 ebuild
+ local jobs=$(sed -ne 's/.*\(-j[[:space:]]*\|--jobs=\)\([[:digit:]]\+\).*/\2/;T;p' <<< "${MAKEOPTS}")
+
+ bam -a -j ${jobs} ${myopt} || die
}
src_install() {
if use debug; then
- newgamesbin ${PN}_srv_d ${PN}_srv || die "newgamesbin failed"
+ newgamesbin ${PN}_srv_d ${PN}_srv || die
else
- dogamesbin ${PN}_srv || die "dogamesbin failed"
+ dogamesbin ${PN}_srv || die
fi
if ! use dedicated; then
if use debug; then
- newgamesbin ${PN}_d ${PN} || die "newgamesbin failed"
+ newgamesbin ${PN}_d ${PN} || die
else
- dogamesbin ${PN} || die "dogamesbin failed"
+ dogamesbin ${PN} || die
fi
- doicon "${FILESDIR}"/${PN}.xpm || die "doicon failed"
+ doicon "${FILESDIR}"/${PN}.xpm || die
make_desktop_entry ${PN} Teeworlds
insinto "${GAMES_DATADIR}"/${PN}/data
- doins -r data/* || die "doins failed"
+ doins -r data/* || die
else
insinto "${GAMES_DATADIR}"/${PN}/data/maps
- doins -r data/maps/* || die "doins failed"
+ doins -r data/maps/* || die
fi
newinitd "${FILESDIR}"/${PN}-init.d ${PN}
insinto "/etc/${PN}"
doins "${FILESDIR}"/teeworlds_srv.cfg
- dodoc readme.txt || die "dodoc failed"
+ dodoc readme.txt || die
prepgamesdirs
}