summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-07-12 17:42:51 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-07-12 17:42:51 +0000
commita73a718c9049bb48fa9644003640dab7ea719721 (patch)
tree85f27eddefdf8f404b363edf6f3e6853a1d35b19 /games-action
parentAdded ~mips, bug 154882 (diff)
downloadgentoo-2-a73a718c9049bb48fa9644003640dab7ea719721.tar.gz
gentoo-2-a73a718c9049bb48fa9644003640dab7ea719721.tar.bz2
gentoo-2-a73a718c9049bb48fa9644003640dab7ea719721.zip
clean up deps and install (bug #374865)
(Portage version: 2.1.10.3/cvs/Linux i686)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/clanbomber/ChangeLog5
-rw-r--r--games-action/clanbomber/clanbomber-2.1.1.ebuild44
2 files changed, 39 insertions, 10 deletions
diff --git a/games-action/clanbomber/ChangeLog b/games-action/clanbomber/ChangeLog
index 63c419b5d92c..cbfbb6559dd8 100644
--- a/games-action/clanbomber/ChangeLog
+++ b/games-action/clanbomber/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/clanbomber
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/clanbomber/ChangeLog,v 1.14 2011/07/05 05:40:33 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/clanbomber/ChangeLog,v 1.15 2011/07/12 17:42:51 mr_bones_ Exp $
+
+ 12 Jul 2011; Michael Sterrett <mr_bones_@gentoo.org> clanbomber-2.1.1.ebuild:
+ clean up deps and install (bug #374865)
*clanbomber-2.1.1 (05 Jul 2011)
diff --git a/games-action/clanbomber/clanbomber-2.1.1.ebuild b/games-action/clanbomber/clanbomber-2.1.1.ebuild
index 92bedb5d1e40..b4385208e8d3 100644
--- a/games-action/clanbomber/clanbomber-2.1.1.ebuild
+++ b/games-action/clanbomber/clanbomber-2.1.1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/clanbomber/clanbomber-2.1.1.ebuild,v 1.1 2011/07/05 05:40:33 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/clanbomber/clanbomber-2.1.1.ebuild,v 1.2 2011/07/12 17:42:51 mr_bones_ Exp $
EAPI=2
-
-inherit base eutils games
+inherit autotools base eutils flag-o-matic games
DESCRIPTION="Bomberman-like multiplayer game"
HOMEPAGE="http://savannah.nongnu.org/projects/clanbomber/"
@@ -15,18 +14,45 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND="media-libs/sdl-image
+RDEPEND="media-libs/libsdl[audio,joystick,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer
media-libs/sdl-ttf
- media-libs/sdl-gfx"
-RDEPEND="${DEPEND}
- dev-libs/boost"
+ media-libs/sdl-gfx
+ >dev-libs/boost-1.36
+ <dev-libs/boost-1.46
+ media-fonts/dejavu"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog ChangeLog.hg IDEAS NEWS QUOTES README TODO )
+
+src_prepare() {
+ local boost_ver=$(best_version "<dev-libs/boost-1.46")
-DOCS=( AUTHORS ChangeLog ChangeLog.hg IDEAS LICENSE.DEJAVU NEWS QUOTES README
- TODO )
+ boost_ver=${boost_ver/*boost-/}
+ boost_ver=${boost_ver%.*}
+ boost_ver=${boost_ver/./_}
+
+ einfo "Using boost version ${boost_ver}"
+ append-cxxflags \
+ -I/usr/include/boost-${boost_ver}
+ append-ldflags \
+ -L/usr/$(get_libdir)/boost-${boost_ver}
+ append-flags -DBOOST_FILESYSTEM_VERSION=2
+
+ export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
+ export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
+ sed -i -e 's/menuentry//' src/Makefile.am || die
+ eautoreconf
+}
src_install() {
base_src_install
newicon src/pics/cup2.png ${PN}.png
make_desktop_entry ${PN}2 ClanBomber2
+ rm -f "${D}${GAMES_DATADIR}"/${PN}/fonts/DejaVuSans-Bold.ttf
+ dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf \
+ "${GAMES_DATADIR}"/${PN}/fonts/
prepgamesdirs
}