summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-07-21 01:31:45 +0000
committerMike Frysinger <vapier@gentoo.org>2004-07-21 01:31:45 +0000
commit954174d3ce5f34db88e6d1bb8c633e2e2d704af4 (patch)
tree94c4f9a56f4f17712e9d8b2607b2aa2113c66494 /games-action
parentinitial ebuild (Manifest recommit) (diff)
downloadgentoo-2-954174d3ce5f34db88e6d1bb8c633e2e2d704af4.tar.gz
gentoo-2-954174d3ce5f34db88e6d1bb8c633e2e2d704af4.tar.bz2
gentoo-2-954174d3ce5f34db88e6d1bb8c633e2e2d704af4.zip
ver bump #56118
Diffstat (limited to 'games-action')
-rw-r--r--games-action/heroes/ChangeLog9
-rw-r--r--games-action/heroes/files/0.21-cvs-segfault-fix.patch17
-rw-r--r--games-action/heroes/files/digest-heroes-0.21-r1 (renamed from games-action/heroes/files/digest-heroes-0.21)0
-rw-r--r--games-action/heroes/heroes-0.21-r1.ebuild (renamed from games-action/heroes/heroes-0.21.ebuild)28
4 files changed, 37 insertions, 17 deletions
diff --git a/games-action/heroes/ChangeLog b/games-action/heroes/ChangeLog
index 52045ac00c26..4a0aac29e1be 100644
--- a/games-action/heroes/ChangeLog
+++ b/games-action/heroes/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-action/heroes
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/heroes/ChangeLog,v 1.6 2004/06/24 21:56:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/heroes/ChangeLog,v 1.7 2004/07/21 01:31:45 vapier Exp $
+
+*heroes-0.21-r1 (20 Jul 2004)
+
+ 20 Jul 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/0.21-cvs-segfault-fix.patch, +heroes-0.21-r1.ebuild,
+ -heroes-0.21.ebuild:
+ Version bump to fix SDL segfault #56118 by Kim Tingkær.
02 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> heroes-0.21.ebuild:
fix up use invocation
diff --git a/games-action/heroes/files/0.21-cvs-segfault-fix.patch b/games-action/heroes/files/0.21-cvs-segfault-fix.patch
new file mode 100644
index 000000000000..99f770631f6c
--- /dev/null
+++ b/games-action/heroes/files/0.21-cvs-segfault-fix.patch
@@ -0,0 +1,17 @@
+===================================================================
+RCS file: /cvsroot/heroes/heroes/src/menus.c,v
+retrieving revision 1.108.2.1
+retrieving revision 1.108.2.2
+diff -u -r1.108.2.1 -r1.108.2.2
+--- heroes/heroes/src/menus.c 2002/06/16 19:16:09 1.108.2.1
++++ heroes/heroes/src/menus.c 2002/08/22 11:45:51 1.108.2.2
+@@ -219,7 +219,8 @@
+ { N_("NEW LEVEL"), editor_menu },
+ /* TRANS: Load an existing level for edition. */
+ { N_("LOAD LEVEL"), editor_selector },
+- { N_("GO BACK"), 0 }
++ { N_("GO BACK"), 0 },
++ { 0, 0 }
+ };
+
+ a_menu *editor_menu_data;
diff --git a/games-action/heroes/files/digest-heroes-0.21 b/games-action/heroes/files/digest-heroes-0.21-r1
index 952f6f93ddb3..952f6f93ddb3 100644
--- a/games-action/heroes/files/digest-heroes-0.21
+++ b/games-action/heroes/files/digest-heroes-0.21-r1
diff --git a/games-action/heroes/heroes-0.21.ebuild b/games-action/heroes/heroes-0.21-r1.ebuild
index 092302912172..653173843a3a 100644
--- a/games-action/heroes/heroes-0.21.ebuild
+++ b/games-action/heroes/heroes-0.21-r1.ebuild
@@ -1,16 +1,12 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/heroes/heroes-0.21.ebuild,v 1.7 2004/06/24 21:56:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/heroes/heroes-0.21-r1.ebuild,v 1.1 2004/07/21 01:31:45 vapier Exp $
-inherit games
+inherit games eutils
data_ver=1.5
snd_trk_ver=1.0
snd_eff_ver=1.0
-pkg_list="${P}
- heroes-data-${data_ver}
- heroes-sound-tracks-${snd_trk_ver}
- heroes-sound-effects-${snd_eff_ver}"
DESCRIPTION="Heroes Enjoy Riding Over Empty Slabs: similar to Tron and Nibbles"
HOMEPAGE="http://heroes.sourceforge.net/"
@@ -27,27 +23,27 @@ IUSE="sdl nls ggi"
DEPEND="virtual/x11
nls? ( sys-devel/gettext )
sdl? ( media-libs/libsdl media-libs/sdl-mixer )
- ggi? ( media-libs/libggi media-libs/libgii media-libs/libmikmod )"
+ ggi? ( media-libs/libggi media-libs/libgii media-libs/libmikmod )
+ !sdl? ( !ggi? ( media-libs/libsdl media-libs/sdl-mixer ) )"
-S="${WORKDIR}"
+S=${WORKDIR}
-pkg_setup() {
- if use !sdl && use !ggi ; then
- die "You must have sdl or ggi in your USE variable"
- fi
- return 0
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}/${P}
+ epatch ${FILESDIR}/${PV}-cvs-segfault-fix.patch #56118
}
src_compile() {
local myconf="--disable-heroes-debug $(use_enable nls)"
- if use sdl ; then
+ if use sdl || ! use ggi ; then
myconf="${myconf} --with-sdl --with-sdl-mixer"
else
myconf="${myconf} --with-ggi --with-mikmod"
fi
- for pkg in ${pkg_list} ; do
+ for pkg in ${A//.tar.bz2} ; do
cd ${S}/${pkg}
egamesconf ${myconf}
make || die "unable to compile ${pkg}"
@@ -55,7 +51,7 @@ src_compile() {
}
src_install() {
- for pkg in ${pkg_list} ; do
+ for pkg in ${A//.tar.bz2} ; do
cd ${S}/${pkg}
make DESTDIR=${D} install || die
done