summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-02-03 08:37:22 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-02-03 08:37:22 +0000
commit90f20d53520b439b97ad0d649b2f383a1eb69185 (patch)
tree6ddd7898ab94ceab8e9b12f749d377328496054a /games-action
parentpatch for as-needed (diff)
downloadgentoo-2-90f20d53520b439b97ad0d649b2f383a1eb69185.tar.gz
gentoo-2-90f20d53520b439b97ad0d649b2f383a1eb69185.tar.bz2
gentoo-2-90f20d53520b439b97ad0d649b2f383a1eb69185.zip
Don't use egamesinstall
(Portage version: 2.1.2-r6)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/glaxium/ChangeLog8
-rw-r--r--games-action/glaxium/files/glaxium-0.5-build.patch60
-rw-r--r--games-action/glaxium/glaxium-0.5.ebuild37
3 files changed, 80 insertions, 25 deletions
diff --git a/games-action/glaxium/ChangeLog b/games-action/glaxium/ChangeLog
index ecd7b9d11985..894788d62a08 100644
--- a/games-action/glaxium/ChangeLog
+++ b/games-action/glaxium/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/glaxium
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/ChangeLog,v 1.13 2006/09/26 19:40:46 nyhm Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/ChangeLog,v 1.14 2007/02/03 08:37:22 nyhm Exp $
+
+ 03 Feb 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/glaxium-0.5-build.patch, glaxium-0.5.ebuild:
+ Don't use egamesinstall
26 Sep 2006; Tristan Heaven <nyhm@gentoo.org> glaxium-0.5.ebuild:
Check for nvidia-drivers instead of nvidia-glx, bug #146452
diff --git a/games-action/glaxium/files/glaxium-0.5-build.patch b/games-action/glaxium/files/glaxium-0.5-build.patch
new file mode 100644
index 000000000000..f7c7899e2a89
--- /dev/null
+++ b/games-action/glaxium/files/glaxium-0.5-build.patch
@@ -0,0 +1,60 @@
+--- configure.in
++++ configure.in
+@@ -41,7 +41,7 @@
+ AC_EGREP_HEADER(PFNGLBINDPROGRAMNVPROC, GL/glext.h, ,echo "Glaxium won't compile: get a newer version of your openGL header GL/glext.h at <http://oss.sgi.com/projects/ogl-sample/registry/>";exit 12)
+
+ dnl Expand DATADIR
+-FC_EXPAND_DIR(DATADIR, "$datadir/games/glaxium")
++FC_EXPAND_DIR(DATADIR, "$datadir/glaxium")
+ AC_DEFINE_UNQUOTED(DATADIR, "$DATADIR")
+
+ AC_OUTPUT(Makefile)
+--- Makefile.in
++++ Makefile.in
+@@ -1,5 +1,5 @@
+
+-CC=@CXX@
++CXX=@CXX@
+ INCLUDE=@CFLAGS@ @CPPFLAGS@
+ LIB=@LIBS@
+
+@@ -15,11 +15,11 @@
+
+ GLAXIUM_INSTALLDIR=$(bindir)
+ DATA_DIRS=samples textures
+-GLAXIUM_HOME=$(datadir)/games/glaxium
++GLAXIUM_HOME=$(datadir)/glaxium
+ MAN_DIR=$(mandir)
+
+ glaxium : $(OBJ)
+- gcc -g -o glaxium $(OBJ) $(LIB)
++ $(CXX) -o glaxium $(OBJ) $(LIB) $(LDFLAGS)
+
+
+
+@@ -31,18 +31,17 @@
+
+
+ %.o : %.cpp
+- $(CC) -c $(INCLUDE) $< -o $@ -DDATADIR=\"$(GLAXIUM_HOME)\"
++ $(CXX) -c $(INCLUDE) $< -o $@ -DDATADIR=\"$(GLAXIUM_HOME)\"
+
+
+ install: glaxium
+ @echo Instaling glaxium in $(GLAXIUM_INSTALLDIR) and its data in $(GLAXIUM_HOME)
+- @if [ ! -d $(GLAXIUM_HOME) ] ; then \
+- mkdir -p $(GLAXIUM_HOME) ; \
+- fi
+- @cp -f glaxium $(GLAXIUM_INSTALLDIR)/
+- @cp -R $(DATA_DIRS) $(GLAXIUM_HOME)
+- @mkdir -p $(MAN_DIR)/man6/
+- @cp -f glaxium.6 $(MAN_DIR)/man6/glaxium.6
++ mkdir -p "$(DESTDIR)$(GLAXIUM_INSTALLDIR)"
++ @cp -f glaxium "$(DESTDIR)$(GLAXIUM_INSTALLDIR)"/
++ mkdir -p "$(DESTDIR)$(GLAXIUM_HOME)"
++ @cp -R $(DATA_DIRS) "$(DESTDIR)$(GLAXIUM_HOME)"
++ @mkdir -p "$(DESTDIR)$(MAN_DIR)"/man6/
++ @cp -f glaxium.6 "$(DESTDIR)$(MAN_DIR)"/man6/glaxium.6
+
+ uninstall:
+ @echo Uninstaling glaxium
diff --git a/games-action/glaxium/glaxium-0.5.ebuild b/games-action/glaxium/glaxium-0.5.ebuild
index acec731e0c3c..6da846da7432 100644
--- a/games-action/glaxium/glaxium-0.5.ebuild
+++ b/games-action/glaxium/glaxium-0.5.ebuild
@@ -1,26 +1,24 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/glaxium-0.5.ebuild,v 1.15 2006/09/26 19:40:46 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/glaxium-0.5.ebuild,v 1.16 2007/02/03 08:37:22 nyhm Exp $
-inherit eutils flag-o-matic toolchain-funcs games
+inherit autotools eutils games
DESCRIPTION="OpenGL-based space-ship shoot-em-up style game"
HOMEPAGE="http://xhosxe.free.fr/glaxium/"
-SRC_URI="http://xhosxe.free.fr/glaxium/glaxium_${PV}.tar.gz"
+SRC_URI="http://xhosxe.free.fr/${PN}/${PN}_${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND=">=media-libs/libsdl-1.1.5
- >=media-libs/sdl-mixer-1.2.4
- x11-libs/libXmu
- x11-libs/libXi
+DEPEND="media-libs/libsdl
+ media-libs/sdl-mixer
virtual/opengl
virtual/glu
virtual/glut
- >=media-libs/libpng-1.0.0"
+ media-libs/libpng"
S=${WORKDIR}/${PN}_${PV}
@@ -30,24 +28,17 @@ src_unpack() {
if has_version x11-drivers/nvidia-legacy-drivers || \
has_version x11-drivers/nvidia-drivers
then
- epatch "${FILESDIR}/${P}-glx.patch"
+ epatch "${FILESDIR}"/${P}-glx.patch
fi
- epatch "${FILESDIR}/${PV}-rc.patch" \
- "${FILESDIR}/${P}-gcc41.patch"
-}
-
-src_compile() {
- egamesconf \
- --datadir="${GAMES_DATADIR_BASE}" || die
- emake || die "emake failed"
+ epatch \
+ "${FILESDIR}"/${PV}-rc.patch \
+ "${FILESDIR}"/${P}-gcc41.patch \
+ "${FILESDIR}"/${P}-build.patch
+ eautoreconf
}
src_install() {
- dodir "${GAMES_BINDIR}"
- egamesinstall \
- exec_prefix="${D}/${GAMES_PREFIX}" \
- datadir="${D}/${GAMES_DATADIR_BASE}" \
- || die
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc README.txt CHANGES.txt
prepgamesdirs
}