summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-12-20 13:35:49 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-12-20 13:35:49 +0000
commit9011bbf255dd32b83907fa28a26eaf390731d077 (patch)
treeac0d19565e45ab813662d09290637302f5d7a11d /games-action
parentAdded an elog message about removed pidof tool (diff)
downloadgentoo-2-9011bbf255dd32b83907fa28a26eaf390731d077.tar.gz
gentoo-2-9011bbf255dd32b83907fa28a26eaf390731d077.tar.bz2
gentoo-2-9011bbf255dd32b83907fa28a26eaf390731d077.zip
version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/cs2d/ChangeLog7
-rw-r--r--games-action/cs2d/cs2d-0123.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/games-action/cs2d/ChangeLog b/games-action/cs2d/ChangeLog
index de5f9a2e3f93..28d5ad84997c 100644
--- a/games-action/cs2d/ChangeLog
+++ b/games-action/cs2d/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/cs2d
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/cs2d/ChangeLog,v 1.6 2013/07/29 22:07:03 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/cs2d/ChangeLog,v 1.7 2013/12/20 13:35:49 hasufell Exp $
+
+*cs2d-0123 (20 Dec 2013)
+
+ 20 Dec 2013; Julian Ospald <hasufell@gentoo.org> +cs2d-0123.ebuild:
+ version bump
*cs2d-0122 (29 Jul 2013)
diff --git a/games-action/cs2d/cs2d-0123.ebuild b/games-action/cs2d/cs2d-0123.ebuild
new file mode 100644
index 000000000000..9c0b9e20ed7b
--- /dev/null
+++ b/games-action/cs2d/cs2d-0123.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/cs2d/cs2d-0123.ebuild,v 1.1 2013/12/20 13:35:49 hasufell Exp $
+
+EAPI=5
+
+inherit eutils games
+
+DESCRIPTION="Counter-Strike 2D is freeware clone of Counter-Strike with some added features in gameplay."
+HOMEPAGE="http://www.cs2d.com/"
+SRC_URI="http://dev.gentoo.org/~maksbotan/cs2d/cs2d_${PV}_linux.zip
+ http://dev.gentoo.org/~maksbotan/cs2d/cs2d_${PV}_win.zip
+ http://dev.gentoo.org/~maksbotan/cs2d/cs2d.png"
+LICENSE="freedist"
+
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="
+ x86? (
+ media-libs/openal
+ media-libs/freetype:2
+ x11-libs/libX11
+ x11-libs/libXxf86vm
+ virtual/opengl
+ )
+ amd64? (
+ app-emulation/emul-linux-x86-sdl
+ app-emulation/emul-linux-x86-opengl
+ app-emulation/emul-linux-x86-xlibs
+ )"
+
+QA_PRESTRIPPED="opt/cs2d/CounterStrike2D"
+QA_EXECSTACK="opt/cs2d/CounterStrike2D"
+
+S=${WORKDIR}
+
+src_prepare() {
+ # removing windows files
+ rm -f *.exe *.bat
+
+ # OpenAL is default sound driver
+ sed -i -e 's:^sounddriver.*$:sounddriver OpenAL Default:' sys/config.cfg || die
+}
+
+src_install() {
+ insinto "${GAMES_PREFIX_OPT}"/${PN}
+ doins -r .
+ # avoid file collision with untracked file
+ rm -f "${ED%/}/${GAMES_PREFIX_OPT}"/${PN}/sys/core/started.cfg
+
+ make_desktop_entry CounterStrike2D "Counter Strike 2D"
+ make_desktop_entry "CounterStrike2D -fullscreen -24bit" "Counter Strike 2D - FULLSCREEN"
+ games_make_wrapper CounterStrike2D ./CounterStrike2D \
+ "${GAMES_PREFIX_OPT}"/${PN} "${GAMES_PREFIX_OPT}"/${PN}
+
+ doicon "${DISTDIR}"/${PN}.png
+
+ prepgamesdirs
+
+ # fixing permissions
+ fperms -R g+w "${GAMES_PREFIX_OPT}"/${PN}/maps
+ fperms -R g+w "${GAMES_PREFIX_OPT}"/${PN}/screens
+ fperms -R g+w "${GAMES_PREFIX_OPT}"/${PN}/sys
+ fperms ug+x "${GAMES_PREFIX_OPT}"/${PN}/CounterStrike2D
+}