summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-05-04 06:20:09 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-05-04 06:20:09 +0000
commit7f07e0e7f1a3f89a5e9ae7dcf22be43ad2df066c (patch)
tree6739aad74059dc7a496b09c4372e216b2876cb60 /games-action
parent[kde-base] Drop KDE SC 4.4.1 (diff)
downloadgentoo-2-7f07e0e7f1a3f89a5e9ae7dcf22be43ad2df066c.tar.gz
gentoo-2-7f07e0e7f1a3f89a5e9ae7dcf22be43ad2df066c.tar.bz2
gentoo-2-7f07e0e7f1a3f89a5e9ae7dcf22be43ad2df066c.zip
Force python2 fixing bug #312227
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/accelerator3d/ChangeLog6
-rw-r--r--games-action/accelerator3d/accelerator3d-0.1.1-r1.ebuild14
2 files changed, 15 insertions, 5 deletions
diff --git a/games-action/accelerator3d/ChangeLog b/games-action/accelerator3d/ChangeLog
index e4e4efc2d713..535dee60f369 100644
--- a/games-action/accelerator3d/ChangeLog
+++ b/games-action/accelerator3d/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/accelerator3d
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/accelerator3d/ChangeLog,v 1.7 2010/04/09 19:14:40 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/accelerator3d/ChangeLog,v 1.8 2010/05/04 06:20:09 tupone Exp $
+
+ 04 May 2010; Tupone Alfredo <tupone@gentoo.org>
+ accelerator3d-0.1.1-r1.ebuild:
+ Force python2 fixing bug #312227 by arferever@gentoo.org
09 Apr 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
accelerator3d-0.1.1-r1.ebuild:
diff --git a/games-action/accelerator3d/accelerator3d-0.1.1-r1.ebuild b/games-action/accelerator3d/accelerator3d-0.1.1-r1.ebuild
index ff15abeb7bd9..6e03d65ad529 100644
--- a/games-action/accelerator3d/accelerator3d-0.1.1-r1.ebuild
+++ b/games-action/accelerator3d/accelerator3d-0.1.1-r1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/accelerator3d/accelerator3d-0.1.1-r1.ebuild,v 1.2 2010/04/09 19:14:40 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/accelerator3d/accelerator3d-0.1.1-r1.ebuild,v 1.3 2010/05/04 06:20:09 tupone Exp $
EAPI=2
-inherit eutils games
+PYTHON_DEPEND="2"
+inherit eutils python games
DESCRIPTION="Fast-paced, 3D, first-person shoot/dodge-'em-up, in the vain of Tempest or n2o"
HOMEPAGE="http://accelerator3d.sourceforge.net/"
@@ -16,11 +17,15 @@ IUSE=""
DEPEND="dev-python/pyode
dev-python/pygame
- dev-python/pyopengl
- virtual/python"
+ dev-python/pyopengl"
S=${WORKDIR}/${PN}
+pkg_setup() {
+ python_set_active_version 2
+ games_pkg_setup
+}
+
src_prepare() {
epatch \
"${FILESDIR}"/${P}-gentoo-paths.patch \
@@ -28,6 +33,7 @@ src_prepare() {
sed -i \
-e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
accelerator.py || die
+ python_convert_shebangs 2 accelerator.py
}
src_install() {