summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-06-30 07:05:30 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-06-30 07:05:30 +0000
commit75b5f92d314113c34daf66f99cc39be22b64c578 (patch)
treeb504008842d1f907a1c45a9b519dfbd00e4e6b7f /games-action
parentCall epatch_user #455828 by Alexander Krause. (diff)
downloadgentoo-2-75b5f92d314113c34daf66f99cc39be22b64c578.tar.gz
gentoo-2-75b5f92d314113c34daf66f99cc39be22b64c578.tar.bz2
gentoo-2-75b5f92d314113c34daf66f99cc39be22b64c578.zip
Fixed endless cofigure loop when /bin/sh=dash (bug #475248).
(Portage version: 2.2.0_alpha182_p1/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/garden/ChangeLog11
-rw-r--r--games-action/garden/files/garden-1.0.8-drop-AS_INIT.patch19
-rw-r--r--games-action/garden/garden-1.0.8-r1.ebuild32
3 files changed, 59 insertions, 3 deletions
diff --git a/games-action/garden/ChangeLog b/games-action/garden/ChangeLog
index 0bc55e756888..1ef20448b8bf 100644
--- a/games-action/garden/ChangeLog
+++ b/games-action/garden/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/garden
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/garden/ChangeLog,v 1.8 2011/06/22 16:24:25 tupone Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/garden/ChangeLog,v 1.9 2013/06/30 07:05:30 slyfox Exp $
+
+*garden-1.0.8-r1 (30 Jun 2013)
+
+ 30 Jun 2013; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/garden-1.0.8-drop-AS_INIT.patch, +garden-1.0.8-r1.ebuild:
+ Fixed endless cofigure loop when /bin/sh=dash (bug #475248).
22 Jun 2011; Tupone Alfredo <tupone@gentoo.org> garden-1.0.8.ebuild,
+files/garden-1.0.8-underlink.patch:
@@ -31,4 +37,3 @@
12 Apr 2009; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+garden-1.0.6.ebuild:
initial commit - ebuild submitted by David Valentim Dias via bug #265726
-
diff --git a/games-action/garden/files/garden-1.0.8-drop-AS_INIT.patch b/games-action/garden/files/garden-1.0.8-drop-AS_INIT.patch
new file mode 100644
index 000000000000..69cff8fa319d
--- /dev/null
+++ b/games-action/garden/files/garden-1.0.8-drop-AS_INIT.patch
@@ -0,0 +1,19 @@
+At least for autoconf-2.69 AS_INIT is called by AC_INIT.
+
+When using /bin/dash calling AS_INIT directly leads to infinite
+reexec loop.
+
+Gentoo-bug: http://bugs.gentoo.org/475248
+diff --git a/configure.ac b/configure.ac
+index eb0002f..6c77ef9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -5,7 +5,7 @@ AC_PREREQ(2.62)
+ AC_INIT([GARDEN],
+ [1.0.8],
+ [bubla@users.sourceforge.net])
+-AS_INIT
++
+ AC_CONFIG_AUX_DIR([build-aux])
+ AM_INIT_AUTOMAKE([-Wall])
+ AC_CONFIG_SRCDIR([src/input.h])
diff --git a/games-action/garden/garden-1.0.8-r1.ebuild b/games-action/garden/garden-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..3190b5cf1b2c
--- /dev/null
+++ b/games-action/garden/garden-1.0.8-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/garden/garden-1.0.8-r1.ebuild,v 1.1 2013/06/30 07:05:30 slyfox Exp $
+
+EAPI=5
+inherit eutils autotools games
+
+DESCRIPTION="Multiplatform vertical shoot-em-up with non-traditional elements"
+HOMEPAGE="http://garden.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="<media-libs/allegro-5"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-underlink.patch
+ epatch "${FILESDIR}"/${P}-drop-AS_INIT.patch #475248
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doicon resources/garden.svg
+ make_desktop_entry garden "Garden of coloured lights"
+ dodoc AUTHORS ChangeLog NEWS README
+ prepgamesdirs
+}