summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-06-28 13:48:12 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-06-28 13:48:12 +0000
commit3b4f824bc4563d00553572748b696bb2849c594d (patch)
treec888b6111f0c6b95943f65a2db6da30870f91c43 /games-action
parentadd mono useflag for libbtctl (diff)
downloadgentoo-2-3b4f824bc4563d00553572748b696bb2849c594d.tar.gz
gentoo-2-3b4f824bc4563d00553572748b696bb2849c594d.tar.bz2
gentoo-2-3b4f824bc4563d00553572748b696bb2849c594d.zip
Fixing cdinstall and closing bug #55417.
Diffstat (limited to 'games-action')
-rw-r--r--games-action/d2x/ChangeLog5
-rw-r--r--games-action/d2x/d2x-0.2.5-r1.ebuild22
2 files changed, 16 insertions, 11 deletions
diff --git a/games-action/d2x/ChangeLog b/games-action/d2x/ChangeLog
index 93bac7d10689..29a46c3ed106 100644
--- a/games-action/d2x/ChangeLog
+++ b/games-action/d2x/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/d2x
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.6 2004/06/28 04:25:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.7 2004/06/28 13:48:12 wolf31o2 Exp $
+
+ 28 Jun 2004; Chris Gianelloni <wolf31o2@gentoo.org> d2x-0.2.5-r1.ebuild:
+ Fixing cdinstall and closing bug #55417.
27 Jun 2004; Aron Griffis <agriffis@gentoo.org> d2x-0.2.5-r1.ebuild,
d2x-0.2.5.ebuild:
diff --git a/games-action/d2x/d2x-0.2.5-r1.ebuild b/games-action/d2x/d2x-0.2.5-r1.ebuild
index a86d98243771..c4199d37397e 100644
--- a/games-action/d2x/d2x-0.2.5-r1.ebuild
+++ b/games-action/d2x/d2x-0.2.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r1.ebuild,v 1.2 2004/06/28 04:25:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r1.ebuild,v 1.3 2004/06/28 13:48:12 wolf31o2 Exp $
inherit flag-o-matic eutils games
@@ -8,7 +8,7 @@ DATAFILE="d2shar10"
DESCRIPTION="Descent 2"
HOMEPAGE="http://icculus.org/d2x/"
SRC_URI="http://icculus.org/d2x/src/${P}.tar.gz
- http://icculus.org/d2x/data/${DATAFILE}.tar.gz"
+ !cdinstall? ( http://icculus.org/d2x/data/${DATAFILE}.tar.gz )"
LICENSE="GPL-2"
SLOT="0"
@@ -25,15 +25,17 @@ DEPEND="${RDEPEND}
x86? ( dev-lang/nasm )"
pkg_setup() {
- if ! [ -e ${DISTDIR}/descent2.sow ] ; then
+ if use cdinstall ; then
+ if ! [ -e ${DISTDIR}/descent2.sow ] ; then
cdrom_get_cds d2data
- if [ -e ${CDROM_ROOT}/d2data/descent2.sow ] ; then
- export CDROM_ROOT=${CDROM_ROOT}/d2data
- einfo "Found the original Descent2 CD"
- einfo "Copying descent2.sow to ${DISTDIR}"
- cp ${CDROM_ROOT}/descent2.sow ${DISTDIR}/descent2.sow
- else
- die "You need the original Descent2 CD"
+ if [ -e ${CDROM_ROOT}/d2data/descent2.sow ] ; then
+ export CDROM_ROOT=${CDROM_ROOT}/d2data
+ einfo "Found the original Descent2 CD"
+ einfo "Copying descent2.sow to ${DISTDIR}"
+ cp ${CDROM_ROOT}/descent2.sow ${DISTDIR}/descent2.sow
+ else
+ die "You need the original Descent2 CD"
+ fi
fi
fi
games_pkg_setup