summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2003-10-09 19:08:05 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2003-10-09 19:08:05 +0000
commit27fcad1425c00fb9232413cf8072e01e25516a86 (patch)
treefa50af11ff59a2d4f24a08eb3ac14548a0498463 /games-action
parentremoved hardened-gcc flags again (diff)
downloadgentoo-2-27fcad1425c00fb9232413cf8072e01e25516a86.tar.gz
gentoo-2-27fcad1425c00fb9232413cf8072e01e25516a86.tar.bz2
gentoo-2-27fcad1425c00fb9232413cf8072e01e25516a86.zip
Added menu entry. Closing bug #30618.
Diffstat (limited to 'games-action')
-rw-r--r--games-action/maelstrom/ChangeLog5
-rw-r--r--games-action/maelstrom/Manifest6
-rw-r--r--games-action/maelstrom/maelstrom-3.0.6.ebuild17
3 files changed, 22 insertions, 6 deletions
diff --git a/games-action/maelstrom/ChangeLog b/games-action/maelstrom/ChangeLog
index d6e503f8d4a4..27d492ccbdc3 100644
--- a/games-action/maelstrom/ChangeLog
+++ b/games-action/maelstrom/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/maelstrom
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/ChangeLog,v 1.3 2003/10/06 14:14:31 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/ChangeLog,v 1.4 2003/10/09 19:08:02 wolf31o2 Exp $
+
+ 09 Oct 2003; Chris Gianelloni <wolf31o2@gentoo.org> maelstrom-3.0.6.ebuild:
+ Added menu entry. Closing bug #30618
06 Oct 2003; Aron Griffis <agriffis@gentoo.org> maelstrom-3.0.6.ebuild:
Stable on alpha
diff --git a/games-action/maelstrom/Manifest b/games-action/maelstrom/Manifest
index 3d19495b4d50..aebdfc92508c 100644
--- a/games-action/maelstrom/Manifest
+++ b/games-action/maelstrom/Manifest
@@ -1,6 +1,6 @@
-MD5 bce2f72f02c5d0ddb4ef4ecf8143e5ff ChangeLog 819
MD5 68010b0b115544f259a4c0d40cc8b13b maelstrom-3.0.5.ebuild 660
-MD5 a66115088a9b5c3f165da7c09ad8ed16 maelstrom-3.0.6.ebuild 766
+MD5 ee786b8d93736d8157bbf888e8cd4d02 maelstrom-3.0.6.ebuild 1002
+MD5 3f35d7862a0d3c86fd4a37d8ab51ac40 ChangeLog 938
+MD5 5ea58949614a6eab777bda186f607f03 files/maelstrom-3.0.6-security.patch 14189
MD5 c4abb77232ff7eede86ec0636d7d6af9 files/digest-maelstrom-3.0.5 67
MD5 e3ab80b2fbf8ddabc7817b0fbb6a3068 files/digest-maelstrom-3.0.6 68
-MD5 5ea58949614a6eab777bda186f607f03 files/maelstrom-3.0.6-security.patch 14189
diff --git a/games-action/maelstrom/maelstrom-3.0.6.ebuild b/games-action/maelstrom/maelstrom-3.0.6.ebuild
index 143df1533d61..5c9c2041d472 100644
--- a/games-action/maelstrom/maelstrom-3.0.6.ebuild
+++ b/games-action/maelstrom/maelstrom-3.0.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/maelstrom-3.0.6.ebuild,v 1.2 2003/10/06 14:14:31 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/maelstrom/maelstrom-3.0.6.ebuild,v 1.3 2003/10/09 19:08:02 wolf31o2 Exp $
-inherit eutils
+inherit eutils games
MY_P=Maelstrom-${PV}
S=${WORKDIR}/${MY_P}
@@ -17,6 +17,10 @@ LICENSE="GPL-2"
DEPEND=">=media-libs/libsdl-1.1.5
>=media-libs/sdl-net-1.2.2"
+pkg_setup() {
+ games_pkg_setup
+}
+
src_unpack() {
unpack ${A} ; cd ${S}
@@ -26,4 +30,13 @@ src_unpack() {
src_install() {
einstall || die
dodoc ChangeLog README TODO DIFFERENCES INTERESTING-COMBINATIONS
+
+ insinto /usr/share/pixmaps
+ newins ${D}/usr/games/Maelstrom/icon.xpm maelstrom.xpm
+ make_desktop_entry Maelstrom "Maelstrom" maelstrom.xpm
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
}