summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2010-01-24 19:05:43 +0000
committerTristan Heaven <nyhm@gentoo.org>2010-01-24 19:05:43 +0000
commit26a85e63d21dafeb76dfd6cb6abed5922ad4b0bd (patch)
tree4703844e27be7bbddf297b95b99c3ad25d81162e /games-action
parentapple-opengl was renamed to opengl-apple (diff)
downloadgentoo-2-26a85e63d21dafeb76dfd6cb6abed5922ad4b0bd.tar.gz
gentoo-2-26a85e63d21dafeb76dfd6cb6abed5922ad4b0bd.tar.bz2
gentoo-2-26a85e63d21dafeb76dfd6cb6abed5922ad4b0bd.zip
Fix runtime error with recent pyopengl versions, bug #297521
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/accelerator3d/ChangeLog11
-rw-r--r--games-action/accelerator3d/accelerator3d-0.1.1-r1.ebuild39
-rw-r--r--games-action/accelerator3d/files/accelerator3d-0.1.1-gllightmodel.patch11
3 files changed, 59 insertions, 2 deletions
diff --git a/games-action/accelerator3d/ChangeLog b/games-action/accelerator3d/ChangeLog
index 3664df44803f..f25c5c020f7d 100644
--- a/games-action/accelerator3d/ChangeLog
+++ b/games-action/accelerator3d/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-action/accelerator3d
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/accelerator3d/ChangeLog,v 1.5 2009/12/09 22:32:01 fauli Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/accelerator3d/ChangeLog,v 1.6 2010/01/24 19:05:42 nyhm Exp $
+
+*accelerator3d-0.1.1-r1 (24 Jan 2010)
+
+ 24 Jan 2010; Tristan Heaven <nyhm@gentoo.org>
+ +accelerator3d-0.1.1-r1.ebuild,
+ +files/accelerator3d-0.1.1-gllightmodel.patch:
+ Fix runtime error with recent pyopengl versions, bug #297521
09 Dec 2009; Christian Faulhammer <fauli@gentoo.org>
accelerator3d-0.1.1.ebuild:
diff --git a/games-action/accelerator3d/accelerator3d-0.1.1-r1.ebuild b/games-action/accelerator3d/accelerator3d-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..b5e315c0595b
--- /dev/null
+++ b/games-action/accelerator3d/accelerator3d-0.1.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/accelerator3d/accelerator3d-0.1.1-r1.ebuild,v 1.1 2010/01/24 19:05:42 nyhm Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Fast-paced, 3D, first-person shoot/dodge-'em-up, in the vain of Tempest or n2o"
+HOMEPAGE="http://accelerator3d.sourceforge.net/"
+SRC_URI="mirror://sourceforge/accelerator3d/accelerator-${PV}.tar.bz2"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-python/pyode
+ dev-python/pygame
+ dev-python/pyopengl
+ virtual/python"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo-paths.patch \
+ "${FILESDIR}"/${P}-gllightmodel.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ accelerator.py || die
+}
+
+src_install() {
+ newgamesbin accelerator.py accelerator || die "newgamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins gfx/* snd/* || die "doins failed"
+ dodoc CHANGELOG README
+ prepgamesdirs
+}
diff --git a/games-action/accelerator3d/files/accelerator3d-0.1.1-gllightmodel.patch b/games-action/accelerator3d/files/accelerator3d-0.1.1-gllightmodel.patch
new file mode 100644
index 000000000000..b850ccfa5bab
--- /dev/null
+++ b/games-action/accelerator3d/files/accelerator3d-0.1.1-gllightmodel.patch
@@ -0,0 +1,11 @@
+--- accelerator.py
++++ accelerator.py
+@@ -274,7 +274,7 @@
+ glColorMaterial(GL_FRONT,GL_AMBIENT_AND_DIFFUSE)
+ glMaterialfv(GL_FRONT,GL_SHININESS,128)
+ glMaterialfv(GL_FRONT,GL_SPECULAR,(0.5,0.5,0.5,1))
+- glLightModel(GL_LIGHT_MODEL_COLOR_CONTROL_EXT,GL_SEPARATE_SPECULAR_COLOR_EXT) # GL_LIGHT_MODEL_COLOR_CONTROL, GL_SEPARATE_SPECULAR_COLOR
++ glLightModeli(GL_LIGHT_MODEL_COLOR_CONTROL_EXT,GL_SEPARATE_SPECULAR_COLOR_EXT) # GL_LIGHT_MODEL_COLOR_CONTROL, GL_SEPARATE_SPECULAR_COLOR
+ glEnable(GL_LINE_SMOOTH)
+ glEnable(GL_NORMALIZE)
+ #glPolygonMode(GL_FRONT,GL_LINE)