summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-05-21 01:51:23 +0000
committerMike Frysinger <vapier@gentoo.org>2010-05-21 01:51:23 +0000
commit25223cd1f3ce38f1f45992b0fdb0108e492f0707 (patch)
tree8a1c7c1d26ed59fe332cc54e4b9558c2bcf3cb3b /games-action
parentTell people to go to the HOMEPAGE since this is apparently a very complicated... (diff)
downloadgentoo-2-25223cd1f3ce38f1f45992b0fdb0108e492f0707.tar.gz
gentoo-2-25223cd1f3ce38f1f45992b0fdb0108e492f0707.tar.bz2
gentoo-2-25223cd1f3ce38f1f45992b0fdb0108e492f0707.zip
Version bump #319607 by A.C.Heron.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/lugaru-demo/ChangeLog9
-rw-r--r--games-action/lugaru-demo/lugaru-demo-1.0c.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/games-action/lugaru-demo/ChangeLog b/games-action/lugaru-demo/ChangeLog
index 8dd92cb63052..255154f06a3f 100644
--- a/games-action/lugaru-demo/ChangeLog
+++ b/games-action/lugaru-demo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/lugaru-demo
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/lugaru-demo/ChangeLog,v 1.10 2009/10/25 15:20:47 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/lugaru-demo/ChangeLog,v 1.11 2010/05/21 01:51:23 vapier Exp $
+
+*lugaru-demo-1.0c (21 May 2010)
+
+ 21 May 2010; Mike Frysinger <vapier@gentoo.org> +lugaru-demo-1.0c.ebuild:
+ Version bump #319607 by A.C.Heron.
25 Oct 2009; Markus Meier <maekke@gentoo.org> lugaru-demo-1.0b.ebuild:
amd64/x86 stable, bug #288827
diff --git a/games-action/lugaru-demo/lugaru-demo-1.0c.ebuild b/games-action/lugaru-demo/lugaru-demo-1.0c.ebuild
new file mode 100644
index 000000000000..ba396bc0b063
--- /dev/null
+++ b/games-action/lugaru-demo/lugaru-demo-1.0c.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/lugaru-demo/lugaru-demo-1.0c.ebuild,v 1.1 2010/05/21 01:51:23 vapier Exp $
+
+inherit eutils games
+
+DESCRIPTION="3D arcade with unique fighting system and anthropomorphic characters"
+HOMEPAGE="http://www.wolfire.com/lugaru"
+SRC_URI="http://cdn.wolfire.com/games/lugaru/lugaru-linux-x86-${PV}.bin"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND="sys-libs/glibc
+ amd64? ( app-emulation/emul-linux-x86-xlibs )
+ x86? (
+ x11-libs/libX11
+ x11-libs/libXext
+ )"
+
+S=${WORKDIR}/data
+
+src_unpack() {
+ tail -c +194469 "${DISTDIR}"/${A} > ${A}.zip
+ unpack ./${A}.zip
+ rm -f ${A}.zip
+
+ # Duplicate file and can't be handled by portage, bug #14983
+ rm -f "${S}/Data/Textures/Quit.png "
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ insinto "${dir}"
+ doins -r Data || die "doins failed"
+
+ dodoc *.txt
+
+ exeinto "${dir}"
+ doexe lugaru || die "doexe failed"
+ games_make_wrapper ${PN} ./lugaru "${dir}" "${dir}"
+
+ newicon lugaru.png ${PN}.png
+ make_desktop_entry ${PN} "Lugaru Demo" ${PN}
+
+ prepgamesdirs
+}