summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-08-29 04:23:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-08-29 04:23:28 +0000
commitd95bba8b0e3feb3d21bffb42a6338c0b97a5d5eb (patch)
tree3e174815e9dfdfc94df188def706a7e7436f5285 /games-action/violetland
parentRemove older version and unused patches. (diff)
downloadgentoo-2-d95bba8b0e3feb3d21bffb42a6338c0b97a5d5eb.tar.gz
gentoo-2-d95bba8b0e3feb3d21bffb42a6338c0b97a5d5eb.tar.bz2
gentoo-2-d95bba8b0e3feb3d21bffb42a6338c0b97a5d5eb.zip
limit boost to the versions that work
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'games-action/violetland')
-rw-r--r--games-action/violetland/ChangeLog8
-rw-r--r--games-action/violetland/violetland-0.4.3.ebuild23
2 files changed, 24 insertions, 7 deletions
diff --git a/games-action/violetland/ChangeLog b/games-action/violetland/ChangeLog
index ae67b067daeb..200442b3ad89 100644
--- a/games-action/violetland/ChangeLog
+++ b/games-action/violetland/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/violetland
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/ChangeLog,v 1.23 2011/12/07 07:41:04 phajdan.jr Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/ChangeLog,v 1.24 2012/08/29 04:23:28 mr_bones_ Exp $
+
+ 29 Aug 2012; Michael Sterrett <mr_bones_@gentoo.org> violetland-0.4.3.ebuild:
+ limit boost to the versions that work
07 Dec 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> violetland-0.4.3.ebuild:
x86 stable wrt bug #392691
@@ -105,4 +108,3 @@
30 Nov 2009; Michael Sterrett <mr_bones_@gentoo.org>
+violetland-0.2.4.ebuild, +metadata.xml:
initial commit - ebuild submitted by Azamat H. Hackimov via bug #294776
-
diff --git a/games-action/violetland/violetland-0.4.3.ebuild b/games-action/violetland/violetland-0.4.3.ebuild
index 410410230af7..00a44d27d43a 100644
--- a/games-action/violetland/violetland-0.4.3.ebuild
+++ b/games-action/violetland/violetland-0.4.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/violetland-0.4.3.ebuild,v 1.3 2011/12/07 07:41:04 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/violetland/violetland-0.4.3.ebuild,v 1.4 2012/08/29 04:23:28 mr_bones_ Exp $
EAPI=2
-inherit eutils cmake-utils games
+inherit eutils multilib toolchain-funcs flag-o-matic cmake-utils games
DESCRIPTION="Help a girl by name of Violet to struggle with hordes of monsters."
HOMEPAGE="http://code.google.com/p/violetland/"
@@ -18,7 +18,8 @@ RDEPEND="media-libs/libsdl[audio,video]
media-libs/sdl-image[png]
media-libs/sdl-mixer[vorbis]
media-libs/sdl-ttf
- dev-libs/boost
+ <dev-libs/boost-1.50
+ >=dev-libs/boost-1.37
virtual/opengl
virtual/glu"
DEPEND="${RDEPEND}
@@ -31,6 +32,20 @@ src_prepare() {
-e "/README_EN.TXT/d" \
-e "/README_RU.TXT/d" \
CMakeLists.txt || die "sed failed"
+ # how do I hate boost? Let me count the ways...
+ local boost_ver=$(best_version "<dev-libs/boost-1.50")
+
+ boost_ver=${boost_ver/*boost-/}
+ boost_ver=${boost_ver%.*}
+ boost_ver=${boost_ver/./_}
+
+ einfo "Using boost version ${boost_ver}"
+ append-cxxflags \
+ -I/usr/include/boost-${boost_ver}
+ append-ldflags \
+ -L/usr/$(get_libdir)/boost-${boost_ver}
+ export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
+ export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
}
src_configure() {