summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-06 08:47:53 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-06 08:47:53 +0000
commit272aab1899243c64b41fe71b4038784193afc857 (patch)
treef2147716cd944fcbe1aec44f62351d818de7006e /games-action/transcend
parentEAPI=5 (diff)
downloadgentoo-2-272aab1899243c64b41fe71b4038784193afc857.tar.gz
gentoo-2-272aab1899243c64b41fe71b4038784193afc857.tar.bz2
gentoo-2-272aab1899243c64b41fe71b4038784193afc857.zip
EAPI=5; respect CXX, CXXFLAGS, LDFLAGS; tidy
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-action/transcend')
-rw-r--r--games-action/transcend/ChangeLog6
-rw-r--r--games-action/transcend/transcend-0.3.ebuild30
2 files changed, 19 insertions, 17 deletions
diff --git a/games-action/transcend/ChangeLog b/games-action/transcend/ChangeLog
index 5c8ebe94eb1a..05c636295762 100644
--- a/games-action/transcend/ChangeLog
+++ b/games-action/transcend/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/transcend
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/transcend/ChangeLog,v 1.9 2015/01/02 10:47:13 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/transcend/ChangeLog,v 1.10 2015/02/06 08:47:53 mr_bones_ Exp $
+
+ 06 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org> transcend-0.3.ebuild:
+ EAPI=5; respect CXX, CXXFLAGS, LDFLAGS; tidy
02 Jan 2015; Tupone Alfredo <tupone@gentoo.org> transcend-0.3.ebuild:
EAPI 4
@@ -35,4 +38,3 @@
08 Feb 2005; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+transcend-0.2.ebuild:
initial commit (bug #65472)
-
diff --git a/games-action/transcend/transcend-0.3.ebuild b/games-action/transcend/transcend-0.3.ebuild
index b4fce67e0825..d72f7fbea161 100644
--- a/games-action/transcend/transcend-0.3.ebuild
+++ b/games-action/transcend/transcend-0.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/transcend/transcend-0.3.ebuild,v 1.8 2015/01/02 10:47:13 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/transcend/transcend-0.3.ebuild,v 1.9 2015/02/06 08:47:53 mr_bones_ Exp $
-EAPI=4
+EAPI=5
inherit games
DESCRIPTION="retro-style, abstract, 2D shooter"
@@ -19,7 +19,7 @@ DEPEND="x11-libs/libXmu
virtual/opengl
virtual/glu
media-libs/freeglut"
-RDEPEND="${DEPEND}"
+RDEPEND=${DEPEND}
S=${WORKDIR}/Transcend_${PV}_UnixSource/Transcend
@@ -27,38 +27,38 @@ src_prepare() {
chmod a+x portaudio/configure
mkdir portaudio/{lib,bin}
rm -f game/Makefile
- cat \
+ sed \
+ -e '/^GXX=/d' \
+ -e 's/GXX/CXX/' \
+ -e '/^COMPILE_FLAGS =/ s/OPTIMIZE_FLAG/CXXFLAGS/' \
+ -e '/^EXE_LINK =/ s/LINK_FLAGS/LDFLAGS/' \
Makefile.GnuLinuxX86 \
Makefile.common \
Makefile.minorGems \
game/Makefile.all \
Makefile.minorGems_targets \
- > game/Makefile
+ > game/Makefile || die
sed -i \
-e "s:\"levels\":\"${GAMES_DATADIR}/${PN}/levels\":" \
game/LevelDirectoryManager.cpp \
- game/game.cpp \
- || die "sed failed"
+ game/game.cpp || die
}
src_configure() {
cd portaudio
- egamesconf --enable-dependency-tracking
+ egamesconf
}
src_compile() {
- cd portaudio
- nonfatal emake
- cd ../game
- emake
- cd ..
- cp game/Transcend ${PN} || die "cp failed"
+ nonfatal emake -C portaudio
+ emake -C game
+ cp game/Transcend ${PN} || die
}
src_install() {
dogamesbin ${PN}
insinto "${GAMES_DATADIR}/${PN}"
doins -r levels/
- dodoc doc/how_to_*.txt
+ dodoc doc/{how_to_play.txt,changeLog.txt}
prepgamesdirs
}