summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-25 13:14:20 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-25 13:14:20 +0000
commite7a86f6010cb01fbee5059e6084b91f214c24d90 (patch)
tree919798be5d3d8a44c99e9ffef2d8cbb0259bf473 /games-action/shadowgrounds-bin
parentSupport multilib dependencies aside to emul-linux-x86. (diff)
downloadgentoo-2-e7a86f6010cb01fbee5059e6084b91f214c24d90.tar.gz
gentoo-2-e7a86f6010cb01fbee5059e6084b91f214c24d90.tar.bz2
gentoo-2-e7a86f6010cb01fbee5059e6084b91f214c24d90.zip
Support multilib dependencies aside to emul-linux-x86.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'games-action/shadowgrounds-bin')
-rw-r--r--games-action/shadowgrounds-bin/ChangeLog11
-rw-r--r--games-action/shadowgrounds-bin/shadowgrounds-bin-0_beta12-r1.ebuild68
2 files changed, 76 insertions, 3 deletions
diff --git a/games-action/shadowgrounds-bin/ChangeLog b/games-action/shadowgrounds-bin/ChangeLog
index 823318b3aa12..3cfcbbeb8f85 100644
--- a/games-action/shadowgrounds-bin/ChangeLog
+++ b/games-action/shadowgrounds-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/shadowgrounds-bin
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/shadowgrounds-bin/ChangeLog,v 1.3 2013/03/29 15:35:58 hasufell Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/shadowgrounds-bin/ChangeLog,v 1.4 2014/06/25 13:14:20 mgorny Exp $
+
+*shadowgrounds-bin-0_beta12-r1 (25 Jun 2014)
+
+ 25 Jun 2014; Michał Górny <mgorny@gentoo.org>
+ +shadowgrounds-bin-0_beta12-r1.ebuild:
+ Support multilib dependencies aside to emul-linux-x86.
29 Mar 2013; Julian Ospald <hasufell@gentoo.org>
shadowgrounds-bin-0_beta12.ebuild:
@@ -15,4 +21,3 @@
16 Apr 2011; Mike Frysinger <vapier@gentoo.org>
+shadowgrounds-bin-0_beta12.ebuild, +metadata.xml:
New package.
-
diff --git a/games-action/shadowgrounds-bin/shadowgrounds-bin-0_beta12-r1.ebuild b/games-action/shadowgrounds-bin/shadowgrounds-bin-0_beta12-r1.ebuild
new file mode 100644
index 000000000000..569578c2aced
--- /dev/null
+++ b/games-action/shadowgrounds-bin/shadowgrounds-bin-0_beta12-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/shadowgrounds-bin/shadowgrounds-bin-0_beta12-r1.ebuild,v 1.1 2014/06/25 13:14:20 mgorny Exp $
+
+EAPI=5
+
+inherit unpacker games eutils
+
+DESCRIPTION="an epic action experience combining modern technology with addictive playability"
+HOMEPAGE="http://shadowgroundsgame.com/"
+SRC_URI="Shadowgrounds${PV/*_b/B}.run"
+
+LICENSE="frozenbyte-eula"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch strip"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=sys-libs/glibc-2.4
+ >=sys-devel/gcc-4.3.0
+ !amd64? (
+ gnome-base/libglade
+ )
+ amd64? (
+ || (
+ app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ gnome-base/libglade[abi_x86_32(-)]
+ )
+ )"
+
+S=${WORKDIR}
+
+d="${GAMES_PREFIX_OPT}/${PN}"
+QA_TEXTRELS_x86="`echo ${d#/}/lib32/lib{avcodec.so.51,avformat.so.52,avutil.so.49,FLAC.so.8}`"
+QA_TEXTRELS_amd64=${QA_TEXTRELS_x86}
+
+pkg_nofetch() {
+ einfo "Fetch ${SRC_URI} and put it into ${DISTDIR}"
+ einfo "See http://www.humblebundle.com/ for more info."
+}
+
+src_unpack() {
+ # manually run unzip as the initial seek causes it to exit(1)
+ unpack_zip ${A}
+ rm lib*/lib{gcc_s,m,rt,selinux}.so.?
+}
+
+src_install() {
+ local b bb
+
+ doicon Shadowgrounds.xpm
+ for b in bin launcher ; do
+ bb="shadowgrounds-${b}"
+ exeinto ${d}
+ newexe ${bb} ${bb} || die
+ games_make_wrapper ${bb} "./${bb}" "${d}"
+ make_desktop_entry ${bb} "Shadowgrounds ${b}" Shadowgrounds
+ done
+
+ exeinto ${d}/lib32
+ doexe lib32/*
+
+ insinto ${d}
+ doins -r Config data Profiles *.fbz *.glade *-logo.png
+
+ prepgamesdirs
+}