summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-02-01 00:13:06 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-02-01 00:13:06 +0000
commit70673b109de2521acb98166c5ba4d5d85e372e58 (patch)
tree731896ce3256e31c180ac6202878b91a7054c99d /games-action/powermanga
parentversion bump wrt #393535 (diff)
downloadgentoo-2-70673b109de2521acb98166c5ba4d5d85e372e58.tar.gz
gentoo-2-70673b109de2521acb98166c5ba4d5d85e372e58.tar.bz2
gentoo-2-70673b109de2521acb98166c5ba4d5d85e372e58.zip
version bump wrt #452296
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-action/powermanga')
-rw-r--r--games-action/powermanga/ChangeLog11
-rw-r--r--games-action/powermanga/files/powermanga-0.91-flags.patch11
-rw-r--r--games-action/powermanga/files/powermanga-0.91-segfault.patch22
-rw-r--r--games-action/powermanga/files/powermanga-0.91-underlink.patch21
-rw-r--r--games-action/powermanga/powermanga-0.91.ebuild75
5 files changed, 138 insertions, 2 deletions
diff --git a/games-action/powermanga/ChangeLog b/games-action/powermanga/ChangeLog
index aba6f356f222..e2f894a6a5c9 100644
--- a/games-action/powermanga/ChangeLog
+++ b/games-action/powermanga/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-action/powermanga
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/ChangeLog,v 1.24 2012/08/24 06:59:11 mr_bones_ Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/ChangeLog,v 1.25 2013/02/01 00:13:06 hasufell Exp $
+
+*powermanga-0.91 (31 Jan 2013)
+
+ 31 Jan 2013; Julian Ospald <hasufell@gentoo.org> +powermanga-0.91.ebuild,
+ +files/powermanga-0.91-flags.patch, +files/powermanga-0.91-segfault.patch,
+ +files/powermanga-0.91-underlink.patch:
+ version bump wrt #452296
24 Aug 2012; Michael Sterrett <mr_bones_@gentoo.org> powermanga-0.90.ebuild:
any mod support will do
diff --git a/games-action/powermanga/files/powermanga-0.91-flags.patch b/games-action/powermanga/files/powermanga-0.91-flags.patch
new file mode 100644
index 000000000000..ca665add06cc
--- /dev/null
+++ b/games-action/powermanga/files/powermanga-0.91-flags.patch
@@ -0,0 +1,11 @@
+--- powermanga-0.91/configure.ac
++++ powermanga-0.91/configure.ac
+@@ -54,7 +54,7 @@
+ AC_DEFINE(USE_MALLOC_WRAPPER, 1, Define to use a malloc wrapper)
+ CFLAGS="-Wall -Werror -pedantic -Wextra -std=gnu99 -g"
+ else
+- CFLAGS="-O3 -Werror -Wall -pedantic -Wextra -std=gnu99"
++ CFLAGS="$CFLAGS -Wall -Wextra -std=gnu99"
+ fi
+
+ dnl Check for SDL_mixer
diff --git a/games-action/powermanga/files/powermanga-0.91-segfault.patch b/games-action/powermanga/files/powermanga-0.91-segfault.patch
new file mode 100644
index 000000000000..2413c8913a63
--- /dev/null
+++ b/games-action/powermanga/files/powermanga-0.91-segfault.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/show_bug.cgi?id=422915
+
+--- src/shots.c 2007-08-24 00:55:17.000000000 -0700
++++ src/shots.c 2011-12-26 21:10:28.000000000 -0800
+@@ -490,8 +490,6 @@
+ {
+ bullet->img_angle = (Sint16) (bullet->angle / PI_BY_16);
+ }
+- /* save current angle for the calculation of the next angle */
+- bullet->img_old_angle = bullet->img_angle;
+ /* avoid negative indexes */
+ bullet->img_angle = (Sint16) abs (bullet->img_angle);
+ /* avoid a shot angle higher than the number of images */
+@@ -499,6 +497,8 @@
+ {
+ bullet->img_angle = (Sint16) (bullet->spr.numof_images - 1);
+ }
++ /* save current angle for the calculation of the next angle */
++ bullet->img_old_angle = bullet->img_angle;
+ /* draw the shot sprite */
+ draw_sprite (bullet->spr.img[bullet->img_angle],
+ (Uint32) bullet->spr.xcoord,
diff --git a/games-action/powermanga/files/powermanga-0.91-underlink.patch b/games-action/powermanga/files/powermanga-0.91-underlink.patch
new file mode 100644
index 000000000000..ddede6970c94
--- /dev/null
+++ b/games-action/powermanga/files/powermanga-0.91-underlink.patch
@@ -0,0 +1,21 @@
+--- src/Makefile.am.old 2011-05-19 07:58:50.128783975 +0200
++++ src/Makefile.am 2011-05-19 07:58:55.639128359 +0200
+@@ -8,7 +8,7 @@
+ powermanga_CFLAGS = -DPREFIX=\"$(prefix)\" \
+ -DSCOREFILE=\"$(scoredir)/$(score)\" \
+ @XLIB_CFLAGS@ @SDL_CFLAGS@
+-powermanga_LDADD = @XLIB_LIBS@ @SDL_LIBS@
++powermanga_LDADD = @XLIB_LIBS@ @SDL_LIBS@ -lm
+
+ install-data-hook:
+ -chown root:games "$(DESTDIR)/$(gamesdir)/powermanga"
+--- src/images.c
++++ src/images.c
+@@ -31,6 +31,7 @@
+ #include "display.h"
+ #include "images.h"
+ #include "log_recorder.h"
++#include <zlib.h>
+
+ static char *bitmap_read (bitmap * bmp, Uint32 num_of_obj,
+ Uint32 num_of_images, char *addr,
diff --git a/games-action/powermanga/powermanga-0.91.ebuild b/games-action/powermanga/powermanga-0.91.ebuild
new file mode 100644
index 000000000000..23dd09f3b758
--- /dev/null
+++ b/games-action/powermanga/powermanga-0.91.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/powermanga-0.91.ebuild,v 1.1 2013/02/01 00:13:06 hasufell Exp $
+
+EAPI=5
+inherit eutils autotools games
+
+DESCRIPTION="An arcade 2D shoot-em-up game"
+HOMEPAGE="http://linux.tlk.fr/"
+SRC_URI="http://linux.tlk.fr/games/Powermanga/download/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libsdl-1.2[audio,joystick,video]
+ media-libs/libpng:0
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXxf86dga
+ media-libs/sdl-mixer[mod]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ local f
+ for f in src/assembler.S src/assembler_opt.S ; do
+ einfo "patching $f"
+ cat <<-EOF >> ${f}
+ #if defined(__linux__) && defined(__ELF__)
+ .section .note.GNU-stack,"",%progbits
+ #endif
+ EOF
+ done
+ epatch \
+ "${FILESDIR}"/${P}-underlink.patch \
+ "${FILESDIR}"/${P}-segfault.patch \
+ "${FILESDIR}"/${P}-flags.patch
+ sed -i \
+ -e "/scoredir/s#/var/games/powermanga#${GAMES_DATADIR}/powermanga#" \
+ src/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf --prefix=/usr
+}
+
+src_install() {
+ newgamesbin src/powermanga powermanga.bin
+ doman powermanga.6
+ dodoc AUTHORS CHANGES README
+
+ insinto "${GAMES_DATADIR}/powermanga"
+ doins -r data sounds graphics texts
+
+ find "${D}${GAMES_DATADIR}/powermanga/" -name "Makefil*" -execdir rm -f \{\} +
+
+ insinto "${GAMES_STATEDIR}"
+ local f
+ for f in powermanga.hi-easy powermanga.hi powermanga.hi-hard ; do
+ touch "${D}${GAMES_STATEDIR}/${f}" || die
+ fperms 660 "${GAMES_STATEDIR}/${f}"
+ done
+
+ games_make_wrapper powermanga powermanga.bin "${GAMES_DATADIR}/powermanga"
+ make_desktop_entry powermanga Powermanga
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ ewarn "NOTE: The highscore file format has changed."
+ ewarn "Older highscores will not be retained."
+}