summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-09-04 04:25:42 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-09-04 04:25:42 +0000
commit62edab3eec252036a5eddfec0ffece871aad5847 (patch)
tree63119d7a69fe69857303efa54cd656b31182848b /games-action/powermanga
parentamd64 stable (diff)
downloadgentoo-2-62edab3eec252036a5eddfec0ffece871aad5847.tar.gz
gentoo-2-62edab3eec252036a5eddfec0ffece871aad5847.tar.bz2
gentoo-2-62edab3eec252036a5eddfec0ffece871aad5847.zip
version bump
(Portage version: 2.1.2.12)
Diffstat (limited to 'games-action/powermanga')
-rw-r--r--games-action/powermanga/ChangeLog10
-rw-r--r--games-action/powermanga/files/digest-powermanga-0.903
-rw-r--r--games-action/powermanga/powermanga-0.90.ebuild72
3 files changed, 83 insertions, 2 deletions
diff --git a/games-action/powermanga/ChangeLog b/games-action/powermanga/ChangeLog
index c04bb6220c94..2175c62210ac 100644
--- a/games-action/powermanga/ChangeLog
+++ b/games-action/powermanga/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/powermanga
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/ChangeLog,v 1.11 2006/09/20 16:44:40 blubb Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/ChangeLog,v 1.12 2007/09/04 04:25:42 mr_bones_ Exp $
+
+*powermanga-0.90 (04 Sep 2007)
+
+ 04 Sep 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +powermanga-0.90.ebuild:
+ version bump
20 Sep 2006; <blubb@gentoo.org> powermanga-0.80.ebuild:
stable on amd64
diff --git a/games-action/powermanga/files/digest-powermanga-0.90 b/games-action/powermanga/files/digest-powermanga-0.90
new file mode 100644
index 000000000000..849da186953e
--- /dev/null
+++ b/games-action/powermanga/files/digest-powermanga-0.90
@@ -0,0 +1,3 @@
+MD5 0465ca49dc85e3943a06b3da7e0b92ad powermanga-0.90.tgz 11496484
+RMD160 8bc937fab37b267b26c18689450028d217cd002a powermanga-0.90.tgz 11496484
+SHA256 9537b99cdb860711612ce119a2da7b6f1407c1a2511cf056b0846dbf11b6ff0c powermanga-0.90.tgz 11496484
diff --git a/games-action/powermanga/powermanga-0.90.ebuild b/games-action/powermanga/powermanga-0.90.ebuild
new file mode 100644
index 000000000000..9465e0271909
--- /dev/null
+++ b/games-action/powermanga/powermanga-0.90.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/powermanga/powermanga-0.90.ebuild,v 1.1 2007/09/04 04:25:42 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="An arcade 2D shoot-em-up game"
+HOMEPAGE="http://linux.tlk.fr/"
+SRC_URI="http://linux.tlk.fr/games/Powermanga/download/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-0.11.0
+ media-libs/sdl-mixer"
+
+pkg_setup() {
+ if ! built_with_use media-libs/sdl-mixer mikmod ; then
+ eerror "${PN} needs sdl-mixer compiled with mikmod use-flag enabled!"
+ die "sdl-mixer without mikmod detected"
+ fi
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "/null/d" graphics/Makefile.in || die "sed failed"
+ sed -i -e "/zozo/d" texts/text_en.txt || die "sed failed"
+ local f
+ for f in src/assembler.S src/assembler_opt.S ; do
+ cat <<-EOF >> ${f}
+ #ifdef __ELF__
+ .section .note.GNU-stack,"",%progbits
+ #endif
+ EOF
+ done
+}
+
+src_compile() {
+ egamesconf --prefix=/usr || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin powermanga || die "dogamesbin failed"
+ doman powermanga.6
+ dodoc AUTHORS CHANGES README
+
+ insinto "${GAMES_DATADIR}/powermanga"
+ doins -r data sounds graphics texts || die "doins failed"
+
+ find "${D}${GAMES_DATADIR}/powermanga/" -name "Makefil*" -exec rm -f \{\} \;
+
+ insinto /var/games
+ local f
+ for f in powermanga.hi-easy powermanga.hi powermanga.hi-hard ; do
+ touch "${D}/var/games/${f}" || die "touch ${f} failed"
+ fperms 660 "/var/games/${f}" || die "fperms ${f} failed"
+ done
+
+ make_desktop_entry powermanga Powermanga
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ ewarn "NOTE: The highscore file format has changed."
+ ewarn "Older highscores will not be retained."
+}