summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-05 17:39:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-05 17:39:11 +0000
commit9aec5955102c4d950a3707f073a75ca91c176dbc (patch)
tree9fb005fad4c2f3350d635924b58029afc35ce0b5 /games-action/luola
parentStable for HPPA (bug #252607). (diff)
downloadgentoo-2-9aec5955102c4d950a3707f073a75ca91c176dbc.tar.gz
gentoo-2-9aec5955102c4d950a3707f073a75ca91c176dbc.tar.bz2
gentoo-2-9aec5955102c4d950a3707f073a75ca91c176dbc.zip
EAPI=2 and avoid using PATCHES variable
(Portage version: 2.1.6.4/cvs/Linux 2.6.27.8 i686)
Diffstat (limited to 'games-action/luola')
-rw-r--r--games-action/luola/ChangeLog8
-rw-r--r--games-action/luola/luola-1.3.0-r1.ebuild25
2 files changed, 18 insertions, 15 deletions
diff --git a/games-action/luola/ChangeLog b/games-action/luola/ChangeLog
index d00a32482f2d..fd0a894aea1b 100644
--- a/games-action/luola/ChangeLog
+++ b/games-action/luola/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/luola
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/luola/ChangeLog,v 1.9 2006/11/27 01:24:39 blubb Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/luola/ChangeLog,v 1.10 2009/01/05 17:39:11 mr_bones_ Exp $
+
+ 05 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ luola-1.3.0-r1.ebuild:
+ EAPI=2 and avoid using PATCHES variable
27 Nov 2006; <blubb@gentoo.org> luola-1.3.0-r1.ebuild:
stable on amd64
diff --git a/games-action/luola/luola-1.3.0-r1.ebuild b/games-action/luola/luola-1.3.0-r1.ebuild
index 5ba04b3c8eb6..8eecf19e57d2 100644
--- a/games-action/luola/luola-1.3.0-r1.ebuild
+++ b/games-action/luola/luola-1.3.0-r1.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/luola/luola-1.3.0-r1.ebuild,v 1.2 2006/11/27 01:24:39 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/luola/luola-1.3.0-r1.ebuild,v 1.3 2009/01/05 17:39:11 mr_bones_ Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="A 2D multiplayer arcade game resembling V-Wing"
HOMEPAGE="http://luolamies.org/software/luola/"
-PATCHES="http://luolamies.org/software/luola/luola-1.3.0-1.patch
+PATCH_SET="http://luolamies.org/software/luola/luola-1.3.0-1.patch
http://luolamies.org/software/luola/luola-1.3.0-2.patch"
SRC_URI="http://luolamies.org/software/luola/${P}.tar.gz
- http://www.luolamies.org/software/luola/stdlevels-5.2.tar.gz
- http://www.luolamies.org/software/luola/nostalgia-1.1.tar.gz
- ${PATCHES}"
+ http://www.luolamies.org/software/luola/stdlevels-6.0.tar.gz
+ http://www.luolamies.org/software/luola/nostalgia-1.2.tar.gz
+ ${PATCH_SET}"
LICENSE="GPL-2"
SLOT="0"
@@ -24,24 +25,22 @@ DEPEND="media-libs/libsdl
media-libs/sdl-mixer
media-libs/sdl-ttf"
-src_unpack() {
+src_prepare() {
local p
- unpack ${A}
cd "${S}/src"
- for p in ${PATCHES}
+ for p in ${PATCH_SET}
do
epatch "${DISTDIR}/${p##*/}"
done
}
-src_compile() {
- egamesconf --enable-sound || die
- emake || die "emake failed"
+src_configure() {
+ egamesconf --enable-sound
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
insinto "${GAMES_DATADIR}"/${PN}/levels
doins "${WORKDIR}"/*.{lev,png} || die "doins failed"
dodoc AUTHORS ChangeLog DATAFILE FAQ LEVELFILE README TODO \