summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-11-04 05:36:43 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-11-04 05:36:43 +0000
commit4499d07ae403f5c1fc01eb2712d1862a36a84f40 (patch)
treebc08af4970884644a018a9d51a87df45572c41b5 /games-action/heroes
parentpatches as per bug #144008 thanks to Carsten. old versions removed (diff)
downloadgentoo-2-4499d07ae403f5c1fc01eb2712d1862a36a84f40.tar.gz
gentoo-2-4499d07ae403f5c1fc01eb2712d1862a36a84f40.tar.bz2
gentoo-2-4499d07ae403f5c1fc01eb2712d1862a36a84f40.zip
Add nls dependencies
(Portage version: 2.1.2_rc1-r3)
Diffstat (limited to 'games-action/heroes')
-rw-r--r--games-action/heroes/ChangeLog5
-rw-r--r--games-action/heroes/heroes-0.21-r1.ebuild32
2 files changed, 26 insertions, 11 deletions
diff --git a/games-action/heroes/ChangeLog b/games-action/heroes/ChangeLog
index 8cf42f588285..b9603c6bd914 100644
--- a/games-action/heroes/ChangeLog
+++ b/games-action/heroes/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/heroes
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/heroes/ChangeLog,v 1.13 2006/09/20 12:26:36 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/heroes/ChangeLog,v 1.14 2006/11/04 05:36:43 nyhm Exp $
+
+ 04 Nov 2006; Tristan Heaven <nyhm@gentoo.org> heroes-0.21-r1.ebuild:
+ Add nls dependencies
20 Sep 2006; Danny van Dyk <kugelfang@gentoo.org> heroes-0.21-r1.ebuild:
Marked stable on amd64 wrt bug #148335.
diff --git a/games-action/heroes/heroes-0.21-r1.ebuild b/games-action/heroes/heroes-0.21-r1.ebuild
index d0a4c191fa25..ed685842db0a 100644
--- a/games-action/heroes/heroes-0.21-r1.ebuild
+++ b/games-action/heroes/heroes-0.21-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/heroes/heroes-0.21-r1.ebuild,v 1.6 2006/09/20 12:26:36 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/heroes/heroes-0.21-r1.ebuild,v 1.7 2006/11/04 05:36:43 nyhm Exp $
inherit eutils games
@@ -20,22 +20,27 @@ SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
IUSE="sdl nls ggi"
-DEPEND="nls? ( sys-devel/gettext )
+RDEPEND="nls? ( virtual/libintl )
sdl? ( media-libs/libsdl media-libs/sdl-mixer )
ggi? ( media-libs/libggi media-libs/libgii media-libs/libmikmod )
!sdl? ( !ggi? ( media-libs/libsdl media-libs/sdl-mixer ) )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
S=${WORKDIR}
src_unpack() {
unpack ${A}
- cd ${WORKDIR}/${P}
- epatch ${FILESDIR}/${PV}-cvs-segfault-fix.patch #56118
+ cd "${WORKDIR}"/${P}
+ epatch "${FILESDIR}"/${PV}-cvs-segfault-fix.patch #56118
epatch "${FILESDIR}/${P}"-gcc4.patch
+ sed -i 's:$(localedir):/usr/share/locale:' \
+ $(find . -name 'Makefile.in*') \
+ || die "sed failed"
}
src_compile() {
- local myconf="--disable-heroes-debug $(use_enable nls)"
+ local myconf
if use sdl || ! use ggi ; then
myconf="${myconf} --with-sdl --with-sdl-mixer"
@@ -43,17 +48,24 @@ src_compile() {
myconf="${myconf} --with-ggi --with-mikmod"
fi
+ local pkg
for pkg in ${A//.tar.bz2} ; do
- cd ${S}/${pkg}
- egamesconf ${myconf}
- make || die "unable to compile ${pkg}"
+ cd "${S}"/${pkg}
+ egamesconf \
+ --disable-heroes-debug \
+ --disable-optimizations \
+ $(use_enable nls) \
+ ${myconf} \
+ || die
+ emake || die "unable to compile ${pkg}"
done
}
src_install() {
+ local pkg
for pkg in ${A//.tar.bz2} ; do
- cd ${S}/${pkg}
- make DESTDIR=${D} install || die
+ cd "${S}"/${pkg}
+ emake DESTDIR="${D}" install || die "emake install failed"
done
prepgamesdirs
}