summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-10-24 22:08:54 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-10-24 22:08:54 +0000
commitd4046f5466e48f9b7458c0a166a678feeec216b2 (patch)
tree6eb7339757d752ecf1a5d85571b1a6392625aa4e /games-action/heretic2
parentBug 152049, missing dep on media-libs/jpeg. Thanks ECP (diff)
downloadgentoo-2-d4046f5466e48f9b7458c0a166a678feeec216b2.tar.gz
gentoo-2-d4046f5466e48f9b7458c0a166a678feeec216b2.tar.bz2
gentoo-2-d4046f5466e48f9b7458c0a166a678feeec216b2.zip
Moved cdrom_get_cds to src_unpack since binary packages don't require the original media to install as well as some general cleanup.
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'games-action/heretic2')
-rw-r--r--games-action/heretic2/ChangeLog6
-rw-r--r--games-action/heretic2/heretic2-1.06c.ebuild21
2 files changed, 14 insertions, 13 deletions
diff --git a/games-action/heretic2/ChangeLog b/games-action/heretic2/ChangeLog
index 30915eda9f2e..bf976c1f58ef 100644
--- a/games-action/heretic2/ChangeLog
+++ b/games-action/heretic2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/heretic2
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/heretic2/ChangeLog,v 1.1 2006/10/03 22:32:24 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/heretic2/ChangeLog,v 1.2 2006/10/24 22:08:54 wolf31o2 Exp $
+
+ 24 Oct 2006; Chris Gianelloni <wolf31o2@gentoo.org> heretic2-1.06c.ebuild:
+ Moved cdrom_get_cds to src_unpack since binary packages don't require the
+ original media to install as well as some general cleanup.
*heretic2-1.06c (03 Oct 2006)
diff --git a/games-action/heretic2/heretic2-1.06c.ebuild b/games-action/heretic2/heretic2-1.06c.ebuild
index fac144c81b3c..5ec4160d32b4 100644
--- a/games-action/heretic2/heretic2-1.06c.ebuild
+++ b/games-action/heretic2/heretic2-1.06c.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/heretic2/heretic2-1.06c.ebuild,v 1.1 2006/10/03 22:32:24 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/heretic2/heretic2-1.06c.ebuild,v 1.2 2006/10/24 22:08:54 wolf31o2 Exp $
inherit eutils games
@@ -24,13 +24,11 @@ RDEPEND="virtual/opengl"
S=${WORKDIR}
GAMES_CHECK_LICENSE="yes"
-
-pkg_setup() {
- games_pkg_setup
- cdrom_get_cds bin/x86/glibc-2.1/${PN}
-}
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
src_unpack() {
+ cdrom_get_cds bin/x86/glibc-2.1/${PN}
mkdir ${A}
local f
@@ -42,7 +40,6 @@ src_unpack() {
src_install() {
cd "${CDROM_ROOT}"
- local dir=${GAMES_PREFIX_OPT}/${PN}
insinto "${dir}"
doins -r base help Manual.html README README.more || die "doins failed"
@@ -50,11 +47,11 @@ src_install() {
exeinto "${dir}"
doexe bin/x86/glibc-2.1/${PN} || die "doexe failed"
- games_make_wrapper ${PN} ./${PN} "${dir}" .
+ games_make_wrapper ${PN} ./${PN} "${dir}" "${dir}"
newicon icon.xpm ${PN}.xpm
make_desktop_entry ${PN} "Heretic II" ${PN}.xpm
- cd "${D}/${dir}"
+ cd "${Ddir}"
ln -s "${CDROM_ROOT}"/*.gz .
unpack ./*.gz
rm -f *.gz
@@ -62,12 +59,12 @@ src_install() {
local d
for d in "${S}"/* ; do
cd "${d}"
- loki_patch patch.dat "${D}/${dir}" || die "loki_patch ${d} failed"
+ loki_patch patch.dat "${Ddir}" || die "loki_patch ${d} failed"
done
- rmdir "${D}/${dir}"/gl_drivers
+ rmdir "${Ddir}"/gl_drivers
sed -i '128i set gl_driver "/usr/lib/libGL.so"' \
- "${D}/${dir}"/base/default.cfg || die "sed failed"
+ "${Ddir}"/base/default.cfg || die "sed failed"
prepgamesdirs
}