summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-05-07 06:30:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-05-07 06:30:17 +0000
commit74df286bd1d99f2f06bf552f8dc70347652f6687 (patch)
tree0ee7db11ca2883846b22a799ad294b7ae61c5994 /games-action/dungeon
parentMove CFLAGS filtering stuff inside of src_unpack (Manifest recommit) (diff)
downloadgentoo-2-74df286bd1d99f2f06bf552f8dc70347652f6687.tar.gz
gentoo-2-74df286bd1d99f2f06bf552f8dc70347652f6687.tar.bz2
gentoo-2-74df286bd1d99f2f06bf552f8dc70347652f6687.zip
don't rdepend on sed
Diffstat (limited to 'games-action/dungeon')
-rw-r--r--games-action/dungeon/ChangeLog7
-rw-r--r--games-action/dungeon/dungeon-3.2.3.ebuild20
2 files changed, 18 insertions, 9 deletions
diff --git a/games-action/dungeon/ChangeLog b/games-action/dungeon/ChangeLog
index fe51d0f4c733..24df5c43f298 100644
--- a/games-action/dungeon/ChangeLog
+++ b/games-action/dungeon/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/dungeon
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/dungeon/ChangeLog,v 1.2 2003/09/10 20:28:22 vapier Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/dungeon/ChangeLog,v 1.3 2004/05/07 06:30:17 mr_bones_ Exp $
+
+ 06 May 2004; Michael Sterrett <mr_bones_@gentoo.org> dungeon-3.2.3.ebuild:
+ don't rdepend on sed; error check emake; tidy
*dungeon-3.2.3 (10 Jul 2003)
diff --git a/games-action/dungeon/dungeon-3.2.3.ebuild b/games-action/dungeon/dungeon-3.2.3.ebuild
index 5584eac895a6..5a1f57ae1ac7 100644
--- a/games-action/dungeon/dungeon-3.2.3.ebuild
+++ b/games-action/dungeon/dungeon-3.2.3.ebuild
@@ -1,17 +1,21 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/dungeon/dungeon-3.2.3.ebuild,v 1.2 2004/02/20 06:13:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/dungeon/dungeon-3.2.3.ebuild,v 1.3 2004/05/07 06:30:17 mr_bones_ Exp $
inherit games
DESCRIPTION="A linux port of the Dungeon game once distributed by DECUS"
HOMEPAGE="http://www.ibiblio.org/linsearch/lsms/dungeon-3.2.3.html"
SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/games/textrpg/${P}.src.tar.gz"
+
LICENSE="as-is"
SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="dev-lang/f2c
+
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND}
+ dev-lang/f2c
>=sys-apps/sed-4"
S="${WORKDIR}/dungn32c"
@@ -21,7 +25,9 @@ DATS="${GAMES_DATADIR}/${PN}"
src_unpack() {
unpack ${A}
cd ${S}
- sed -i -e "s:-O:${CFLAGS}:g" Makefile || die "sed Makefile failed"
+ sed -i \
+ -e "s:-O:${CFLAGS}:g" Makefile \
+ || die "sed Makefile failed"
}
src_compile() {
@@ -31,14 +37,14 @@ src_compile() {
-e "s:ofnmlen = [^;]+:&+${#DATS}+1:g" \
game.c || die "sed game.c failed"
- emake || die
+ emake || die "emake failed"
}
src_install() {
- dogamesbin dungeon
- insinto ${DATS}
+ dogamesbin dungeon || die "dogamesbin failed"
+ insinto "${DATS}"
doins dindx.dat dtext.dat
- doman ${FILESDIR}/dungeon.6
+ doman "${FILESDIR}/dungeon.6"
dodoc README *.txt *.doc
prepgamesdirs
}